New Release and Beta FW Updates

Log submitted as requested: 344189

However, I am not sure how to flash the VDB Back. Can you do that? I will try to update it again to see if I can get it working.

1 Like

Another log report from another VDB that is having same issues as original poster. Log 344290

Don’t mean to hijack this topic but figured this isn’t a one off issue. More logs the better?


I tried connecting using an iPhone instead of my Android. On the iPhone, I am getting stuck at step 1 authenticating, Connecting…If I kill the Wyze app, it comes back with error code 90, device offline. However, I am having all the same issues. VoIP works, events get triggered but no notifications. I can’t load the event. The VDB shows in my network. I’ve cycled the power to the doorbell and my router and still no luck. The doorbell was working fine before I updated the firmware. I submitted another log from the iPhone: 344847. @spamoni4 sorry for adding onto your thread, but we are having identical issues. Have you heard back from Wyze on downgrading the firmware?


No problem at all, the more we can provide Wyze the better it is.

Glad I am not the only one having issues. I realize now how much I liked having the Doorbell there and relied on it. :slight_smile:

If I knew how to roll back the FW on the VDB, I would try that. I know it is responding and on my network because when I reset it, you see it change to Yellow and then blue. Just never stops flashing Blue.

I am going to go to Home Depot and but an additional Doorbell later today. :slight_smile:

1 Like

Yah I just ordered another one just in case. I’ll keep watching this topic, not sure what else I can really do. Bummed that the firmware killed the doorbell for me (well in the app at least)

1 Like

Did you order the same or the new Doorbell? Not sure I like the Fish eye approach. But do like it being 5Ghz

Same. New doorbell not available to Canadians yet

1 Like

I ended up getting another Doorbell from Home Depot as I found that I was actually more attached to it than I thought. I did the setup in my house first and made sure it was working, then I proceeded to do the Beta Update while holding my breath, and when completed it was still working. So now I have a functional doorbell and the broken one is hooked up in my house to see how ee can fix it.

I realize that at times a beta release of Firmware could cause issues, but this was a weird one as everything was still working except being able to connect to it or playing back the video. The Doorbell thought it was not connected, but it was.

For your setup, did you connect power via the USB? And then shifted it to your wired location after?

Yes, I set it up in the house via USB. Not recommended and could Void Warranties. However, I put the sticky covering back on and then hooked it up via the Doorbell wires.

I now have the old one, which need to be updated, in the house on USB. Still pulsating Blue.

OK, good to know, My 2nd one comes Saturday. I’m hoping that @WyzeBaohua
gets something back from the VDB manager on this. Sucks that the beta firmware more or less bricked the VDB but didn’t brick it. I’m seeing same thing as you, flashing blue, but everything “seems” to work except connecting to Wyze and the app.

1 Like

Yea, I find that intersting as well. I have foind that @WyzeBaohua does a great job following through. Not sure who the VDB PM is on this, hopefully we will here soon.

This is the first time that I ran into something I could not fix. Contemplating pushing the reset button on the back to see if I can add it again. Bit also don’t want to cause issues for Wyze when and if they want to test something.

I enrolled in the beta firmware testing. Today wyze released new firmware for the doorbell (not pro). I updated it and the doorbell bricked. It starts solid yellow light for few seconds and then turns off.

Can anyone suggest how to flash it with older firmware via the usb in the back?

Please help

I think @spamoni4 experienced something similar and has spoken with Wyze employees about something similar happening to him with new firmware too. Perhaps he’ll chime in about his findings or what support is looking into with it.

Worst case scenario you could try contacting support as you should still be covered under warranty since the doorbell is new enough. Hopefully they can somehow revert it to a different firmware to function normally again.


A few of us experienced the same issue. Here is the topic where it is being discussed:

Received a DM from Wyze that they have sufficient logs and are working on a Firmware fix. Mine and others Doorbells are not bricked, we simply cannot connect to them. They still show up on our routers and if you ring them Alexa Announces and the VoIP process will call you, if you have the VoIP option.


Thanks for helping out buddy. I couldn’t remember where the public thread about this was, I just knew that you were very much in the know about what was going on. :wink: And thanks Jason for merging.


That’s good news that they are working on a firmware fix. I’m guessing we will need to apply it via the USB as the doorbells will not connect to the app which is the usual way of deploying firmware. Keep us updated on what you hear back. @WyzeBaohua I’m also available to try the firmware fix if you need more testing as I am having identical issues as @spamoni4


Sorry for the trouble from the Doorbell beta firmware. We are working on fixing it.


Is there any reason why the .267 firmware can’t be released? We’ve had people asking for the voice response fix for awhile now.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.