New Release and Beta FW Updates

@WyzeBaohua @QiS - Any help on this would be appreciated.

if you can provide a bit of help. Submitted Log: 344054 For the VDB issue.

Running Android 12 Pixel 6
Adroid Wyze App Version: 2.25.31

So I did the latest updates as indicated in the following Topic.

Everything seemed to update ok. The Following was updated:

  • V3 Camera’s
  • V2 Camera’s
  • WCO + Base
  • HMS
  • VDB version 1

However, I cannot connect to the VDB now. Did a restart of the VDB to no avail. Also, not sure what the HMS or V2 Camera updates provided as I have not seen any reference to it.


I just doisconnected the VDB from the Transformer and plugged it back in, wanted it to do a full refresh. However, he is what I am experiencing:

  • Cannot connect to the VDB via the app, never gets by step 1

  • Light on the front of the VDB is blinking blue. However here is the weird things about it:

    • When I walk in front of the VDB it sees me and starts blinking white
    • When I ring the VDB, my phone rings as I have VoIP turned on
    • When I ring the VDB, Alexa announces tha there is someone at the Front Door - so the Alexa problem has been resolved.

You just cannot connect via the app.


Sorry for the trouble. Did you see any error code when connecting the VDB? Did the livestream connection fail every time after updating it to


No error code. Installation was successful.

I restarted it, unplugged it, and even brought it in the house hooked it up to USB to see and no luck.

I can provide my Mac Address if needed. Is it possible for you to push a FW version to it to see if it works again?

Also to answer your question, Yes ever time I cannot get by step 1 of the connection process. Worked perfectly until now. :slight_smile:

Here is an image:


That’s interesting, I was going to try and replicate this for you but I don’t have an update showing for my doorbell. I have all the other updates V3 and pan V2 and such after the app update today but nothing for the doorbell

Is it selected in the Beta Menu under About? Maybe it is not selected.

Here is an interesting thing. It is connected to my network, I can reset it via the app, the Video’s do get recorded and then shows up in the events tab, Alexa now works and announces, VoIP still works and rings my phone and the chime works.

I would like to roll back to a previous version of the FW and try again. Not sure how to do this though. Any idea how to do roll back FW for the VDB? @WyzeBaohua , is it possible for you all to push a FW version to the VDB? I know it is on the network.

I even disconnected power, brought it in the house, hooked up via USB still no luck.

You think I should remove my MAC Address… :slight_smile: - I did Remove it


Let me create a bug for this one and ping the VDB product manager about this. Could you please submit an other log before flashing back to the previous firmware? Thanks a lot.

1 Like

Log submitted as requested: 344189

However, I am not sure how to flash the VDB Back. Can you do that? I will try to update it again to see if I can get it working.

1 Like

Another log report from another VDB that is having same issues as original poster. Log 344290

Don’t mean to hijack this topic but figured this isn’t a one off issue. More logs the better?


I tried connecting using an iPhone instead of my Android. On the iPhone, I am getting stuck at step 1 authenticating, Connecting…If I kill the Wyze app, it comes back with error code 90, device offline. However, I am having all the same issues. VoIP works, events get triggered but no notifications. I can’t load the event. The VDB shows in my network. I’ve cycled the power to the doorbell and my router and still no luck. The doorbell was working fine before I updated the firmware. I submitted another log from the iPhone: 344847. @spamoni4 sorry for adding onto your thread, but we are having identical issues. Have you heard back from Wyze on downgrading the firmware?


No problem at all, the more we can provide Wyze the better it is.

Glad I am not the only one having issues. I realize now how much I liked having the Doorbell there and relied on it. :slight_smile:

If I knew how to roll back the FW on the VDB, I would try that. I know it is responding and on my network because when I reset it, you see it change to Yellow and then blue. Just never stops flashing Blue.

I am going to go to Home Depot and but an additional Doorbell later today. :slight_smile:

1 Like

Yah I just ordered another one just in case. I’ll keep watching this topic, not sure what else I can really do. Bummed that the firmware killed the doorbell for me (well in the app at least)

1 Like

Did you order the same or the new Doorbell? Not sure I like the Fish eye approach. But do like it being 5Ghz

Same. New doorbell not available to Canadians yet

1 Like

I ended up getting another Doorbell from Home Depot as I found that I was actually more attached to it than I thought. I did the setup in my house first and made sure it was working, then I proceeded to do the Beta Update while holding my breath, and when completed it was still working. So now I have a functional doorbell and the broken one is hooked up in my house to see how ee can fix it.

I realize that at times a beta release of Firmware could cause issues, but this was a weird one as everything was still working except being able to connect to it or playing back the video. The Doorbell thought it was not connected, but it was.

For your setup, did you connect power via the USB? And then shifted it to your wired location after?

Yes, I set it up in the house via USB. Not recommended and could Void Warranties. However, I put the sticky covering back on and then hooked it up via the Doorbell wires.

I now have the old one, which need to be updated, in the house on USB. Still pulsating Blue.

OK, good to know, My 2nd one comes Saturday. I’m hoping that @WyzeBaohua
gets something back from the VDB manager on this. Sucks that the beta firmware more or less bricked the VDB but didn’t brick it. I’m seeing same thing as you, flashing blue, but everything “seems” to work except connecting to Wyze and the app.

1 Like

Yea, I find that intersting as well. I have foind that @WyzeBaohua does a great job following through. Not sure who the VDB PM is on this, hopefully we will here soon.

This is the first time that I ran into something I could not fix. Contemplating pushing the reset button on the back to see if I can add it again. Bit also don’t want to cause issues for Wyze when and if they want to test something.

I enrolled in the beta firmware testing. Today wyze released new firmware for the doorbell (not pro). I updated it and the doorbell bricked. It starts solid yellow light for few seconds and then turns off.

Can anyone suggest how to flash it with older firmware via the usb in the back?

Please help

I think @spamoni4 experienced something similar and has spoken with Wyze employees about something similar happening to him with new firmware too. Perhaps he’ll chime in about his findings or what support is looking into with it.

Worst case scenario you could try contacting support as you should still be covered under warranty since the doorbell is new enough. Hopefully they can somehow revert it to a different firmware to function normally again.