Location trigger

I use a location trigger rule to turn on cam motion detection when I exit the area, and turn it off when I enter the area. It worked great for a while but lately it only triggers when I exit but not when I enter the area.

Its very reliable on triggering when I exit but only triggers about 1 in 10 times when I enter.

Is anyone else having problems with this rule?

1 Like

I was helping another user with the same issue and set location triggers on my notifications. The location services for rules did not seem to be working at that time.

However, there was an app update yesterday. I have not been able to test this from within the new Android app update yet. Here is my post explaining my difficulties to a user who was experiencing the same issues.

1 Like

My location rules are working, maybe try again? Could have been a small outage.

Same , another user in the discord mentioned it too and I thought I was going crazy

I have a location trigger to turn on both my living room lamp bulb and my bedroom floor lamp bulb when I get home . Both failed to turn on , I got home and both were Off

I also set up a rule to turn off the floor lamp in my room when I leave my house and it failed to do so as well

In the rules history it doesn’t show anything but the rules been set .

Seems to be acting funny lately … especially after this latest app update

1 Like

Location based rules seem to be somewhat hit-or-miss. I was having problems with Wyze rules so I setup some on SmartThings to send a message when I left or arrived home. Sometimes Wyze works and SmartThings doesn’t. Sometimes it’s the other way around. Other times, neither works or both work.

I have an iPhone, but I’m sure there are similar problems with Android. Just seems to be an overall issue with location services in general across applications.


All my location triggers have stopped working. I had various lights set to turn on as I approach home and my lock is set to auto-unlock when I get home, but nothing works anymore. I had a help ticket and did everything suggested by support but still nothing works. It’s very frustrating as it worked seamlessly before and all of a sudden it stopped working.

1 Like

Make sure you have location permission set to always for the app.

My location trigger rule has worked flawlessly for the past 3 days coming and going. But thats the way it has been going for the past few weeks. It work ok for a time and then wont work.

For me it always works leaving. My problem is entering the are and getting it to trigger when it should.

There have been multiple reports of location triggers for rules not working recently. I created several rules with location triggers to test and none of them triggered the rule to execute.

I do not regularly use location rules, so it has not been a priority for me to investigate as I only used them for testing purposes.

If the Location Services trigger rules are not working, My suggestion would be to post it on the September Fix-It Friday topic that will be coming out at the begining of the month to report the function as not operating. That should get it on the radar.

1 Like

This has become a pet peeve of mine…why should everyone need to ask to have a bug/problem fixed and hope that Wyze sees fit to do something? Shouldn’t Wyze be focused on fixing all of them? Are there so many, due to poor programming, that they don’t have the staff to fix things that are broken AND put out new products?

This is just a constant annoyance to me. Rant over.

1 Like

Mine stopped working today

I feel your pain, really I do. I have also voiced my opinion for a better way to capture bugs and track them… as many have.

But please trust me when I say Wyze is aware of this and they ARE listening! A better way is on their minds and is being discussed. But, with any change there are hurdles and barriers that need to be overcome.

Right now… This is the best we have and it is better than when there was no monthly sounding board.

1 Like

Update… Location trigger rule has been working reliably for a couple of weeks now both coming and going.

1 Like

That is great to hear. It looks like they connected the right wires on the server then.

Anyone having this issue again or just now? I recently bought into the ecosystem but can’t get this to work

Welcome to the Wyze User Community Forum @jonmy2x4! :raising_hand_man:

Share some details about how you are trying to employ it. I’m sure someone here might have some ideas or pointers. If not, we can always try and duplicate it by testing.

I had a lot of trouble with it at various times last year but lately it has been working pretty good. Just an occasional hick up maybe once a month.

fair point - for context i’m using a pixel 6pro, latest wyze app version, and have several cameras i’m trying to have trigger on exit from my location and then trigger again upon arrival (though i’ve only tested the former so far since if the former doesn’t work the latter is pointless)

I should say my trigger is for motion detection off/on when enter/exit the area as opposed to the other options like camera on/off etc. I am using an ancient Note 9.

My location trigger problem is back.

It works ok for a time and then wont work.

For me it always works leaving. My problem is entering the area.

Just not a very reliable system.