Do location-based rules work at all?

I’ve never seen a location-based rule work EVER. Should it?

I have location services setting for Wyze app is set to ALWAYS.

My geofence is set to 1500 ft, way more than enough to include my home. I want notifications to be turned off when I come home, that’s all I’m going for right now.

The rule seems simple enough. When I enter the location, turn off notifications, nothing more. This action fails on both v2 and v3 cams 100% of the time, almost as if I’m doing something wrong.

What should I expect from Wyze in this regard? I’ve read that this feature is just a “pilot” (hey here’s a thought just call it what it is, “beta or worse,” you’ll get more respect) but does it literally not work at all? I would prefer that the entire functionality be hidden in the app in this case – stop tempting me.

I’m totally good with having done something stupid here – but what? (and don’t say “buying Wyze” – I can come to that conclusion on my own if needed).

They do work for others.

Will you submit a log? Go to Account Tab → Wyze Support → Submit a Log → Wyze App & Services → Rules

Leave a description about the issue. Then post the reference number in here, and we’ll see if @QiS will look into it and see if they can tell why your location rules aren’t working for you.

1 Like

Thank you @carverofchoice . Submitted, Log ID = 495691.

1 Like

Hi @jeglin sorry for this inconvenience. We’ll look into this issue.

1 Like

Hi @jeglin we checked the log. It seems you have been inside the geofence and have not left the range.
Could you recall if you left your home more than 1500ft? If yes, we’ll dive deep into the geofence feature.

1 Like

Yes, that’s how it works. I’m at my computer and with my phone and was asked to submit a log. While I am doing a log submission, I am sitting in one location that happens to be inside the geofence.

I don’t understand your question. If you want me to do something different than send you a log while I’m with my phone then please specify.

FWIW, I have crossed the geofence line many many time (left the location and also returned to the location. Never once have the notifications stopped.

Dr J

@carverofchoice thanks for the help you provided here. WyzeQi’s response was highly scripted and resulted in “wait for the next update” (without indicating whether the update will even address location based rules). I’m disappointed but I appreciate the volunteers on this forum.

I think it’s partially that it’s the weekend currently. There is typically less interaction from the employees over the weekend.

If you happen to leave the geofence again over the weekend try to make a note of roughly what time you were outside the zone, and post it here (preferably with a new log). That way he can narrow it down to exactly when he knows it should’ve run. Might make it easier to help resolve this. I’ve had pretty good luck with Qsun figuring things out for me in the past related to testing the rules, which is why I called them in here for this.

Something else that came to mind while I was thinking about your situation, do have the Wyze app on more than one device (a tablet, an emulator on a computer, a second phone, etc)? Is it possible that a secondary Wyze app thinks it is still at home even though your primary phone leaves the boundary? I ask because I do this…and it could be a possible explanation we can look into options for. For example, for me, I just had to tell the app on my other devices not to allow them to use the devices’ location, and it solved some of my similar issues. Anyway, I am guessing this isn’t applicable to you, but wanted to ask just in case.

Hopefully, you’ll get a chance to log some times when you were clearly away.
If WyzeQi DM’d you to wait for the next update, that sounds like confirmation that there is something coming that should be making improvements. There is a new version being beta-tested as we speak (I’m currently using it, so maybe that’s why I am not having the same issues as you), so I expect it will be launched really soon. When it does, Let me know if you’re still having issues so we can have it looked into and confirm things better.

1 Like

You can also check the rule history to see if the rule triggered.


@WildBill thanks for that tip – I didn’t know that I could look at the history – that at least gives me a way to do some real-time testing.

@carverofchoice excellent point – in fact I do have Wyze on other apps, just because I may want to check cameras with those devices instead of my phone. I’ll need to investigate this.

Here’s another point: the app works literally on an exit and entrance of the geofence, according to a literal reading of the interface and the instructions. As per Wyze support, the app does not continually check location to test the rule. But just how often DOES it check? Every 50 sec? Every 50 min? Right now I’m testing by driving up and down the street to simulate “leaving my house.” IMO the app /must/ check on a regular basis, which means this rule should not be entrance/exit but pure location based. No one expects it to check once a sec, but maybe this should be a UI option because everyone may have different needs.

Another suggestion was to change the geofence to 500 feet. I did that and got ONE entrance logged – woohoo. And no more entrances or exits after that. Then I changed it to 666 ft bc why not. I got two exits logged and no more entrances. It’s too painful to try to find a magic fence that will always work.

So the first takeaway is that it does work under some unknown set of conditions. It’s also possible that it works under some unknown /changing/ set of conditions – change the fence boundary and the app wakes up for a while before ignoring the location again?

None of this is repeatable as far as I can tell. With regard to my other devices, they are housebound. If they were interfering, then I still should not get random successes; however, I will definitely check this idea. Unfortunately I’ll be off-line for a couple of days.

1 Like

I had a lot of problems when I was running the app on my iPhone and iPad. I finally set the iPad to allow location only while using the app and then made sure to exit it.

I have my fence set at 500ft which is as low as I can get it. I take my iPhone when I go out and the location service works most of the time. Using something similar with SmartThings and it seems more reliable.

1 Like

Hi, @jeglin Thank you for providing these details. Could you send me the rule name, submit a log and send me this id? We need this information to find the root cause.

1 Like

I can confirm that location services aren’t working properly. Left my home with my iPhone and went way beyond my 500ft limit but location rules for home and away never triggered. No other devices running the Wyze app at the time.


@WildBill thank you for your feedback. We’re working on improving the geofence stability.


Update on my situation.

As per @carverofchoice 's recommendation, I carefully reviewed my devices with Wyze installed on them: 4 total. On 3 I made sure to turn off location services entirely for Wyze and then killed the app to make sure it wasn’t running, leaving my primary device, an iPhone X, as my Wyze controller. This led immediately to a successful exit and entrance to the geofence. I then prepared to go out of town and when I left, I again got a successful exit; that was Sunday. I came back this afternoon, and not only was there no entrance recorded when I crossed the geofence, but when I checked for the entrance by looking at the Rules history, there were none – not even the few successful logged Rule actions I had from a few days ago. How long are logs retained? Should they have been flushed? Losing the logs was frustratingly unhelpful.

Have to agree with @WildBill, it’s not working right, even when it seems to work right.

@QiS should I even bother to send a new log file at this point, or just wait for the next update? I’m cool with waiting since this appears to be getting some attention.

As an aside, I’m unclear on how to best communicate all this. I had filed a support ticket that referred to this thread, but I’ve gotten a confusing mix of responses from what is now 3 different people (I think) who keep sending me the usual scripts but who sometimes appear to sorta kinda read this thread but not really always. I personally like the idea of communicating with someone in the know here publicly so that others may benefit, and I of course would still submit logs the usual way but who should I pay attention to?

1 Like

The latest app update came out just this afternoon/evening (pushed out this afternoon, but some people reported not getting it until this evening):

Make sure you’re up to date on version 2.29, and let us know if you continue to have issues now that the update is launched.

Hi @jeglin thank you for your feedback.
The log will be kept for 14 days. As for your issue, would you please submit a new log so that we can look into it.
You don’t need to contact anyone else, just PM me or post your issues here, I’m the PM of Rule Engine and I’ll follow up on your issues.
Thank you again for helping us improve this feature.

Update for @QiS

With the new version 2.29.0 (a25), my Rules history reappeared after having disappeared.

Then, exiting the geofence WORKED both times I tried it. Reentering the geofence FAILED both times to register anything. Details that you should be able to correlate in the logs for Mar 17:

  • For the successful exit at 4:52pm, the re-entry at about 4:57 failed.
  • For the successful exit at 6:13pm, the re-entry at about 6:26 failed.

Log file uploaded: 507015

1 Like

Thanks, we’ll look into it. If there’s any update, I’ll let you know.

1 Like

Probably overkill on messaging but another trip yesterday failed to register the geofence on both exit and then entrance after about 2 hours. So it’s not just one or the other that’s failing, which is what I was beginning to suspect.