Do location-based rules work at all?

Hi @jeglin our devs found that the code was partially migrated, which caused a little problem and they solved it in 2.30 alpha. Can you try if 2.30 alpha solves your problem? If yes, I can DM you the download link.

1 Like

Yes please! How will I actually use that link though? Won’t I have to go through the App Store?

This is really great to hear. I am glad you did all this testing jeglin to help get this discovered, and thank you WyzeQi for your team’s efforts looking into this so that everyone can have an improved experience. I love seeing positive progress like this.

@QiS I don’t see a DM anywhere to link up to the alpha. When should I expect that?

The alpha version will be released tomorrow or the day after tomorrow. Once I get it, I’ll forward it to you. Thank you.

1 Like

Thank you @carverofchoice for helping us improve Wyze products to make them too good to be true.

1 Like

I just submitted a log and a detailed report to @QiS.

The alpha is working better than before, but there are still misses and errors. Hopefully we can continue to converge.

@QiS any updates? The newer version definitely worked better, but there are still misses. In particular, I see double entries (duplicates) most of the time. I wonder though if this is because I have both the official app installed and the alpha (you only told me to download the alpha, but was I supposed to delete the app?). I generally make sure the app is not running and only the alpha, but without my intervention, I do see them both running at times. I’m wondering if there are background processes that may be conflicting or duplicating effort.

What is my next step as to updating? Should I stay with alphas or delete the alpha now and only use the officially released app?

1 Like

Not a great solution, but an observation. I found that if I set the location permission for the WYZE app on my android device to ‘Allow all the time’, everything works as it should every time. If I set the permission back to the default setting “Allow only while using the app” then my location based rules are spotty.

1 Like

That makes a lot of sense, actually. If location is only on when you’re in the app, then for location based rules to work you’d almost always have to have your app open or the location won’t be called.

I leave my location on all the time because I need to for location based rules to work without the app being open.

Well I receive notifications from the app while outside of the geo-fence. I also have a “notification” on my android device constantly stating the WYZE app is running in the background. With that said, I do not bring the app to the foreground every time I leave or enter the geo-fence.

I think the location tracking uses a different method than the constant notification. From what I understand the constant notification is for connection with the watch and possibly headphones or buds?

This is the same with another app I use. I have to have location on all the time for the app or the location triggers don’t work unless the app is open. The notification being always up doesn’t have anything to do with the location request for that app, either.

1 Like

Fair enough and thanks for sharing your experience.

1 Like

FTR I believe the instructions I read somewhere required location on all the time. My troubleshooting chronicled above has location on continuously – that did not resolve the issues.

1 Like

Do you know how often your location is polled? I use Macrodroid to set the location ping rate to once every 30 seconds when I leave my house… And it seems to help a lot with location based rules.

Good question, I do not know, and this was another of my questions early on: what is the algorithm for determining that you have entered or exited? (It was clarified to me by Wyze support that technically it is not location-based – they are triggering on entrance and exit, literally. This is why, if a trigger is missed, you don’t recover).

Of course, the process MUST be location-based on some level, but the algorithm isn’t shared, to my knowledge. Also to my knowledge, we don’t know if the rules-management coding contains bugs, or if there is a hardware issue.

Does that cause problems with using something like Google maps? If it can only check every 30 seconds I’d be afraid it might not warm me about a turn early enough, or not realize I went off course for a bit or how fast I’m going.

IDK just thinking out loud. Does it make an exception for certain things?

Actually, all my navigation apps seem to work better. My location history in Google is also far more accurate than it used to be.

I think with navigation apps, they use a combination of GPS, cellular, and average speed - but I’m not 100% sure of how that process works.

1 Like

Interesting side thread. I’m on iPhone but I’ve never used an automation app – will check it out.

Indeed, navigation apps use dead reckoning in combination with GPS or other location signals.


Just keeping the thread alive. Disappointed that the original support flurry has died. Tonight I did some careful testing. I recorded 4 straight exits but Wyze believes I never returned ever (5 times including the original entrance). Of course I was entrancing so I could do exiting again.