Flashing your WyzeCam v2 firmware

The fact that you are using this camera in a commercial environment says a lot about your boss company. Whats is the company name, again?

Did they take away the easy way to revert firmware on V2 OR JUST REMOVE ALL THE OLD firmwares and if so WHY??
I want to run time-lapse, so I had to revert to .33.
Did it on several cams using the relatively new feature in the app.

Whent to use it today - on a recently bought cam - clicked Have a Problem →

@WyzeRoy might you be able to give us some insight on this one? that is an extremely useful feature. especially with the current bug in the time-lapse.

Hi, we did it because the new beta firmware can’t be downgraded to or firmware or lower. We are going to release a new beta firmware which overwrites a few files from the old f/w. It is a ‘breaking’ change which is not reversible. If you downgrade, your camera will be at flashing blue state forever.

If you want to revert back to older firmware, please manual flash the firmware via https://support.wyzecam.com/hc/en-us/articles/360022732931-Wyze-Cam-Firmware.

BTW, our beta firmware (coming out soon) has a fix for timelapse download issue.

1 Like

Thank you for your reply,
Unfortunately it seems very often when Wyze “fixes” something or adds a new feature (which Wyze does FREQUENTLY) another feature gets damaged,
I realize this is a common occurrence when dealing with state-of art hardware and software.
I dealt with it for 20 years in fielding state-of art military topographic systems.
I also realize Wyze is trying to cram 2 gallons of code into a 1 gallon container.

Could Wyze archive the older versions of beta firmware so we could download them from Wyze versus a third party?

The ability to revert with a click of the mouse was REALLY nice, especially for those of us with remote cams. The “SD card dance” requires physical contact. Many people put cams in vacation homes, up high, and other inaccessible places.
At this writing I’m sitting in Mississippi and I’ve 2 cams I’m monitoring in Virginia. I don’t expect to be near them for 3 to 6 months. They have been running fine through power outages etc. with no problem for a month.
I would have like to upgrade them to the “people - vehicle” motion detection but don’t dare because it might break something else and now I can’t revert them without a “hands on”.

But the remote cameras still work as well as they did the day I bought them.

1 Like

Thanks for your feedback! Well, our alpha/beta firmware have higher chance for bugs. I am not touting about the bugs but that is part of the nature of beta testing. :slight_smile: We did introduce a few bugs in official bugs. That is something we need to pay more attention on. Quality is very important.

For this specific case, my best suggestion is to wait hopefully 2-3 days until us release a new test firmware which fixes the time lapse issue. They are being tested now. Thanks!

1 Like

@WyzeTao thank you for the information. It is responses and information like this that will keep me with Wyze for a VERY long time. Both @gemniii and know the nature of working with things this along with being a beta tester and working a company that is actually trying to do best by its users. but your clarity on why you do what you do is yet another sterling example of what sets this company apart. Beyond getting feedback from users, there are well informed and clear reason as to why you do what you do. a rarity in this day and age. thank you for the information.

Thanks for the heads up. Looking forward to next beta release. I appreciate you saying the next update will be a “breaking” change which is not reversible.

I’ve been a beta tester with a number of companies over the years … and I have NEVER had this much openness and communication from a company. I continue to be amazed by WYZE and its people.

I know. I almost got demoted when early in my career I told senior management in a meeting that failure was to be expected in beta testing. We had to winnow out what DIDN’T work before we put it in the field Army.

Thanks for producing cameras inexpensive enough so I can run a few as test cases before I deploy the firmware to all of my cams.

Thank you @Bam, @todwatts, and @gemniii for your encouragement! It seems like removing all old Beta firmware created a new scenario which may not work well. We will discuss how to handle the situation.

1 Like

I had the issue with my Wyze camera not connecting to WiFi network. I did just as was indicated by not adding 5g to end of my WiFi network name and it worked like a charm. My camera updated to new firmware after I clicked to update and it works fine now!! Thanks is so much!

I have had problems with seemingly formatted cards that the cam would not work with. The fix for me was to pull card and do a full format in PC - not quick format.


Where can you download the latest firmware? There appears to be no working link on the firmware page.

You can update your camera to latest firmware in the Wyze app. Click on gear icon in camera settings, Device Info, Firmware upgrade.

Firmware Files can also be Downloaded Here

1 Like

StopICU33: Tried that on a new cam at first connection, when the app suggested it. (I had done the update to the first cam at first connect, and it updated just fine.)

On the second cam, the update failed. When powered up now, the cam displays a continuous yellow status lite for 30-45 seconds, you hear the IR filter switch in the camera, and the status light goes out. It waits a couple of minutes, and the process starts again. and again.

I downloaded the firmware (build 108) working the current camera, copy it to the root folder of a micro SD, renamed to demo.bin. With power disconnected, I insert the SD card, hold the reset button down, and insert power. I hold the reset button down, but the light never goes to any shade of blue; it remains the yellow, and does the power cycling thing. after it failed to update, I power off & remove the SD card.

It’s been unformatted. I had to reformat it, and not the quick format, which relies on being able to detect the current format. I did the rewrite format.

After the format, reloaded the demo.bin to the root folder, and tried the manual update procedure again. This time, it turned the pale blue, and acted like it was updating. But, it was a fakeing it - after a bit, the status light turned yellow, and the IR filter/lights out cycle started again.

Now, the only difference between the first and second camera installations is the network - I have a new wifi router. Does the manual update process require that the camera is in the dmz?

I’ve seen a FAQ which lists the dozen or so ports that the camera needs open; is this port access needed going out through the router, or coming in through the router to the LAN?

I’ll ask about this for you. I don’t want to give you the wrong answer.

Are you using Beta firmware? I noticed you posted this in the Beta thread.

You shouldn’t have to open any inbound ports on your router, and outbound ports are not typically blocked on consumer routers.

1 Like

You did uncompress the firmware if the file ended in .zip before you renamed it, correct?

The camera does not need to be in a DMZ, but also hopefully you aren’t doing any unusual port filtering anyway.

1 Like

Instead of trying to do all of that , just do a factory reset on that camera , set it up like new again , once you know the camera is then working good if it is , then update the firmware the normal way , like you did the first one.
Take your time don’t get in a big hurry .
I’m not positive it will fix it but give it a shot

To perform a factory reset on your camera, follow the instructions below:

  1. If using an SD card with the camera, remove it before proceeding.
  2. Leave the unit plugged in and power on.
  3. Press and hold the setup button on the bottom of the unit for 10 seconds for Wyze Cam V2 and Wyze Cam Pan units and 20 seconds for Wyze Cam V1 units
  4. Allow at least 30 seconds for the unit to initialize. In some rare instances, this process can take up to 5 minutes.
  5. The LED on the back should move from Solid Yellow to Blinking Yellow.
  6. The device is now ready to be setup once again.