Flashing your WyzeCam v2 firmware

As far as I know the bigger issue is the upgrade process. Once the camera starts the update process, it downloads the binary from the cloud, unpack it, and then copy the files as needed. The issue could be because of incomplete download, corrupted files or bad copy. We have limited flash space that we couldn’t keep an image for the previous version. In most cases if you flash firmware + re-upgrade you will succeed. Or you can just flash with the newest version of f/w.

We are aware that our f/w update process is not smooth enough. We are working on tracking different stages of the process and pin-point the root cause. however this is a long process since we need to deploy f/w changes first to collect the additional info as we need. We will still take a while to fix this issue but we are actively working on it. Thanks!

I have the same problem, but I could not reflash older firmware successfully.

History: Upgrade in December failed. Reset did not work. Tried flashing older firmware using SD card. I cannot get the blue light come on. The camera appears bricked.

1 Like

Keep in mind that this forum is primarily a user to user community. If you don’t get a helpful reply here, I suggest you file a support request including the log files for more help. You might want to go ahead and submit your ticket now as there is somewhat of a backlog. If you end up getting the issue resolved before support contacts you, then you can always let them know that it’s already resolved.

1 Like

Had issues with an update, flashed back to,, and separately, was able to get back into the camera, attempted update again, camera unavailable yet again.

Any ideas?

I figured out the trick for those of you that only get the flashing yellow light and it never turns blue. 1st, unplug your camera, 2nd hold down the setup button and insert the flash card until its in. Release the button. Then hold the setup button again and keep holding it while inserting the power cord. the light will turn blue after a couple seconds. Then release the setup button. Wait until you can view the camera in the WYZE app, and then from within the app, restart the camera. Wait for it to reboot and come back online and then view the firmware version number.

I got the same problem.
My Pan motion doesn’t work. I needed to downgrade the firmware.
But it never blue lighted.
After a day. I found out.
I use a 64GB never worked. The other day I tried another 32GB one. It worked!!!
The camera ONLY READ 32GB cards maybe lower works too.

1 Like

Holding down the reset on multiple V2 cams for 3, 6, 30+ seconds does not turn the light blue. Eventually it will reset and require a new pairing with the app which works.
Used app to format SD card which works as the cam will start writing video to it once rebooted.
What am I missing?

Great tip but unfortunately, did not work for me

What size SD card are you using? I used a freshly FAT32 formatted 8GB card, copied demo.bin to it, and then followed the instructions. Previously I was trying to use. 64GB exFAT formatted card (which works for video storage) and could never get the firmware to update.

Tried 16GB FAT32 with latest and previous firmware named demo.bin on 2 different v2 cams with same result when holding down reset: no blue light

Just a thought. If you are re-naming the firmware file on Windows, surround the file name with quotation marks like so; “demo.bin” . This makes sure you don’t end up with a file name of demo.bin.bin on the SD card.

A few thoughts:

  1. Please make sure to to hold down the reset button before plugging in your power cord. Keep holding the button for 5-8 seconds after plugging in power cord. It should turn blue at this time.
  2. As DreadPirateRush mentioned please double check the decompressed file name as “demo.bin”, not anything else.
  3. Try to format your SD card on a PC or MAC and try again

Good luck!

Hello! I try to connect the camera, scan the code and hear “cannot to local network”.
I tried to update the firmware but did not get the blue color.
I am using sandisk extreme 16gb.
I tried the first and last version of the firmware.
I put the demo.bin.cpgz file on it.
What have I done wrong? file format must be .bin or .cpgz ?
I tried both options. nothing works

and there is one more thing. In the app, when I select a camera, there is only “xiaofang camera”. there is no wyzecam v2. I choose xiofang. Could this be the case?
I chose the china region.

I think a .cpgz file is still a compressed file. It needs to be uncompressed into a “demo.bin” file (no extra extension). You may want to try downloading the file again using a different browser, and if that doesn’t work search for .cpgz on the web to get advice on how to decompress it.

If you still have trouble, please specify what operating system you are using to download it so we can give more specific advice.

1 Like

guys, i am an idiot :upside_down_face:
all this time I tried to connect in the program Mi home. Now I downloaded the wyze app and it all worked!

1 Like

Just curious, why did you download Mi Home instead of the Wyze app?

I watched the video instructions on how to configure the previous versions of the camera, and completely forgot to look into the instructions for this camera


I can’t seem to get the camera to update from the SD card. I have the RTSP beta demo.bin on the flash drive but it wont install it. I followed the instructions with holding setup and everything until the light turns blue, but the camera winds up connecting to the network as if it was a normal restart without ever doing the install.

If you are using Windows to rename the file on the SD card, make sure you name the file in the dialogue box exactly like this, with the quotation marks:


Otherwise Windows may name the file like so, “demo.bin.bin” if you have file extensions hidden in the global folder settings. Hope that helps!

1 Like