V2 cam bricked after firmware update

I just updated 3 v2 cams with 4.9.91851. Two survived. The 3rd cam is now bricked with a solid amber status light. Tried numerous power reset and reset button reset. New cable and new power supply. Nothing worked. This cam worked fine prior to the update. It is not the router or modem as the other cams are working. Is there anything else to be tried or is that the end of this cam? So much for this “exciting update waiting for you!”.

You can try a manual firmware update from the SD card.

Thanks. I’ll give it the ole college try.

I had the same thing happen just two weeks ago to one of my V2;s. I had to search around to find the instructions for the manual firmware install to recover the camera. I had forgotten how important it is to follow the instructions. So, let me emphasis for you.

After you download a recent firmware zip file, expand/unzip/extract the .bin file. Now, keep it simple. Very simple. Copy that single file on to the root of a Micro SD card, formatted at Fat32. I used a 2 gig because it was handy, not a 32 Gig as recommend. Still worked. Now that you have that file on the Micro SD, you rename it. Don’t forget this part. This is critical. For the V2, its simply, demo.bin (you are removing the numbers, and dots). Simple. Do for yourself one more step. For Windows, make sure there are no other Wyze files on the Micro SD. Then put it in the camera.

And boot, holding down the Setup button.

Thanks Sam_Bam. Your instructions are appreciated. I hope that anybody else running into this situation finds your instruction.

I got the cam. to work. Hallelujah. First I tried firmware version The cam went to a purple status light, as mentioned by the Wyze rep., and then it went to solid yellow. So, I tried the next version available for download, v That version brought my cam back to life. I think I’ll just leave it there because as my Daddy once told me, “Son, if it ain’t broke, don’t fix it or…fix it 'til it is broke.” Wise words, indeed.

Thank you Wyze and thank you Sam for getting me back on track.


Yeah. I now have 8V2 cameras that are bricked as a result of a firmware update. Ridiculous garbage products.

So I am assuming you have already done a factory reset and flashed the cams to a previous working firmware version.

That is correct. failed on 8 v2 cameras. Rendering them worthless. Loaded demo.bin of to SD card. The cams I’m able to reach to remove fail to reconnect to the app Very much resent that I have to climb all over the roof of my house in the middle of winter to fix these. Everything had been rock solid stable for years. My other 8 v3 cams are now calling for updates. That’s not going to happen. Oh, and my doorbell pro is more worthless than the $28.00 AliExpress one it replaced. Just a worthless doorbell that will not take a 64 character password, won’t take a micro SD card, and won’t send notifications, either on motion or doorbell press. Plus, I have to pay a monthly fee!

1 Like

I had recently tried to start up my CAM v2, it was a headache and said there was software updates upon startingthem, it locked up, now all it does it light up light ‘orange’ and make clicking noises. Will this forced flash firmware update work ? also will it work from a thumbdrive usb?

One of my v2 cams out of the blue locked up on the solid yellow light. I power reset it. No response. I hit the reset button. Again no response. So I followed the instructions for a manual flash of the cam. firmware to an earlier version using a usb micro sd card formated fat32 inserted into the cam (essential) loaded with a earlier firmware version renamed “demo.bin” , held down the cam reset button and plugged in the power supply. Bingo. Cam is back online. I thought the cam. died due to old age but I figured what the hell, give it a go and got lucky.

I need some help, same thing here. But I was dumb enough to remove the camera from my app. Now when I try and flash it, I do get the initial blue light, but after a minute it goes back to solid yellow. I’ve tried v and as suggested, but none work. Really want to get it back up and running. Any advice?

Unfortunately not. They offered me a discount but I haven’t taken it as well Whats to say same thing won’t happen on next camera?

The Cam v2 bricked after performing a version update proposed by the Android Wyze Application. I formatted the 32G SD card to FAT32 and tried to reflash the firmware with four versions available on the Wyze Cam v2 Firmware support page.
The,, and did nothing to the steady yellow LED. The made a difference. After firmware refreshing, the LED blinks between yellow and blue. But then, I cannot add the device via the Wyze Application since the camera does not sound “Ready to connect” in response to the Setup button. I tried to issue the factory reset but with no success. The LED continues flashing yellow & blue regardless of how long I press the Setup button. The camera’s HW is OK since it worked with the original version. Any suggestions?

Unfortunately not. You’ve gone above and beyond what I did. I contacted Wyze who offered me a discount for a new camera, but I don’t really have faith in their equipment now so I have not moved forward to give them more money.


I am in the exact same boat as you. I decided to setup 2 v2 cams that I had lying around that we never opened. After setting up the first one, the android app recommended that I upgrade firmware from to I let the app perform the upgrade, but that turned out to be a huge mistake because it bricked the unit. Now the device is stuck with a solid yellow light and occasional clicking noises.

I tried to recover the unit by flashing older versions of firmware via SD card. Any firmware newer than 4.9.6.x gives me a solid yellow light. Versions at or older than seem to install ok, but I get stuck at the perpetual flashing blue and yellow lights after the cam boots up. The setup button doesn’t seem to do anything. I get no audio prompts when I press it. The camera does have some signs of life though. I see new mp4 files being written to the sd card, along with .txt files that contain gibberish.

My hunch is that the wifi config is corrupt. I tried to do a “factory reset” by holding the setup button for 5-10 seconds, but that doesn’t do anything either. The button is totally dead, except when I use it to flash firmware from the sd card.

Since I am ready to throw these pieces of junk in the river, I decided to see if I could upgrade the second working device from SD card, starting with the oldest firmware versions I can find on the wayback machine. I have successfully upgraded from to, then to, and finally to I stopped at that point.

The moral of the story is don’t let the wyze app upgrade your camera.



Take it back to homedepot were it was purchased or what

I had the same issue.
4.9.9.x and 4.9.6.x firmware: solid yellow firmware: yellow/blue flash
press setup button doesn’t work
press and hold setup button will bring factory default setting

try everything, but no one works.
any solutions?

Just to put more pressure on Wyze to come up with a solution, I just updated firmware on four V2 and bricked two of them with same issues as every one else here are describing. I then tried manual firmware over micro SD with same results as many other has described…

Same thing just happened to me. Bricked two v2 cams and cannot get them back even with SD card. Unless Wyze reaches out to send me new cameras I’ll never buy a Wyze product ever again