Flashing your WyzeCam v2 firmware

HDRock: There was no effect when trying to reset to factory defaults. It continues on with the 30-40 seconds of yellow light, a click-click from (I assume) the IR filter being engaged/released, then a minute or so of ‘off’ before repeating.

Newshound - Yes. I extracted the .bin file before renaming.

If you haven’t already done so I suggest you put in a Support Request at this link

1 Like

I agree with @HDRock- call the cavalry!
In the , I remembered another user with a similar problem who claimed to have come up with a solution. Cannot remember who he was but I did save his solution just in case. If you’re bored and want to try something, here is what he suggested. Again this is not sanctioned by any of us but it seemed to work for him.
Text follows

I figured out how to fix v2 cams that have been bricked. The issue when it boots up with a solid yellow light and after about 30 seconds it just goes off and does nothing. Then ends up rebooting over and over again if you keep it plugged in.

The key to fixing the issue is during boot up once the solid yellow light goes off, immediately push the setup button on the camera. The camera will say ready to connect or something to that effect. By going into setup mode it steers the camera away from continuing the normal boot up process which causes it to crash. Right after it says ready to connect you can hold down the setup button for 10 to 15 seconds and it will do a factory reset. You can immediately tell that the subsequent boot up process is a little different because there will be moments of the blue light blinking. Once it boots up it will now blink yellow making it ready for you to set up. Go through the regular setup mode and it should work just fine.
Again - call the cavalry!

1 Like

Yup, that came from Andy Ly on the facebook beta testers forum.


@gemniii - Either you save stuff like I do or you have an eidetic memory! At any rate, thanks. I’ll note that.


In case it helps anyone in the future, here’s how I solved the issue where holding setup with a microsd card would not result in a solid blue light:

I am using a 64gb cheap microsd card I picked up locally. The computer reads the file fine, and I copyied the demo.bin file to the root, but the light on the (v2) cam would never turn blue, it would just blink yellow and I’d hear the voice prompt. The card was formatted in exFAT (the default for cards of this size).

The solution was to use Windows Disk Management interface (WIN+X, then select ‘Disk Management’), to delete the existing partition on the microsd card, then create a new 8GB partition, and format it fat32 (NOT exFAT). After that everything worked just as advertised.

It might be that the camera will only read firmware updates from FAT32 formatted SD cards, and fat32 volumes cannot exceed 32GB.

Welcome to the community, @JohnnyPrimus. Wyze cameras only officially support FAT32. YMMV if you use exFat. Please see these support articles. :slight_smile:

Thanks, I appreciate the quick response!

Two suggestions:

  1. It would be really helpful to link to those articles from the flashing-your-wyze articles. Those articles have no indication of a required format.

  2. FAT32 is limited to 32GB partitions when formatting from a Windows 10 machine. People who attempt to format a larger card (and larger cards are rather prevalent due to the very cheap nature of microsd storage) on a Windows 10 machine will only be able to select exFAT or NTFS – a shortcoming I encountered in this process that resulted in my post above with the (admittedly complex) workaround. It would be great if the articles you linked to made note that cards should be 32GB or smaller if they are going to be used with or formatted from a Windows 10 machine.

Thanks again–


I had to update RTSP firmware to get my cam to work, I was getting the same prompt: unable to find network.

Thanks so much worked perfect i flashed
following the instructions just as prescribed and it works again
since the update a few moths ago it just would not connect !
finally it hit me try flashing and so thanks again .

For OSX users having trouble getting a FAT32 filesystem using OSX – the following link did it for me:

I successfully flash firmware and used it as a web cam without problem.
Please check my video for instruction. Thank you.