Error 90 Reset every couple of days!

2nd V3, still get error 90 (network error) have tried every “fix”, advanced, talked with support. Too bad, seems like a great camera when it works. Tired of resetting every couple of days…


Welcome to the community @mcgyverdc

Not sure of all the fixes you have tried. So will provide a few here:

  • Unplug the power, wait for about 15 seconds and plug the power back in
  • Go to the App, Select Account, App Setting, then Clear Cache. Backout one menu and the log out of the App.
  • Since you have and Android Device, Long Press on the App and select Force Stop, the Storage and Cache, clear Cache there as well. Then Shut down the app.
  • Restart your Phone or Tablet and logon to see if the device is working.

Note Make sure you know your credential to log back into the app. Also, the images will be gone for your camera’s. They will come back once you start a live stream again.

Others have also restarted their routers as well.

What make & model are you running for a router, and how far is the camera from it?

Well thanks for the reply, I can reset the camera by unplugging and sometimes having to do a hard reset. What I’m getting at is that doing this every few days is frustrating to say the least. I am sure this is a fault in the firmware and Wyze is not able to fix with an update. Seems to be a very common issue and unless they fix it I’m sure their marketshare will continue to struggle


Router was just upgraded by my provider about 6 months ago, it is about 15-20 feet away

1 Like

definite possibility.

Curious on the Firmware you are using and the App Version you are using.

I am not experiencing the error 90 on my v3’s. But I am running the Beta FW and App for testing to see what is coming or changing. You could always sign-up for the Beta App and then add the Beta FW for the V3’s. Then only update one of the V3’s and see if your problem is corrected.

If you would like to do this go here to sign-up for the Beta App: Become a Beta Tester – Wyze Then after loaded, go to the App, then Account, About, select Beta Program. From there, select Edit (top right) and select the Wyze Cam V3. Select Save at the bottom.

You should be prompted for the FW update when you start streaming the V3 or you can select the FW update located in Account.

Please be aware, it is easy to roll back to the production release of the app by simply leaving the Beta Program. In order to get the Prod FW back on the Camera, you will need to manually flash it back.

These are a few options to try which could indicate if it is indeed a FW or App issue.

v2.29.0 (114)

That is the same App Version I am using. My Firmware version was updated today - Beta Update:

Here is the link:

Signed up for Beta, will update in a week or so…

1 Like

Hopefully it works out.I have 7 active v3’s. So far no real issues.

I was having problems with two of my 4 cameras constantly going offline with error 90. One of them sometimes would do it several times a day. The other did it about once a week. What seemed to fix it was i changed the 2.4ghz channel. I used a wifi analyzer and then picked the channel with the least traffic. They have worked fine ever since.

Nope, on Beta and still goes through “connecting”. Getting the “secure Channel” but ends up with a power cycle or force close app message (which works)

Do you see the KB/s go to 0? Asking as I had this issue with mine in the past. It turned out to be my router. I ended up switching to an Asus Router which has performed flawlessly for me.

My previous routers were TPLink Deco’s, a P7 and a X60. All of which would suddenly stop streaming and doing a router reboot would correct it for a period of time, and clearing Cache and restarting the devices would also. But it was never a long term fix.

So, have you tried rebooting the router? Do you have an additional router you could possibly add to your network and attach the products to test.

One other thing that some routers may have difficulty using is the Tren Micro Security items. I have read where some individuals have turned off the Trend Micro on their routers and everything started to work again.

Hi! I had error 90 on both cameras this morning (V2 and V3). I reset my wifi routeur, reinstalled my 2 devices and it worked for me!

and here we go again…
Time to look at Amcrest etc cameras
I can do hard resets, clear cache etc and will come back on line but not interested in babysitting this camera and app


Equally fed up with this issue. Cameras worked nearly flawlessly until one of the most recent FW updates. Now essentially useless. Constant error 20, 90, or i think 23. Not a problem at all with outdooe cam only indoor v2 cams. Being 1800 miles from cams can’t do any more hard resets. Wyze has made these useless to me. Problem seems to be with the app. Since when they occasionally can be accessed I see that there is continuous recording on the memory card in the cam. Time to switch to another provider.


This is ridiculous! No camera in the history of IP cameras has this many problems with staying connected and NOT having any self-recovery method! Imagine even if the camera tries again and again (who cares if it’s indefinitely)? What’s the purpose of having dedicated power connected to it?

It is obvious that the network is working when we are checking. Because of an intermittent network drop some time ago, the whole camera just shuts down, and someone needs to come and power-cycle it? Imagine watching TV and you have to unplug the TV every once in a while because… well just because.

I think there should be a lawsuit for this! It is being advertised as a security monitoring device, no? No security device should just shut itself down. Wyze should advertise this as a TOY or FOR FUN USE ONLY.


I am getting the same error. I have tried reaching out through support but the chat is not getting me the correct information I need.

The worst part about the whole things is this was a gift from a vendor who helped build the website and my product will probably not be allowed to be returned. :frowning:

I agree with your frustration. My V3/Floodlight keeps randomly going offline and needs to be power-cycled to work again. Not such a great option for a SECURITY cam when you’re out of town, etc. Camera f/w - Floodlight f/w - Android v2.31.0 (145) - RouteThisHelps shows an awesome network connection with no suggestions for improvement. I spoke with support this afternoon and they said that the cameras can go offline whenever Wyze sends a system update, although I doubt they are doing that with the regularity of my dropouts. Not to mention that my indoor V3 cam has never gone offline.