Camera V3 update 4.36.319 crashes cameras (fatal flaw in design?)

I manage an elderly family members care, and use the Wyze V3 cams to help when I am away.I have bought several Wyze cams, and SmartLocks. Normally, the camera updates go through without a hitch. This latest update 4.36.319 says is “updating”, but then the camera(s) do NOT come back online. I have tried ALL the troubleshooting methods, as well as trying to “flash” the cameras with the .BIN file offered on the website. No luck. Out of 3 cameras, 2 have died. My issues are, 1) why? Why do we have to pursue replacement cameras , (and all the wasted time waiting on hold) to just get a camera to update? Wyze customer service reps try their best to accommodate people, but it seems to me, that this company cannot continue profit by just replacing every camera that will not update. There has to be a better option than to have potential new customers see the reviews, and wasted time trying to repair devices that they purchase. Please fix your devices so they work, update and function as advertised.

1 Like

@rwolder Welcome to the community and sorry to hear about your troubles. I am a community member as you and try to assist when I can. As you we have Cameras at my in-laws home and monitor them. I have not experienced the same issue, was lucky or maybe I do my updates differently.

With that said, when you tried to roll back the firmware on the cameras, did you name it correctly and put it in the root of the SD Card?

here is a link to explain how to flash the camera to a previous FW Version

Here is the location for the Firmware. Go to the v3 section, click on the Chevron (down arrow) to expand it. The version Numbers will be links to download that Firmware. It is critical to name the Bin file as it is described in the previous link.

In your case, it looks like 436.2.5 is the closest previous version you can roll back to.


Yes, I tried all of your suggestions…. Several times.
Then, I read on the forums
That this is an ongoing recurring issue.
As all of the posts say, tried the flash to camera, light turns purple for a minute, then solid red.
Restart, hold setup button, does nothing.
It appears that there’s an issue with the cameras.

Rick Wolder
[Mod Edit]

Moderator Note: Personal information has been manually removed from this post. Such information often gets included inadvertently in an email signature block when replying by email. The forum software attempts to automatically remove email signatures but it is not always successful. When replying to the forum by email, it is best to remove the signature block yourself before sending.

I would contact Wyze Directly, they will have you walk through some steps or may provide other solutions. I have found calling them is better than texting most of the time, but you can try the support chat sessions.

By phone: (206) 339-9646 Available Monday - Friday 5 am - 6 pm PT and Saturday 8 am - 4 pm PT Or online:

1 Like

I have done that, they replaced the cameras without hesitation. Again, because I see the lengthy posts about this same issue, and because Wyze offered replacements without question, makes me believe the company knows there’s an issue with this camera/version/software. Seems like an expensive conclusion to correct an issue.


Maybe you are right. Maybe these $30 cameras are not perfect every time for the rest of our lives. We can’t expect a $1.29 McDonald’s hamburger to look and taste like the $12.95 Ruby Tuesday burger on a platter. There’s a reason the $30 Wyze doesn’t have the reliability and features that a $300 Arlo does. We get what we pay for in this reality. I wish too that they were better. Its a numbers game - so to speak. Maybe these inexpensive cameras are not up to the your requirement. I suspect you would stop buying a Corolla if you needed a F150. Not criticizing you for anything you have done. We learn what’s a better choice oft through our experiences.

1 Like

While I get what you saying, it shouldn’t matter if cost $30 dollars or $300. If they are engineered to only last 5 minutes (2 V3’s in my case) something seriously wrong. Not to mention how much will it cost Wyze to replace the cameras. Its obvious it’s no longer a small number of cameras.

I agree. But that does not mean they are engineering it to only last a short time. It could be the material, the manufacturing processes. I don’t know. I just know they are low end and we should not treat them like they are an anvil that will last 100 years. Yes, that’s an exaggeration of many magnitudes.

We don’t know how large or small the problem is. But we are not hearing tens of thousands of reports of problems. Could be the hundreds that fail, are a small number to replace compared to thousands+ they sell in many venues.

It is unfair of us to Wyze to presume to know all that goes on inside Wyze. I am disappointed that they are not vocal and give us a timely update on things. But from the outside looking in, we don’t control what they do, do we?

Many people who buy electronic products are not on forums trying to fix them. If doesn’t work, they just return them or get replacements. When people on forums are saying 3-4 out 7 cameras have died or 5 out of 5, it’s not longer just a few cameras. Let’s not forget, replacements are dying too. More concerning, they are still dying while going to ,319 firmware. That tells me either haven’t fix fixed with software, or simply not fixable. I do agree with you, Wyze silence speaks volumes.
But hey, at least we can buy a Wyze table lamp now.

1 Like

You all have made valid points. I agree that “you get what you pay for” also. However, I guess I’m stuck on principle. I guess my expectations are that some manager, or engineer would see how many cameras they’ve replaced only because of a software update, and say… “hey we should fix these BEFORE we continue pushing out the product”. —- OR —- perhaps someone in Wyze did see or say something internally, and the company has decided its within profit margins to just replace cameras to those of us that complain. It’s really too bad because the customer service folks, and marketing people get the brunt end of this feedback. I see there’s another thread that has a lot of folks complaining about this also. Wyze cam V3 stuck on solid red light - #72 by JeffB Nowhere do I read that the “flash” software actually fixes this bug. Wyze has replaced the bad cameras, and I guess for the $30 I paid for each did get me what I needed at the time I really needed them.

Nope, last firmware doesn’t seem to be fixing this issue either. Wyze released .318 firmware, to prepare for .319 update. Hope was those 2 updates would fix it, There are tons of posts on this, here, Reddit and quite a few more electronics forums. Silence on this is the worse.
Oh well, like some others, I may have bought my last Wyze product.

@rwolder. I commend you for your principles. I am not saying it right what’s going on. I am just thinking outloud what could be going on, and that its not right. Sometimes our stress comes from not knowing how/why something is happening. Nuff stress these days when we can share our ideas to the cause of that something that we can’t figure out.

I’ve said, I am disappointed they won’t talk about what they are doing with V1 sensors. I like them for their size. I don’t like V2’s for their size. I’ve started moving to Yolink sensors. They are bigger than V2, but good grief are the reliable. Never offline. Lots of stuff, great range indoor and outdoor stuff. Doesn’t mean I am throwing out my Wyze cameras though.

There is some odd things about this latest update, Wyze firmware vetting has taken 2nd place to pushing new products and it shows with each update. Look at screenshot after latest updates and it shows two line of firmware version?

Wyze is aware of the issue…

Also present in previous firmware too, Like I said their priorities have shifted to new product and not quality software/firmware :cry:

Maybe it is for the spotlight, but I don’t have one at my property.
Did install spotlights at my Aunt’s and vaguely remember there being a firmware listing?

Seems to show previous and current update???


@Seapup what does this mean for us? They’re admitting to a mistake, that somehow they sent or posted wrong flash files, or the camera update was wrong?
What is the solution now?

Neither. My reply was to bryonhu which is not related to your issue. bryonhu is pointing out an inoperable visual bug in the user interface. I’m not sure what the cause or solution is to your issue as I’ve not heard anything related from Wyze. Will definitely let you know if we hear/see anything…

New usage for updated cameras. Considering an “art” piece or something. Lol image

1 Like

Two of my v3 cameras updated. The third camera will not update. Still works,but won’t update. My guess is the software is fugged up.

Yup. That seems to be what’s happening. Wyze will replace it. There’s another thread about this also, seems to be an ongoing issue.

1 Like