Trying to update 2 cameras unsuccessfully

I have been trying to do an update on a V3 and Pan Cam. Neither will update. All the other cameras have successfully updated.

Cameras continuously say updating with no change. I’ve tried updating many time and it fails. The V3 will disconnect after saying the update failed and I have to physically unplug it to get it back .

What can I do to get this update to work?

I would try the manual firmware flash method if I can’t get the app the update the cameras OTA. What app version are you using?


Is the manual flash method putting the update on an SD card or what does it entail?


It’s pretty simple:

Thanks I’ll give that a try

1 Like

…Me too. I have 6 v3s, 3 of them updated no problem (as did a v2, a pan cam and a pan cam v2), but oddly the remaining 3 won’t update. They look like they do, go offline and come back as if they are updating, but when I look at the firmware it hasn’t changed!

They’re remote from me so I can’t hard cycle them…

P.S. OP - I suggest you add a “v3” tag to this…

1 Like

I’m still having trouble. The camera behaves as if it processes the update, i.e. it goes offline for a while, then comes back on and seems to work perfectly, however when I check the software version it’s still at the prior one.

Surprised there aren’t more people the same problem…

I had an issue with updating if I closed out of the update screen. When I let it stay on the firmware update screen until it was done my two V3s updated successfully

I just tried that (via iPadOS - other attempts were through Android). After a long time (about 5 minutes), the screen just said “the update failed” and to power off and on and try again.

Meanwhile the ONLY option on the screen is to “try again” - i.e. there is no “back” button, meaning that if you don’t want to “try again” for whatever reason (like you’re 100’s of miles away!), you have to Force Quit the app!

I never had a problem like this before and what confuses me the most is that exactly half my cameras took the update without issue…

Related: Does anyone know how the update is actually delivered to the camera? i.e. after you initiate the update through the app, does the firmware “traverse” to the camera VIA the app (and whatever mobile device you are on) - or does the camera itself get it directly from the servers? Just curious…

OP - did you get yours to update?

I have tried everything that was mentioned here except doing the update manually. I haven’t had time to do it manually. I just keep getting 'Update Failed" and the V3 goes offline. The V2 Pan Cam stays online but doesn’t update. My other V2 Pan Cam updated just fine along with all the other cams which are V2s and V3s. I have 8 cams but the 2 fail to update.

I took a closer look at mine - which were purchased and put into service at different times. (also, I stand corrected, I have 5 V3s in total, not 6 as I said earlier. 2 of these won’t update.)

I noticed that the problem is with the later ones I bought. All the earlier ones (mine have a MAC beginning with 2CAA8) updated without issue.

It’s the later ones, in my case with a MAC beginning with 7C78B and which were the last ones I put into service) which have the problem…

I wonder if you’re is similar (don’t put full MAC address here though!)

1 Like

My V3 starts with D03F

1 Like

Son of a vegetabowl! :face_with_symbols_over_mouth:

I have two 7C78B and one D03F2 - but thanks to you and @Conno1 I know not let those puppies do any updating any time soon! :wink: