Base station not connecting - flashing blue light

They replied to your emails, they only tell me to reply to their email which I do. Then I get email saying reply to email. These things are junk. Wyze does not have a clue what they are doing

It would not be rubbish if the people at Wyze knew what they were doing! They don’t. They got your and your sh__ out of luck. Wyze is a joke!

Here I was thinking I was crazy for the last week or so because nothing has been able to connect. I’ve been with the dreaded blinking blue light since the 14th. There’s a reason I have security cameras and this totally defeats the purpose. Glad this thread let me know what was going on since they didn’t have the common courtesy to

Wow. We called, explained exactly what I posted here. My wife had the wall for the RMA info request, had a replacement e route within a day.

Guessing it really depends on who you get on the phone maybe?

they told me the base station is not in stock so i guess i just wait now?? this really sucks. I use these cameras for security and now i will probably have to just buy something else since i was not given an ETA. BS

FWIW - Had the same problem after power outages. Here’s what I did to get it back online after trying everything I read on the net. In this order: Installed July firmware. Removed SD card and removed everything on card. Removed base station from app. Plugged into main network switch. Held reset pin for about 15 seconds until flashing blue light stops, momentarily goes solid blue, then to yellow. Unit reset, flashed blue for about 30 seconds and then went to solid blue. Setup as new base station on app. Set camera to “new” base station. Voila! Good Luck. p.s. I have no idea which of these actions caused it to work but I’m guessing that the firmware rollback allowed me to remove the base while offline and the reset under the old firmware fixed the network issue. Even though my other base is on the new firmware and has no problems, I’m going to wait until at least one more before updating.


I’m going to try this with the “bricked” one and see if it revives it. I did try to downgrade the firmware via the SD card. But to no avail it seemed as if it would work but it went back to the flashing. I’m hoping the experiment will do something and at least be a fix for those who now can’t get a base station.

I had to go through two days of trouble shooting. I did get a email stating I never replied to a email that was sent. The funny thing was I never got one and had to tell them.

I got one saying I never replied to their email when I’m fact i never got a follow up.

Wow Muda888 you are my hero! The steps you published worked for me, I was getting tyred of answering support email to troubleshoot without any success.

Just to complement your steps, firmware version that I installed was wco_sta_sd_4.16.2.12. Also after getting the solid blue light for the first time, it would start blinking again after 5 seconds. don’t be affraid since the solid blue light would come and go until your are able to add it to the app. Once is added it wont go off again.

I would recommend everyone not to update, until a new firmware that fixes this comes out, so skip the upgrade that the app recommends.

Again, thank you very much Muda888!

1 Like

Glad I was able to help!!!

Thanks for your save while Wyze figured it out, @Muda888! :+1:

They have an update for this now. If you have lost contact with your base, you will need to do a manual firmware update. Don’t forget to remove the SD card after the Base lights stabilize. Then you may have to do a power cycle to get it to come online, if it hasn’t already. Hopefully you won’t have to re-sync the cameras, but that is a pretty simple process if you do.

Download Base Station Firmware (September 8, 2021):

Base Manual Firmware Update Procedure:


Very helpful, thank you!!!

I was able to find base station firmware from July here:

I used this firmware specifically, July had two: (July 14, 2021)

Thanks again!

1 Like

After a week of waiting for a new outdoor camera it was finally delivered yesterday. But this brand new camera comes with the same dreaded problem of the flashing blue light. I noticed the light turned blue for a few seconds, but that was not enough time to open the app and connect.
We have several other indoor cameras that have been working great. This new outdoor camera is a big disappointment! I’ll stop recommending these cameras.

Here’s what worked for me:
Try switching the base station to a different port on your router. As long as it was different from the current port it worked for me, even after I went back to the original port.
I’m on a Google mesh network and it had been working fine until I loaned the base to someone else. It installed on their system just fine but my reinstallation was halted because we hadn’t deleted the base from their account. Once that was taken care of I had problems getting the router to initialize. Moving it to a different router port (and different cable) worked. I then plugged it back into the original cable and the original router port. Worked fine. Then setup the WiFi account and disconnected the base station from the router. All good.

Thank you for your suggestion! I will try that when I get home.
Your help is very much appreciated!

I posted about this issue a couple weeks ago. Earlier in this thread someone suggested restoring firmware from June or July. It worked well for me. Have you tried that?

1 Like

How do ou go back to a specific firmware?

Directions here, make sure you follow them correctly: Use a good clean SD card

Great detailed steps. As you have seen others have benefited from this. Great job.

1 Like