Alexa, show front porch cam :-(

Is there something special (apart from integrating the Wyze skill on the Alexa app) that I must do for a Wzye camera to display on my screen (TV or Fire HD)?

Alexa, show front porch cam.
Then I see “Waiting for wyze” on the screen for enough minutes.
Hmm, the camera didn’t respond.

I have disabled and re-enabled the Wyze skill, but still no joy.

All the devices are on the same network subnet.

If there was an issue with Alexa, it would tell you there was no porch cam, etc.
Not sure why it’s having issues and stalling so long. Mine shows me my Cameras on my Show 8 in about 4 seconds. Could be something to do with your network/router settings.
Are you using stand alone router? Or one of those router/modem combos that are provided by your internet provider?

1 Like

Which Camera are you trying to show?

Can you also provide the Firmware Version of the Camera, the app version you are using?



I have the FireStick 4K. Any cam I add to my Wyze account automatically shows up in Alexa.

I am able to view view my cams on the TV FireStick (V3 and WCPv1) by Alexa Voice Command. “Alexa, show the Front Porch Cam on the FireStick” But, the doorbell cam (VDBv1) is not compatible so it will not stream.

The fact that you get the Waiting for Wyze message indicates the cam is linked and available to Alexa, just not streaming.

You can easily see a list of all your Alexa available cams and devices on the TV by tapping the microphone :microphone: button once and selecting Smart Home. The menu at the top sorts devices by type. If you select Cameras, you can see all of them and test the stream on each there.

1 Like

I am using a V3 and WCP v2 with all firmware up to date as I am on the BETA program.
v3 firmware is while WCP v2 firmware is App version is v2.34.0 (75)

I am using a standalone router. All my devices are on the same IP subnet.

ok, checking mine in a bit. I have a v3 out on my porch and a WCP v2 in my office

I have tested that method and they still don’t stream.

Probably nothing to do with your issue, but is beta firmware for Cam Pan v1.

Cam Pan v2 beta firmware is

You are right. That is for V1. My V2 is actually not powered at the moment.

1 Like

Are there other Wyze devices linked to Alexa through the Skill that show up in the Smart Home UI on the TV and are also not working appropriately, indicating a Skill Link issue… Possibly due to the new 2FA if just recently employed on your account? Skill Link has to be reset w\ 2FA included.

If the other devices (bulbs, plugs, switches, thermostat, etc.) do work appropriately, then the problem is only isolated to the cam stream and not the skill.

1 Like

I don’t have many Wyze devices running here as most of them are OFF - the light strips are unplugged, but they used to work.

It’s the cameras that I am having an issue with. Last night I delinked and relinked the skill using the 2FA. I then tried streaming the WCPv1 from my phone.
There was no video coming, but the 2-way communication was there.
I was seated below it (it’s in the living room) and I could speak and hear myself from the camera, but no video!