Wyze1 the - getting video data (3/3) - stuck here

Again, this is another bug I found with new firmware but not in the old firmware.

When I try to live stream the wyze1, sometime it would get stuck at “getting video data (3/3)” from an external network. Internal network is okay. Cloud upload is okay, notification is okay.

Only way to get this working again is the power off/on the camera.

This would start happening every few days, before i need to reboot it again.

Any ideas?

I tried this. Does not work for me.

I got the same issue <span style=“color: #000000; font-family: ‘Open Sans’, sans-serif;”>get stuck at “getting video data (3/3) </span>after update new firmware ,

I like old firmware connect very quickly

I am having the same problem with several of my cameras. By stating that you restart the IOS app do you mean that you delete it or just swipe it up and off the screen? When I had only one camera that was not giving a live view, I deleted the app, then redownloaded it. That particular camera is listed but it still will not connect. All of the other cameras were still working at the time. Now, I have several cameras that will not do a live view but them are very good at sending me notifications so I know that they are working.

Thanks for any help you can give me.


Same here, been getting hung up when I try to view my camera feeds from work while at home I connect with no issues. Issue popped up since updating my camera’s firmware.

Connection issues at work could be your company’s firewall blocking the traffic. I know I’ve seen at least 1 post where this (company network) was confirmed to be the issue.

PS - I have no issues connecting from my work.

I’m having the same problem since updating the firmware. I have five cameras on the same network. Two of them get stuck 100% of the time on getting video data and the other three never fail.

Same issue here. Some cams good others problematic. Any feedback?

I just got my wyzecam. When im at home on the same network, i am able to connect to my cam without issue. Connecting to the camera from outside of my home network is a nightmare. I’ve gotten it to work well once over my cellular data, but within the past few days if i am able to connect to the camera at all, i only get one pic before the video freezes. I cant get it to work over any other wifi at a friends house or at work at all.


I’ve checked the ports on my firewall and i’ve made sure all of the correct ones are open. In addition the android app crashes constantly when i try to open it, but will open the next time i try.


I’ve seen many people complain about this kind of thing since the last firmware / app update. Can someone from wyze comment on this? I dont know if the issue lies in the firmware update/app because i have no previous experience to compare it to.

Same behavior for me too! #metoo Using latest iOS with 6s and when I’m on my home wifi network, all is good. But when I’m on carrier’s data network, I can’t connect and get this endless loop of “getting video data”. Restarting the app does no good either. Seems to have happened after latest firmware or app update. Either way, not happy as I’m constantly checking for the things that go bump at night!



I’m having the same issue. Newest firmware, one camera always connects and two cameras ONLY connect when I am on the same network - never remotely. When not on my home network, the two go through steps 1, 2, and 3, but never progress beyond “getting video data”. After hanging up there for a bit, we see the three steps repeated. One difference from many of you - I’m on Android using the latest version of the app. Seems like it’s not an iOS issue.

I am having the same issue off and on with all 8 of my cameras. I decided to fix the IP address for each of them but soon discovered after the update that 4 of them had changed their MAC addresses to ones corresponding to the original Chinese hardware manufacturer, not what is on the camera info or bottom label, and of course they now no longer match the assigned IP addresses and since the cameras will not tell you the IP address they are using to connect, unlike most devices, I cannot tell which is which camera is which with an IP scan or on my router. Anyone else seen this chameleon switch?

Yep. Same issue here. Two cams stuck on “Getting Video Data (3/3)” when on cellular or another wifi network. Latest firmware, and iOS app.

Thank you for the response.

I swipe first the screen first. I only once deleted the app then re-downloaded. I am in the process of adding a Leviton WiFi outlet to all of my cameras. I have 18 cameras and have this unit on 6 of them. Leviton DW15A-1BW No Hub Required. You can switch this unit off then back on to reboot the camera. Bought on Amazon.


Cellular eh? Hmmm, I’ll try this the next time I have the “Connecting camera (1/3)” problem that happens from time to time.

Adding myself to this list. Closing the app, and logging out of the app doesn’t seem to make any difference either. Tried disconnecting from my office wifi and using 4G data and doesn’t make any difference.

Unless I am missing something, where is wyze on this!? This has been up for 6 days and no one from wyze has commented!? Some feedback anything would be nice. As I am also having the same issue with one of my cams.

I contacted support on Monday about this issue. Still nothing…

Contacted Wyze as well on this issue. No resolution yet.

Now my cams load, they just take about 2 minutes to finally load.

I’ve tried on cellar and wifi even on 2 different devices with no luck. It will not display live feed. It stopped giving me connection failed message now