Wyze1 the - getting video data (3/3) - stuck here

After reading this, I tried letting mine sit. One worked fine (but that one always works), the two that are having the issue were left to sit for five minutes each. They never showed live video, rather they just would repeatedly go through the three steps, hang on step three for up to a minute, then back to step one.

Now the problem is intermittent. Sometimes they load normally. Sometimes they load after a 3 minute wait. Sometimes they don’t load. Sure would be nice to hear from Wyze on this issue. Either her in the thread or the help ticket I submitted several days ago.

Yes, this has happened to me as well. For my 3 cameras, I had manually assigned on my ASUS RT-AC68U router, only to see their names, IP addresses, and (surprisingly) MAC addresses change upon subsequent setup(s). Because of this, I’ve abandoned the idea of manually assigning addresses within the DHCP pool. By the way, if you power cycle your cameras, you MAY see the original name (that you entered during setup) and MAC address (printed on the camera) return on your router’s client list.

So I got an updated router from my internet provider and now my camera will load when I am off the network.

Can I ask for a little more info? What type of router did you have? Who’s the provider? Did you have cameras that always worked, but the one didn’t? Thanks, just trying to figure out if the same fix will work for me.

Now I have one cam that loads, and one that sits on Getting video Data indefinitely.

So, to sum up, Sometimes the cams dont load. Sometimes they take several minutes to load, and sometimes they load quickly. Sometimes one loads and the other doesnt. There seems to be no rhyme or reason to it, other than being off the home network when trying to connect.

Same issue here - in addition, one of 11 cameras reports “Connection failed (-90)” live but still receives alert notifications with video! Latest firmware, Android app.


I have now 5 cameras installed. Two at home, three in a distant location (just installed them yesterday). Now the three remote are stuck at the Getting video data 3/3. On my ios device, and the same on the shared ios device.

The two at home are accessible, either from the same network, or from mobile network.

App closed/opened, not working.

logged out/in again - nope

unshare/share - now the notification does not arrive to the other phone…

Would love to see this bug solved

When this happens i found that the MAC address for my cam showing on the router is different then the one shown when it is working. I don’t know why there are 2 mac addresses

Heard back from Wyze on this issue. They had me run a diagnostic on the cameras and my network. Surprisingly enough, they are claiming the issue is due to my router. Even though I never had the issue before the latest firmware, and now have the issue with the latest firmware. According to them the problem is with what didn’t change, my router, not what changed, their firmware.

What was the diagnostic, something they provided or something run from Wyze’s end?

It was an app I was instructed to download by the Wyze rep. Called RouteThisHelps. Ran it on my phone with the phone in close proximity to the cameras. It was able to get network diagnostics.

What you are seeing in your cameras is something I see as well. The MAC address change can happen when a device is made by one or more subcontractors. The main contractor uses their assigned block of MAC address and applies their MACs using facilities within the OS. All OS’s have that capability.

An update.

Wyze customer service said I needed a new router. That’s fine. According to them the new problem is the hardware that didn’t change and worked prior, but Ok. Updated my router firmware, and I was able to pull up both my cams several times over the course of several hours away from my home network. Today, as in right now, I am only able to pull up one camera the other sits on “Getting video data 3/3” indefinitely. So the problem, which started after loading the new firmware, doesnt seem to be my router since one cam does load, but rather their software, yet they don’t seem to want to do anything about it.

Also, if the router is the problem why do some cameras work and some don’t? On my network I have three cameras which work and two which stick on ‘Getting video data 3/3’. No matter what I do it’s always those two cameras which don’t work. Why would the router allow three of them to work and cause two of them to fail? And of course as with everyone else it happened right after the firmware update. Failing on Android

Exactly! If the issue is with the router, why would it happily pass traffic from one camera, and not another? And, why would the issue always affect the same camera? I’ve factory reset my prodigal cameras to no avail. I love the idea of supporting Wyze Labs, but the reality is a little frustrating.

I had no chance to re-visit my three cameras which went offline just on the very day I installed them on a remote location.

However one of them came back to life - they are all on the same WiFi network, all upgraded firmware, I don’t understand.

I will visit them, re-install all, and see what happens. I hope they will do their job finally.

Otherwise I might have second thoughts about the 11 cameras I have purchased…

For those with problem cameras. Check your router to see if perhaps you have an unknown device. My problem device shows up as “unknown” with different MAC address. The correct MAC address should be in the range of 94:51:3D:xx:xx:xx

“i’ve made sure all of the correct ones are open”

What ports? I haven’t been unable to find any documentation on this. I am having this issue as well. When I am not on the same wifi as the camera I never see the video feed. I can hear the audio but video never loads.
Android App: 1.2.58

Another interesting thing to note is that if I activate sound for the feed, I’ll usually get an audio feed of the camera while I’m stuck at 'Getting Video Data 3/3". I can hear the audio until it resets back to “Connecting…1/3”.