Wyze Watch 47 - Notifications

NashvilleFlyer got me all excited. I uninstalled the Wyze app. Downloaded it again from the Play Store. Opened the app and signed in to my account. Same problem. Rebooted phone and watch. No change. Even went to Account in the Wyze apo and turned on every notification possible. Went back to Watch notifications, no change. I really do appreciate everyone’s help and input though!!!

When you click notifications in the Wyze Watch area, what do you see? Can you attach a screenshot of what shows up when you click “Allow Notifications”?

That’s it. No drop down menu. No nothing. If I click back to the previous screen and then come back into notifications, they are off. BTW, sorry for the delay. Running errands in town.

Curious how many having this issue had the wyze band before the watch? My band worked perfectly. I do see that under the wyze setting in android that the wyze band service is running.

I set mine up this morning for the first time. I had to enable notifications via the extremely intuitive application menu on my Android v11.x device. I have also selected Outlook as a source of notifications and have been getting those notifications as well.

This is my first post regarding the watch. The quick start guide in the box mentioned it would be 100% charged upon delivery. Mine was not, it is only 53% charged. So far I’m happy with it. I plan to charge it up al of the way tonight and then hope to go al full week between charges.

Battery life will obviously be dependent upon the number of notifications. This is going to be great for all of the MFA text messages I get. No longer will I have to unlock my phone. Instead I can just scroll through the notification on my watch. I am seeing how this might actually turn into a useful and practical purchase for me.

FYI, I did leave Beta and download the “normal” app to reinstall. That’s what worked for me anyway.

I’m using Galaxy S9, updated the Wyze app, getting notifications on Wyze band but not Wyze watch. So I disabled notifications on my Wyze band, but still no notifications on the watch, Gmail, Yahoo, calls, texts, nothing coming in to the watch.

Im using the Android app. Gmail, SMS ( vis messenger) are getting to the Watch. I was getting notifications from my Wyze Cam V3 cameras as well ( but turned it off because I have 4 cameras and getting many notifications) . Check the settings on the phone app to ensure they are set correctly.
Allow Notifications [on]
Phone call [on]
Text Message [on]
Wyze [on] (Mine if off now)
Gmail [on]
Other Applications >
Messages [On]

If your dont have those setting on try it and see if that helps
All the best

There are multiple threads about this. Here is something I posted in another Forum Topic: Wyze Watch 47 - #74 by spamoni4

It shows what I have set and the additional item which is set to allow notifications. Something to check on yours.

Tried everything is several threads - no notifications on my LG G6, but then it took a couple years to get an update for motion detection on my camera, so it may require patience.

Hi all, I looked to this thread yesterday for help and found things to try. I have the beta version of the app, galaxy s21, and the 47m watch. I like most was having issues, I would only get some texts phone calls but nothing else to include any notifications from my cams. I tried resetting the watch and the phone multiple times with no improvement. Went through every notification tab possible and again no help. Someone mentioned to uninstall and reinstall the app which I did and again no improvement. It then dawned on me that I had the wyze band prior and was still showing on the device screen page in the app. The band was dead because I stopped wearing it because I knew the watch was coming. Anyway my point is I had to Uninstall and reinstall app also had to remove the band all together and surprise surprise I now get all notifications to the watch. I hope this helps some of you.

For reasons unknown, notifications started working this morning. Only issue is call notifications aren’t showing the phone number and the reject button doesn’t work.

Had the same issue on my S8+, As a last resort, I kept all phone settings and in the Wyze app deleted my watch, restarted my phone then added the watch back in on the app. Bingo, it all started working. Getting all notifications (and the stretching reminders which I also was not getting.) Give that a shot if you haven’t already.

Thank You! I’m working 2 jobs today but will give it a try tomorrow afternoon and let you know. :grinning:

Just got my Watch 47 today, very excited, love it, but same issue, no notifications for either the watch or any of my cams, video doorbell etc. Was using the beta version of the Wyze app for android. Uninstalled it, downloaded a clean version from the Play Store, installed, fired it up, logged in, perfecto! Now getting all my notifications.

Mine just started working next day. Just like the Wyze band, I think this has a connectivity issue. My phone is charging downstairs so there is no connectivity to the phone at night. Next morning, I thing the renegotiating between the phone and watch made notifications work. Either that or Wyze techs snuck into my house and fixed it.

Same here. I get regular text messages through notifications, however none of the other apps are showing on my watch when they are received on my phone. These always worked fine on Wyze Band. Not working on Wyze Watch 47.

same issue with me, used two Moto’s and old moto g4 and a Moto G7
turn it on and no menu…

I think I have fixed the notification issue with my Watch 47!! Based on some of the other posts, I did the following:

  1. If you have it installed, remove Wyze Band from the Wyze app
  2. Remove/uninstall the Wyze app from phone.
  3. Reinstall the Wyze app and log in (camera and watch are still there as before)
  4. Messages from other selected apps are now showing up on the Wyze Watch.

I had a friend send a test through Facebook Messenger and it works. Today, I am getting message from Microsoft Teams. Was unable to get either of these prior to doing the above procedure.

Good luck!

All it took was need to do a forced shut down and restart the application go into app turn on notification select the applications you want
everything’s working