Not receiving texts on 47mm watch - iPhone

Not receiving texts notifications on my 47mm Wyze watch. Yes the firmware in up to date. Yes “Do Not Disturb” is turned off. Yes I’ve restarted my phone and the watch. Yes notifications for text messages are turned on. I can receive calls, Facebook messages, and all other notifications that I’ve turned on, but I’m not getting texts.

1 Like

Same issue here. Been this way for at least a month. Alerts show on phone but not watch. There is an occasional alert that gets through. iPhone 7 and gen 3 watch. All devices and apps are up to date.

Had this issue too. Finally found the fix. For Iphone users, go under setting, then notifications. Go down to options and make sure that either “always (default)” or “when unlocked” is selected. If “never” is selected then you will not receive notifications. I also made sure to have text messages and other applications were selected in the app to receive notifications. Everything worked fine after that. Hope that helps.


I just reviewed all settings mentioned above. All were previously selected I toggled them off and on again. Will see if there is any difference.

Is there any help on this. I reset the watch 3x and out of the 3, the 2nd time I received texts and a call but missing other notifications. Reset that 3rd time and now no texts and random calls.

I have an iphone as well, have checked all those settings, they are accurate. Still not getting text messages on my iphone. If someone calls I get the phone ring notification but no text messages.

I talked with Apple support yesterday and they said they do not support third-party devices, which includes these watches. This is Apple‘s way of not having to deal with non-Apple hardware. The tech attempted to help me but eventually failed because all she could reference was the Iwatch which if Bluetooth is not available due to distance, Wi-Fi takes over which is an awesome feature.

That is weird. My wife has an iPhone and a Wyze Watch 44 and she receives texts on her phone. Since the software on the 47’s and 44’s seem to be different I wonder if that is the issue and not that Apple actually doesnt support it? I get phone rings on my watch which shows me the number, just not texts so there is clearly some communication between the watch and the phone

Thank you for letting me know what you found out.

I’ve factory reset multiple times and I’ll get a text notification every bluemoon.

I added my wifes 44 and it will get some texts but won’t turn on or notify unless I hit the side button to open the watch.

Makes no sense.

Same scenario here. Cant believe this is not working on my iphone 10. What is going on here? Can you guys update this issue!!!

This worked for me! thanks for the info!

Just tried this (2 years after its OG Post) because I too was having this issue and it immediately worked! THANK YOU bc I literally lost sleep over it :joy: