Wyze Watch 47 - Notifications

Just got my 47 today, but I cannot figure out notifications on the watch. I get texts but they dont show up on the watch, they do on the phone though.

I cant figure this out. Any help welcome…

1 Like

I’m having the same issue. Love the watch. Everything seems to be working except notifications.

Tech support gave me a list to check. Here is my reply to them:

Wyze app is running in background. Bluetooth is enabled and functioning. I turn on notifications in the Wyze app under the Wyze Watch. No drop-down happens. I back out and go back in and allow notifications is off. Do not disturb is off.

I’m on a Samsung Galaxy S7 Active, running Android 8.0.

I’d appreciate any help anyone can give. :slightly_smiling_face:

I have all my settings on. I have iOs 14.4.1 iPhone and everything seems to be syncing right. I can add wallpapers, my steps are counted, and if I alert the watch from my phone, it vibrates (to find it). Notifications are not doing anything tho.

I’d also appreciate any help anyone can give. :slightly_smiling_face:

I have the same issue contacted support 3 times, each time they gave the same list. Still no notifications. Pixel 3 xl android 11. I thought it would have been fixed with the last firmware update, but no.

Same problem, Galaxy S20. Received the watch today, cannot get notifications to work no matter what I try. I have the wyze band and it works fine on that.

1 Like

I have a new watch. I get notifications for calls but not text messages. All settings are on but still no text messages. Any ideas welcomed. Love the watch but it would be nice to see text messages. Thanks

1 Like

When my iOS notifications fail, it’s for all notifications. So interesting some are seeing only the failure of text messages.

I took a hint from you. Powered off my Wyze Watch. Checked Google Play Store and saw that there was an update to the Wyze app and downloaded it. I powered my phone off for a few minutes. Powered on the phone. Powered on the watch. Opened the app and synced to the watch. Went to notifications and… nothing. Same problem. But restarting the phone was a good, simple step that I hadn’t tried. Thanks.

1 Like

Figured it out for me. In the app, click enable notifications, then on the next screen there is a Wyze app listed among others. Click that one and on the next screen, enable notifications again there. Once I did that, a whole list of apps showed up for notifications to enable on the watch and all work now.

I’m on Sony Xperia 1 mkii w/ Android 11.

I don’t understand. I go to…
Wyze App
Wyze Watch
Allow Notifications

The toggle bar turns green but nothing else happens. No drop-down, no next screen, nothing. If I back out and then click notifications again, Allow Notifications is off again. :disappointed_relieved:

I’m getting phone call and some text message notifications on the watch, but nothing else that I have selected. All of the other apps that notify fine on the wyze band are not working for the watch.

1 Like

Have you enabled notifications for Wyze within the allow notifications area I mentioned in my post?

Confusing but follow it closely.

I’m using WyzeBeta app now. I can toggle Wyze notifications on the first screen. There is no additional Wyze option on the Other Applications screen.

When you click enable notifications, what do you then see?

I’m not using a beta app version to my knowledge, just latest from Play Store on Android.

I am not having issue with my notifications, but I am on Beta and using an Android Phone. I also have an iOS phone, but didn’t tether the watch to that. Here is some pictures. Note: I use the messages from the Other Application area as that provides the actual name and not only the phone number texting yout.

When you first go to notifications

When you selecty other applications

I’m also using the Play Store version. When I open the Wyze app, this is the first screen:

The notification icon in the top right corner merely toggles notifications off/on. I click on the Wyze Watch:

(Sorry, only allowed one screenshot)

Click notifications:

(Sorry, only allowed one screenshot)

But they don’t stay on and I don’t get the options everyone mentions.

Ok, I uninstalled and reinstalled the wyze app. When I turned notifications on in the app I had new options this time and two Wyze options to select. That did the trick! Getting all notifications now. Thanks! I had added and removed the watch a few times and updated the app, but not an uninstall.

IOS I upgraded the Wyze app on the phone and text messages are working. Still no email. Wyze app version V2.18.43

Did you enable email notifications? If so how?

Nice tip on the messages app from the ‘other’ section!

1 Like