Wyze Watch 47 - Notifications

Restarting my iPhone 11 running 14.4.2 fixed my notifications problem with my Wyze watch also. Thanks for the tip!

I’ll give my .02 here on what issue I had and the fix I found here in the forums. Take it for what it is worth.
I have a Wyze Band and I’m upgrading because I want to be able to read more of the message body from Gmail. So I had the band working just fine with the notification from Gmail.
I opened the box, scanned the QR code, setup the notifications for the watch and thought everything would be great. As I was still getting notifications on the band, I had not worries.

Well after a good amount of searching here, I found the answer in another post and it was something I would have never thought. It seems that after I deleted my band from my Wyze app, it also reset the Special Permission required for notification to work on the Watch. I only uninstalled the band thinking that Wyze would not allow two devices to be on the same account.

Now I’m just waiting and searching for the solution to the Gmail issue as I have seen another screen shot in a different post that show the exact thing I’m seeing to be solved by Wyze. And yes, I posted a reply to the post so Wyze can see people are having this issue. So should you if you find it.

Yeah, hopefully they get the Gmail portion ironed out. Outlook emails come through and I can scroll through them so hopefully it’s a simple change to how it needs to display the message from Gmail. Now if they were to also give an option for screen always on, adjust font sizes, adjust the raise to wake so you can fine tune it a bit better like the sensitivity if anything.(A friend has the watch as well and they wear it facing down on their wrist as in their job it’s out of the way from catching on things).

Finally had a chance to try this. Deleted watch from Wyze app. Powered phone off, restarted watch, powered phone on, added watch. Had trouble pairing and had to do it manually. Lost my custom watch faces. Unfortunately, no changes in notifications. When I turn on notifications, nothing happens. No drop-down menu, no apps to choose from, nothing. :disappointed_relieved:

Thanks this help, got it to wok

In the wyze app go to allowed notification and turn norifications for wyze. Once that is done hit the back arrow to the top right of the app, here you will see all the apps that you can get notifications from and at the bottom of the app you will see other applications, here you will get even more apps.

In the Wyze app
Wyze Watch 47
Allow Notifications (toggle on)

Nothing happens. Back arrow. Nothing new. Back into notifications - it’s off again. I posted a picture before so I’m not going to duplicate it.

In the Wyze app itself, under Account, Notifications, I have push notifications on but it doesn’t list my watch as a device, just my cameras. Email notifications and in-apo notifications don’t seen to apply to this scenario but I did try turning on everything at one point.

Any other ideas are greatly appreciated! :grinning:

If it’s an Android phone going to settings app notifications find the Wise app force stop it and clear the cache then go back and try it

Yes, it’s an Android phone. Did as you suggested. No change. :disappointed_relieved:

I think you missed a step.
In app, click on watch, then click on notifications, then allow notifications.
In here scroll down till you see wyze you may see 2 of them , you have to toggle both on. Then once you go back you will see all notifications that can be enabled.

That’s just it. I do exactly what you said. Exactly.

“In app, click on watch, then click on notifications, then allow notifications.”

Nothing happens. There is nothing to scroll to. Nothing else to choose from. Nothing.

Have you tried to completely uninstall the application reboot your phone reinstall and try again

Yes. I’ll probably try deleting the watch from the app, uninstalling the app, reinstalling the app, and reinstalling the watch over the weekend when I have time. I’ve done all these things already, but maybe not all at once. :slightly_smiling_face:

I shut of notifications in the Wyse App and then re enabled it and they started working.

Apps & notifications
special app acess
notification access

There do you see your watch? I had a wyze band but i removed it but i still see it there. I also see just the wyze. I wanted to share this with you since we both are having the same issue.

This has to be a permission issue on the phone the watch is basically just a monitor for this application. I know when I was doing it I had to dig around and change permissions several places.
I also had to do something with battery optimization or rather not optimization for that application to run the background all the time

I’m sure they’re going to address these issues and the o2 sensor issues in the next firmware update

Holy Cow! I think we did it! Not really sure exactly what you were saying but I went looking. Again, I have a Samsung Galaxy S7 Active running Android 8.0. Here’s what I did…

Settings (phone settings)
Clicked on 3 vertical dots in upper right corner
Special Access
Notification Access
Toggled on Wyze (it was off)
Exited out
Opened Wyze app
Wyze Watch
Toggled on Allow Notifications

I finally have the list of applications that everyone has been talking about!!! Thank You All so much for patiently nudging me in the right directions! I hope this helps someone else. Now to play… :grinning:

1 Like

Great news…

1 Like

I was having the same problem - nothing showing on the beta app notifications page.
Followed your steps - finally got “allow” button to stick,
but when I switch the other buttons to “on”, go out and come back they are off.
Android- Samsung A20
/edit - still not working

If you are running the wyze beta app, I would suggest uninstall it and install the current version, I would guess going to be a permission issue,

you tell what version of android you have …samsung also does not use stock android they “skin” it and that makes it harder to dig around