Wyze Unlock not working

Wyze Unlock isn’t working.
I keep getting locked out of my house.

Here’s what happens:
-ensure bluetooth and Wifi are both on (bluetooth isn’t connected to anything though)
-exit the house and Wyze auto-locks immediately
-take the trash out or whatever, come back and start there like a fool locked out.
-i pull up the app to try and unlock, but even that won’t work it just says “connecting”.

I have now turned off the auto-lock feature but i’d really like to use it.

Any tips?

1 Like

The Auto Unlock won’t work just taking out the trash because you have to first go far enough away from the lock to leave the geofence area (something like A 300-500 foot circle you can see on the map in the settings) and then return for Auto Unlock to work. I’m not sure why it won’t unlock for you manually in the app though, that’s a problem. However, for taking out the trash, there is something called “Trash Mode” which temporarily turns off auto lock for exactly the purpose you’re describing, going outside for a short time. I’ve never used it so you’ll have to look it up or wait for someone to explain it here, but it’s something like turning the lock knob two or tree times before going outside.


I changed the settings to 10 minutes for auto-lock time, rather than instant.
Still troubleshooting why auto-unlock isn’t working when walking up to the lock hands full of groceries.

Did the auto unlock ever work before this issue?

It would work about 1/2 the time.
The last time it didn’t work. In the past few days it’s been working.
I think this was due to my “power saving” mode on my samsung 8, but I can’t confirm. I am ensuring that’s off and will be testing in the next few days. Cross my fingers that was the issue.

Please share the results!

Came home today hands full of groceries and it wouldn’t unlock!!
The worst

Have you tried deleting and reinstalling it? I know you didn’t want to but you might have to try.

Reinstalling the app or the lock?

My question is, how is Wyze determining when to unlock?
Is it looking for my smart phone in-range of the lock (that’s what i’m assuming)?

I pull my phone out and stare at it, double checking that bluetooth is on, but no avail.
Once i hit the button ‘unlock’ it will unlock.

@JonathanF jmaturner needs help with the Wyze lock. :slightly_smiling_face:

The lock

I’m not sure how that works. My guess would be that the lock looks for your phone.
@JonathanF has been tagged in so hopefully he can help.

It looks like this is a feature that simply doesn’t work.
I think returning the product is my only option :frowning_face:

Have you tried the troubleshooting tips?
@JonathanF can help too!

1 Like

Yep I’ve checked each setting listed there.
Weird thing is it works about 50% of the time!

Have you started a support ticket?
The “Wyze Wizards” Might be able to help you better then I can. If you need it, they can get you a replacement.

1 Like

Hello @jmaturner,

For your android smartphone, please make sure the Wyze app has location permission turned on to “Allow all the time.”

I know there are instances where the Wyze app’s location permission is only turned to “Allow only while using the app” as that will affect the performance of Auto-unlock.

Also, there should be a persistent notification if you have auto-unlock turned on for Android. Is this persistent notification running?



Thanks @JonathanF for those tips.
-Yes, allow all the time is on
-Yes location permission is always on
-Yes, I see the persistant running notification…BUT that begs the question

It could be that my phone has restarted, the persistant running application doesn’t ‘start on boot up’. I did have my phone auto restart 3 days a week. Come to think of it, I wasn’t paying attention if the persistant notification was in place (sometimes it isn’t).

I have a feeling that’s the issue! I’ll keep an eye out.
If I have to, I’ll install an auto-run app to ensure the service stays on!

Will report back after testing.


I reported it failed yesterday.
I thought I had all my boxes checked, but somehow by Samsung was in “Medium Power saving mode”/
The samsung has 4 battery modes:
High performance
Maximum Saving

The wyze failed to unlock when i was in “medium” mode.
I think this is because it shortens the frequency of location services (just a guess).
I put the phone in high performance, left the house for a while and unlock worked when I returned.

Hi @JonathanF,
Any known issues here?

The unlock failed again, and battery mode was in “High performance”, so that’s not the issue.

When it does work, sometimes it just takes a bit long. I’ve also noticed sometimes the door just randomly unlocks when i’m sitting in the living room watching TV.

I had a similar problem and ended up returning the lock. I believe the Geofence needs to be adjustable. I live in a condo and found that I had to be about leave my complex and go about 1/8 mile from my door for it to unlock. I wrote to Wyze and said when they make the Geofence adjustable I will be back for another lock. It should be ‘doable’ as some other Geofences are adjustable.

1 Like