Wyze Thermostat not powering on

Need some help please.

Being completely honest here… I setup using the conventional workflow first… (Stupid I know) I have a heatpump. I did not realize there was two different wiring schemes.

So the 1st time I did it… it powered up my Wyze Thermostat… thought I was good. but of course was not working correctly. Powered off, reached out to support, they were not much help… I still did not know I wired it incorrectly. They were confused as well. Then the thermostat just stopped powering on… I have confirmed there was 30vac with my meter. So I though I had a defective unit. Wyze shipped me a replacement. I hooked it up the same way. same thing… Wyze unit does not power on. Then I started reading on here and stupid me wired it wrong. so I have wired it the correct way and it still does not work. Now understand… there is still 30VAC on the red and black wires. So I am still very confused. If I put my old Honeywell back in it works fine,

How am I still getting 30VAC…? is there still a fuse on the AC control board…?

Any help would be appreciated…

Post picture of wired wyze thermostat

Welcome @pjtechservices!
Can you please post pictures f your control board(at furnace) and the way the Wyze thermostat is wired. You should also try setup in the app. The steps should be pretty clear. What part of the setup process was confusing?

1 Like

I don’t have the AC unit opened up yet. I will soon. But here is a pic of the Thermostat.

Also… the app was fine and not confusing… what I am confused about is that I have the 30 volts… and it powered up before during my 1st install as mentioned above but now does not. that’s whats confusing to me. I hope I did not blow this one up… maybe there is something on control board. This is a heat pump, So I am guessing that the control board is on the air handler inside unit or is this on the outside unit? I would love if this is something simple…!

It likely connects to the air handler first. Open that up and take pictures of any wire nuts with thermostat sized wires in them. Both close ups, and zoomed out if possible You might have blown a fuse, so if there is a board with an automotive style fuse on it, show that as well.

1 Like

Pictures attached. Fuse is good. Tested it with my meter… even though it looked good… still tested. Which makes sense it does because it still is putting out 30 volts. It appears I do not have a control board external. Not on inside says inside blower motor. Does that make sense? Pics are from inside and outside.

All the wire nuts are tight and nothing is corroded… any help would be greatly appreciated

Outside unit board. 20210204_090125|666x500

Type of unit I have outside

Everything looks good, assuming that black thermostat wire is securely connected to the brown wire coming from the air handler. Have you tried resetting your wyze by holding down the button for 10-15 seconds? Your wyze might be faulty if it has power but isn’t powering up.

Even if it is not powering up at all…? I will try and see what happens.

Any other thoughts guys…?

Where do I go from here…?

If you have verified that you have ample voltage at your thermostat, and the wyze doesn’t power up, then I’d lean towards it being an issue with the wyze. does the old thermostat still work? Try it without batteries and see if it powers up and works. If the old thermostat works without batteries, then you need to call wyze and get a replacement sent out.

Well… Its working…! so I started going through everything again. Long story short. I have a totaline filter in my air handler. its the electrostatic type. take 24 VAC just like the thermostat…! it must be shorted or just drawing down the voltage to much under load. This was a very frustrating path I went down… but Yay its working now.

Thanks for the help and for reading.


1 Like

Just curious, what was the resolution?

I can’t get my Wyze thermostat to power on. I did get it to click a lot when I tried another wire. The furnace powers up but doesn’t ignite. There is nothing wrong with the furnace. Can you look at the wiring and see if you find anything? I’m running spac

e heaters while I do this :confused:

Just that I unplugged the Electrostatic filter… I will need to get a replacement for that. it was drawing voltage down under load and that is what was not powering up the Wyze thermostat. unplugged that and all is working now.

1 Like