WYZE thermostat wired properly, does not turn on!

I just spent the most frustrating 3 hours! See the photos. I followed the instructions carefully, think I wired everything as it should be. But at the end, “WYZE” did not appear on the thermostat! I double-checked all the wiring. Finally had to remove it and reinstall the old thermostat because it was getting cold in the house (I live in Wisconsin). Does anyone see anything wrong? I think I’m gonna need to return this and get another, maybe the unit is bad.

Old thermostat

Old thermostat wiring ( Note the yellow wire is blue in my thermostat cable run, and the jumper between R and Rc.)

Furnace wiring before

WYZE thermostat wiring

WYZE thermostat to C-Adapter wiring

C-Adapter to furnace wiring
WYZE thermostat not on

Yes power is on

Yes circuit is on

I don’t see anything that jumps out at me. How difficult would it be for you to run a new 5-wire t’stat cable? Do you think you can get a new 5-wire cable, tie and tape it up to your existing wiring and pull it through the wall? This is what I ended up doing with mine to bypass the need for the C-wire adapter. It worked perfectly. See attached diagram…Furnace-Thermostat-Wiring-and-Troubleshooting-Diagram

Move the green wire at the thermostat from G to C

1 Like

Great idea! I had to get some slack out of that cable run, to install the WYZE on the other side of the wall. And found it would be easy to pull a new 5-wire. My only concern is if I do that and it still doesn’t work, I need to reinstall the old thermostat…while the house gets cold (I’m in Wisconsin).

Thanks, Ken, I appreciate your reply. But I’m gonna try a new 5-wire first to negate the need for the C-Adapter.

I did the same, I used the adapter for several months then ran a new cable. There’s really no difference, but I know moving the green wire should fix your issue, I made the same mistake initially.

1 Like