Wyze thermostat not heating or cooling

I received my new thermostat yesterday and installed it today. It seems to have a mind of its own. It won’t heat or cool properly. I set the thermostat to cool 68. All of a sudden, it was 81 degrees in the house. I turned it off and reinstalled the old Honeywell. I have a furnace so no switch heat/cool setting on my app. I’m guessing the wiring needs to be adjusted. Here’s a pic of the Honeywell wiring. Anyone have any solutions?image

You have a heat pump?
if yes, from left to right, your wires are:
Aux/E, G, O/B, C, Y, R

If it heats when it is supposed to be cooling, with the wyze, go to the advanced settings where there should be an option to switch heating and cooling.

If you have a gas furnace and an air conditioner (no heat pump) then i need to see the wiring inside your furnace.

1 Like


I have a similar issue where my cool setting is heat. I currently live in an apartment and my cool setting is relatively hot, but my heat is initially cool and then gets hot.

This is my original Honeywell .


Same issue. Your orange wire is a O/B wire, your W2 wire is an Aux heat wire. You have a heatpump and probably read the top set of labels on your old thermostat instead of the bottom ones when you were telling the wyze what wires it had. Reset your wyze by pressing and holding the button, remove it from the wyze app and add it again. During install, tell it you have the following wires:
Rc = Red
Y1 = Yellow
O/B = Orange
G = Green
Aux = White
C = Black

1 Like

You’re awesome. That worked!!! If you don’t work for Wyze they should be paying you.

1 Like

This is my original Honeywell set up, I’m having the issue of it having a mind of its own

I wasn’t able to connect the green wire it wouldn’t pass the wiring code

use these labels
And keep trying on the G wire, eventually it will let you skip the error

I have a G wire cable not detected error but after few tries, I just skip it. When testing a fan it’s working just fine, I have a different problem though. My system is not cooling. It’s not kicking in the AC unit. I have a heat pump and regardless i turn on the heating or cooling function, there is heat coming out. When I install my Honeywell thermostat back in, everything is good. Any ideas?


I’d need to see the old thermostat hookup to be sure, and possibly the furnace hookup as well, but have you tried settings>advanced> swap hot and cold?

The white I took out before taking a picture.
The “swap” function is not in the app anymore ;(

Swap hot and cold should be in advanced settings if you have an O/B wire. It only shows up if you have a heat pump. If it doesn’t show up, then you need to reset your thermostat and re-add it, making sure to tell it you have an O/B wire

Hello, I hope you can help me too… Heat worked fine but now that switched to AC only cool air comes out, nothing cold seems to be just the fan

what does your wyze wiring look like, and the air handler?

? I take it you found the problem?

Please wise group; I have the same issue Heat worked fine but now that switched to AC only cool air comes out, nothing cold seems to be just the fan, my odd thing is that my control board doesn’t look like nothing in the tutorials!

And I don’t have a “C”

Following logic I did this :



Woao man can’t thank you enough , also notice if the furnace cover is not back on the AC won’t cool down … thank you again thank you thank you

1 Like

I have same Honeywell’s unit as original poster. Here is my original set up. I can get ac from the system but no heat. We have a heat pump.

I have an o/b wire and tried the aux as w2 also no luck.