Thermostat (wiring?) issues

Ok I have a heat pump system with 2 stage heating I believe. The emergency heat (strips) and regular. Had Honeywell wifi thermo before, it worked fine, just wanted something nicer looking and more modern.

Tried to install the wyze and it was a nightmare. One consistent problem, that never changed, is it kept telling me my green wire (G) was missing, even though it was clearly connected. Maybe this has something to do with all the issues.

The issues were the thermostat never worked properly, heat would always blow cool or vice versa, or sometimes half the heat settings would work and half be reversed, same with cool etc. another thing I noticed is never once at any time did the fan stop blowing, even though I tried to turn it off in the app. Also often it would give me a 4 stage test, when I believe I should only have 3 (2 heat 1 cool). I also didn’t understand either the app or the physical thermostat, both seemed uncontrollable or to have no affect on each other at times. Many times turning the physical dial did not change the display at all etc.

I ended up reinstalling the honeywell after like 2 hours of hassling with it. I have already read a lot of the posts and falsely thought “surely this must be my problem too” several times already, no dice. I tried switching the heat/cool, it would never work for all modes some were always reversed etc. I understand about the honeywell bottom vs top wiring labeling from reading posts…still was no help, nothing worked.

Anyways here is a pic of my original wiring on the honeywell

do u have a pic of the wyze tstat when it was wired, and also a pic of your control board wiring?

You followed the letters at the bottom for heat pump instead of the top letters for conventional?

These labels are for heat pumps.

From left to right, your wires are : Aux, G, O/B, C, Y, R

yes, i figured that out from reading posts here. still did not work. was randomly reversed heat/cold (but not allways, it was like 50% of checks were reversed and 50% correct, but random). But I never got to where it was totally reversed so I could do the flip heat with cold thing. and fan never turned off ever at any point no matter what. Also Like I mentioned, I constantly got the “Wire G missing” warning even though it wasn’t. I just had to “skip” that to proceed every time. But I’m wondering if it has to do with my problems.

also another thing not sure it’s relevant and i mentioned before, but many times it was doing a 4 stage check for me, when i assume i have a 3 stage unit. i cant remember if it did that every time.

unfortunately not pic of wyze wiring, but i would have just connected according to the labeling for bottom heat pump, at least later on once i figured that out.

also how do i do a pic of control board wiring? is that mean at the hvac unit?

one thing i noticed is i did screencap the app instructions for one of my wyze wiring runs (of course there were several as i learned new info from here), and it looks like i may have confused rc for r. at least on that run. i cant say if i did it every time, but i suppose that could have been an issue.

still concerned about missing g wire alert which never went away.

i guess i can try one final run making triple sure i’m using aux, g, o/b, c, y, r, i know its still gonna throw the missing g wire alert.

i have a lot of work over the weekend so i wouldn’t dare try again until monday…if at all kinda debating.

I can tell you that you definitely did not have it set up properly, as your aux wire is labeled W2 in your image. The wyze will want you to put that wire into W1, probably.

I did not use those labels. They were the old labels which I replaced with new Wyze labels accordingly. Also, I simply used the picture as a reference of what was what. The labels were not really used as a reference, although I did correct them.

To simplify: A)The wires are now correctly labeled B) I used the picture (on my smartphone) as reference not the labels.

You should have a total of 3 stages. 1: cold 2: heat pump in heat mode. 3: heat pump in heat mode with heat strips. There might be 4 tests, if the wyze allows you to run the heat strips independently of the heat pump. When you are in the app, it will ask you what is on aux, and you should answer electric heat. Have you checked to make sure the G wire is actually hooked up at the air handler? Sometimes it is left disconnected by the installer. From your mention of fan constantly running, I wonder if the C wire somehow got hooked up to G. Did your old thermostat work when there were no batteries in it?

Not sure about the old thermostat working without batteries. They’ve always been in there I guess. Old Thermostat btw is the current one as I hooked it back up since I couldn’t get the Wyze working.

Now I’d like to look at the control board wiring at the air handler, but it’s in the attic and Im worried it’s a bit over my pay grade. If I’m mentioned it a few times I’m not handy and bad at do it yourself projects although I get by.

I guess I can just open the big panel where what looks like power wires go in at the air handler to see the control board?

I’m kind of reticent to do anything in the short term as we’ve had a cold snap and not having heat would be a big problem currently should I mess anything up. I did find the air handler manual in the attic. It shows 3 types of wiring. Single speed cooling 2 stage heat, single cooling 1 stage heat, and heat pump. Obviously I have a heat pump so you’d think that would be the one, but it’s wiring diagram in the manual doesnt match mine at the thermostat. Nor does 1 cool 1 heat wiring. The 1 cool 2 heat wiring most closely matches mine (at the thermostat), it shows W2, W1, G, Y, RC and RH jumpered together. Total of 5 wires where I have 6.

The single cooling 1 stage heat wiring diagram shows just 4 wires at the thermostat ( W, G, Y, R) and the heat pump diagram shows 8 (F, B, X2, W, T, G, O, Y ,R). So these dont seem to come close to the actual wiring at my Thermo.

I believe it’s an American Standard (Trane?) Air handler if that matters. Model TWE-IN-2A. It’s a Goodman heat pump unit I believe

I found the manual online and here are the wiring layouts I referred too

Open the air handler panel and take pictures. Don’t touch anything. just take pictures and post them here. If I need to see a specific part in more detail I might ask you to make it clearer by moving some things around, but I should be able to spot any issues with the wiring pretty quickly.

ok, i scrambled up there, perched precariously on the crossbeams in the dark and was able to pry open the panel. however i was not necessarily able to get 100% clear shot of the board. i also post one clean pic of the wire nut tangle where the thermo wires are attached to the boards. from what i noticed, it seemed mostly color for color, eg green attached to green, yellow/yellow, etc. there were a couple odd ones like brown and two reds in the same nut, maybe you can see them in the pic. The board i couldn’t read well either, the one you can 100% clearly see is the green “G” terminal up top. The 4 to the side i couldn’t really read, and not really sure what the rest of the stuff has got going on. I was able to zoom and rotate one of the pics and the two blue wires going to the top right, just below the green, appear to be labeled j7 and j8?

Everything looks correctly wired.
I don’t suppose you have a picture of how your wyze was wired up? Assuming it was also wired correctly, I would have to assume your thermostat is simply defective and is constantly calling for the fan to run.

Unfortunately never took a pic of the Wyze wiring. Probably will give it one more run and take pics Monday, but I’m not too optimistic.

Do you think another brand, like a Nest, would work for me?

Things have gotten worse now, since I put my old honeywell Thermo back on, things no longer work. I first noticed the fan on control no longer works. Turning it to “on” does not turn the fan on. The latest issue is that the AC no longer comes on AT ALL. The fan doesn’t even turn on. The unit is also coming on and making a loud racket for a few minutes while it’s not actually blowing heat. I have NO idea what this is. I cant see how its related to the thermostat, but yet NONE of these problems existed before I attempted to install the Wyze. Oy. The Honeywell was working 100% for years before I tried to install the Wyze. TBH Wyze is kind of a nightmare so far. I also pre-ordered their watch, found out there is no way to cancel it, and now the ship date has slipped until April. Yes it’s only a $25 watch and unrelated but it’s a really bad look. This company tries to act all friendly but yeah reality is not going well.

Again unrelated to the wyze maybe (not really cus I only opened the air handler because of issues with the Wyze) but I noticed that air handler instructions said if you turn off the HVAC breaker for more than 3 hours, then you must turn off the thermostat for at least 3 hours after turning the breaker back on, or you could damage your unit. This is annoying me too as what the hell does this mean? how could that damage anything? I can’t find anything about it on the web. The thing is most likely just that occurred, when messing with the Wyze I probably left the breaker off more than 3 hours, and then didnt leave the thermostat off for 3 hours, because I had not read the warning not to do that, yet. I cant help but wondering if it caused these issues.

I know the fan works because it blows when heat is on. Currently heat still works, lucky me it’s winter. But there’s still the loud buzz/hum noise the heat pump is now producing when the air is not blowing for a short time, driving me freaking crazy.

I’m thinking a possibility is the Honeywell Thermostat is now broken, perhaps with the handling removing it putting it back etc, it suffered some damage or something. I dont know. This week I hope to work on all these issues more. My plan is to try the Wyze one last time. Most likely I’m out the 50 dollars as I think it’s too late to return it. I’m also considering dropping 130 dollars for the cheap nest model,. as it seems to be rated well. But between it and the Wyze I’ll be out 180 bucks for advanced thermostats I don’t even use the features of, which makes me want to kick myself. If BOTH the honeywell and Wyze are defective this would be sort of a check. I actually dont care about advanced scheduling, I live alone in a small house and set the temp manually always. The reason I use these thermostats is the wifi allows me to control them from my bed at night with alexa. I thought the Wyze would provide a better app (honeywell app looks crap) and it looked/felt nicer, Oh and the honeywell is a nightmare if you ever lose wifi connection, very not user friendly to reconnect. and I thought for 50 dollars the price is right on the Wyze. Well so far the price is very wrong.

Of course the nuclear option is I’m going to have to have a tech come out, which is going to cost me at least the 80 dollar service fee. Again, EVERYTHING was working perfectly before the Wyze. Now I’m afraid my heat pump may be damaged, due to the loud hum noise at times for no reason at all. At least the parts should still be under warranty a couple more years.

Tomorrow I pull the Honeywell and look around…

Give me a clearer shot of the wire nuts and where each one goes.
In this image it is hard to tell where things are going.

As for the warning on your hvac unit, that is because when you turn off the breaker to the unit, the heater coils that keep the oil in the compressor warm also turn off, and the oil needs to be warm in order for your compressor to be happy running in the winter. You’d just need to pull the thermostat off the wall for 3 hours after giving it power to prevent damage to the compressor, but only if you had the power off for at least 3 hours - long enough for the oil in the compressor to cool off, I’d assume.

Ok. I took another hack at it. I hooked up the Wyze again. Paying very careful attention to correctly wire it etc. Well, at least I understood the thermostat functions on the wall this time, how to turn it to heat, cool etc. Unfortunately, nothing worked. With the Honeywell I was down to only heat Which again, is ok for now this being winter), with the Wyze all functions did not work. The thermostat will audibly click and send a signal, the outside unit runs, but nothing comes out of the vents on any setting anymore with the wyze.

As I mentioned the outside unit was running (or at least the fan is whirring, I’m not an expert) all the time with the Wyze. Even with the thermostat set to off, for a good period of time. But no air coming out the vents at all inside.

I went back up to the air handler and got a better pic of the wires. I also checked the purple fuse at the air handler control panel, it’s labeled “e”. Whatever the case, it seems fine, not blown. My hope/instinct here was a fuse somewhere.

I did notice something else, I think I got the breakers mixed up. At my box I have two breakers, the bottom set on one side labeled “A/C”, and the 2nd to top on the same side labeled “heat pump”. When messing with the thermostats I would cut both off. However, I am pretty sure I was messing up, and flipping the top breaker off (which is to the range, not the AC), not the 2nd to top, much of the whole hours long initial time I was trying to install the wyze. because I was just absent minded or got confused. So basically I may not have been cutting power to the “A/C” (not sure what this is, do they mean air handler, or the heat pump has two fuse sets?). However, I may have. I dont know. It just occurred to me that when I flip the range switch the range clock needs to be reset and blinks, and I think I would have noticed/remembered resetting the range clock, and i dont recall doing that anytime recently.

Anyways, unless speadie has a breakthrough when he sees the new wire pic, I’m at the end of my very limited scope. It seems time for a HVAC service call (which means $$, which makes me sad and a bit angry at Wyze)

Here is the new clear pic of the wires at the air handler, all zoomed in and spread apart. Thanks speadie.

E is a backwards 3 for a 3 Amp automotive fuse. how did you check it? Sometimes they don’t fail in a visible manner.
The symptoms you are describing (outside unit working, inside unit not working are symptomatic of a bad fuse, and it looks like the fuse is only protecting the heater/blower circuitry on the blower control board.
The wiring all looks correct.
I’m assuming your wyze is wired as follows:
red> Rc
white> W1
blue> C
yellow> Y1
orange> B/O

yes that’s how wyze is wired,

another odd thing wyze hooked up nothing working, I’d given up on it for the night and was just going to use a space heater in my room and call HVAC in the morning (it’s only low of 50 tonight anyway) i’m sitting here and suddenly the vents come on for the first time in two hours, randomly. sigh. It was putting out mild heat, i felt the vent air, so it seemed like heat pump air not strips, if that means anything, thermo was set to 72 a and inside temp was 70. It heated it to 72-73 and cut back off as it should. However then temp dipped to 71 inside and it hasn’t come back on. I attempted to jog it on by turning heat up to 74, still hasn’t come back on in 30 minutes. Just weird inconsistent behavior.

This is the most bizzare stuff , I dont even know what I’m going to tell the hvac guy. Umm yeah it works sometimes, but sometimes not, and it seems too loud, and like it’s straining when the vents arent even blowing inside and I dont remember it doing that before but maybe? and I tried to replace the thermostat, which started all the problems, here’s two thermostats, I dont know if either is good, I’d like this one (the wyze) to work lol.

Also remember before this with the Honeywell last working stage was heat working, AC not working (also fan on control not turning fan on). Doesn’t that contradict your heater fuse theory?

The fuse looked clean, no burn mark and continuous metal z inside. I suppose it cant hurt to replace it hopefully I have one laying around. I guess I can try that before calling hvac tommorrow.

EDIT yet again: heat came back on maybe 20 minutes after I turned temp up. Maybe the Wyze just has a really long delay, or doesn’t cut on until like 4 degrees below the target? interior temp was 71 for maybe 20 minute’s, target was 74, it cut on finally. i turned the target to 70 (because no way I actually want it to be 74!), it cut off fairly promptly. I’m scared to try AC, I will tomorrow,

The wyze does have a fairly large temperature gap for some people. Sometimes the temp might fall 2 degrees below setpoint and then heat to 2 degrees above setpoint. If the indoor fan is running then the fuse is good. If you have an energy monitoring system on the heat pump, they can introduce a long delay after a power outage - or a circuit breaker power off.