Help fixing missing wiring for thermostat

Hello. I tried wiring up the thermostat and have the missing wire error for Y2 (blue wire), G (green wire) & * (white wire). I double checked and the wires are secure. I also did the uninstall and reinstall the device in the app and get the same error message. Screen shots of the wiring selected, the old thermostat wiring and the Wyze thermostat wiring. I’d appreciate any assistance.

Welcome to the Wyze User Community Forum @teamrizzle! :raising_hand_man:

I am going to ask @speadie to take a look at this and post in for an expert opinion. The only thing that sticks out to me is that the White wire should probably be designated as “W or W1” in the setup and not “E” which would result in it going to the W1 on the Wyze Thermostat instead of the “*” with the Pink going to the W2. But, the G and the Y2 issue is beyond me.

When you went thru the setup, did you tell the app that you had 1 set or 2 sets of labels. I believe you have a Heat Pump there since you have the Orange wire for the reversing valve. With a Heat Pump, you have to tell the app you have 2 sets of labels. That is the only way it knows to operate the unit like a heat pump. If you tell it you have 1 set of labels, it thinks it’s a conventional unit and operates it differently.

1 Like

Do you have a picture of the air handler/furnace side of the wiring?

Normally I’d say just try again until it lets you skip. as long as everything works properly, you can leave it like that, but if you don’t get fan control there could be a problem.

Thanks! Please take a look at the attached picture. The model of the air return is MC48C3XH1A. There is one picture of the overall wiring and a spliced image with a close up. I really appreciate the assistance.

hmm… some splicing in there, but as long as the fan works, you should be able to just press try again multiple times until it lets you skip the errors.