Thermostat "missing wire"

I have installed the Wyze Thermostat this morning and the app installation process is telling me that I have a missing wire (G). The G wire is there and connected properly and I have connected and reconnected several times and the app still gives me this error. What can I do to fix this?

1 Like

Have you cut your G back and restripped the end? and I am assuming its snug and not coming out?

Had the same error. Skipped over it and went to next step and it worked fine. The voltage on R to G was 16v not the 24v it was looking for but it was OK.

Thank you! That did work, however now my new issue is that the test of Stage 1 Heat blows cold air and Stage 1 Cool blows warm air. So I am not sure why that is??? I have quadruple checked all my wiring.

Go to the Wyze app settings and toggle the “Switch Heat & Cool”. Some systems require the Y & O to be energized in Heat instead of Cool.

Worked!! Thanks so much!!

Great! Mark this thread as the Solution for other users. :grin:

Mine says I’m missing y2 wire. Also house was warm so I set to cool and and house wasn’t cooling. Had to switch back to old thermostat. Also I never saw the toggle for the switch heat to cool.

Do you have 2 Stage Cooling?

This feature is only visible for Heat Pump Systems.

I have a heat pump system. My old thermostat had the y2 wire but when I install it and mark it wyze says its missing.

Is your Heat Pump 2 Stage Cooling? What’s the model number?

Old thermostat doesn’t have a c wire connected. But there is a c wire in wall and I did have it connected to wyze and wyze did turn on

You actually have R, Y, O, G, AUX, and E. The old thermostat can be used on both Conventional Furnace or Heat Pumps. The app is correct saying the W2 is missing. Make sure you selected “Heat Pump” during the setup process and use the wires R, Y, O, G, AUX = W1, E = W2


The app was saying y2 was missing. Not the w2. So I need to resticker my wires to the letters underneath?

Yes, that is correct.

Ok ill try it here in a little while and let you know. Thank you for your help so far

1 Like

I wired it up like you stated. Then I get this message during wire check. I ran the system test and not getting cold air and outside unit doesn’t turn on. Also it says its like 32 according to thermostat. Any other advice

Did you do a reset on the thermostat? Chose Heat Pump and them Forced Air?


It doesn’t give me option for heat pump