Wiring Detection issue for thermostat

I am in the process of setting up my thermostat and have all wires installed, but the app continues to say my W2 is missing. I have tried this 3 times, ensuring the W2 is installed and secure. Anyone else run into this issue?

Seeing a similar issue with the g wire showing missing even though it is connected on both ends. Replying in case a solution appears here.

Mine says the y2 is missing. Also house was hot and I set it to cool and wasn’t cooling the house. Temp just kept going up. Had to reinstall old thermostat

Welcome @rakoskej

Could you provide a photo of the Wyze backplate with wiring along with inside the furnace or air handler?

See pic

Did you choose “Gas” during setup? Then “Forced Air”?

Here is another pic

There was no option for that in the app during the setup.

Here is my existing thermostat setup

I pulled my manual. I have a HEIL N9MSE, which is a single-stage gas furnace. That being the case, I would not have a W2 wire anyway. So, the W2 currently connected to my dummy thermostat is doing nothing. Correct?

On your system, you wouldn’t have a W2, it should go into W1 instead. Re-run setup without the W2.

I too am having similar issues. All wiring seemed to be correct, doubled checked it several times and received the Wiring Detection error as well. Mine is only a 4 wire of which the G (Green/ground) turned into C. Thoughts/Suggestions so therefor i think it’s stating it’s missing G.

Yes, however mine is stating that W1 and W2 are missing. I only have an item for W1 and nothing for W2. I have reset three times and still receiving the same error.

For whatever reason, the HVAC company that installed the thermostat when they installed the new furnace, attached the W2, even though there is no second-stage on my furnace. So, I have reinstalled the WYZE thermostat, without the W2 wire, selected Gas and Forced Air and setup is complete. It is working just fine.


Glad to hear it’s working! Please mark Solution for other users who may have this issue.

Brian, any thoughts towards what would cause my wiring issue is as i only have four wires? Attached is original wiring. Thought it was straight forward but it doesn’t seem that way, where do i turn for assistance.

Hey there,

Do you have a conventional system or a heat pump?

It seems like you may have selected heat pump. You may need to start over the install and install the c wire adapter first before continuing.

Also did you utilize the wire c adapter. The Wyze kit comes with it.

I believe once that is installed and you connect all the wires (4) coming from your thermostat into the c wire adapter and the 5 from the c wire adapter into the board you just showed us matching the wires to it’s letters you will be good to go. Then start the thermostat setup.

The c wire adapter that Wyze provides sends power through the “g” wire to power the Wyze thermostat.

I hope this helps.

Thanks for the reply. Tried it again from the beginning but still no luck. Where does it prompt for heat pump, is that the high voltage system? No, i have a conventional Heil forced air system.

Disregard, i bypassed the wiring detection error and it seems to test out (AC and warm air) just fine.