Wyze thermostat dropping Wi-Fi

At various times and for no apparent reason our thermostat shows, “Device offline”. All other devices are connected and working fine. I can’t find any settings to try to reconnect it to Wi-Fi and it eventually just seems to reconnect.

The thermostat works great, but this little issue is baffling. Does anyone have any suggestions?



I am also having this device offline issue. Have you found a solution?

Having this wifi disconnect issue every couple of days, but requires power cycling to get it to reconnect. This has been happening for a couple of months now. Really annoying when trying to access from out of town via my phone. All other Wyze devices (camera, sprinkler) seem to never lose connection. I have an wifi access point less than 10 feet away and still happening. No response from emails to tech support???

BTW, I do have the latest firmware update.

Don’t upgrade thermostat firmware past 1.2.1 that is when issues started.

Any way to revert back. Seems I recall the issue started after a firmware update. Thanks for the response.

I too have this issue with two of my homes that are rentals. Cameras and all ofther Wyze stuff stays connected without issue. This outage is causing me deep issues in preparing the homes comfort fopr my guests, and to save energy (go green) when not being occupied.

I suspected that it was an issue with DHCP and the possibility that another device took the IP address away from the Thermostat and the Thermostat did not initiate requests to get a new address. So I programmed my router to make a IP reservation outside of the DHCP pool, thus no other devices would have an opportunity to take the same IP address. Sad to report that while this may be somewhat more stable, it has not proved to be the magic solution.

Please Wyse, solve this connectivity issue quickly, and simplify the procedures to connect to a different SID without doing a completely new install procedure. Also, while you’re at it, let the user select the safety min and max at any value we the user/owner selects. I would like to be able to set the min to 32f, let me have that choice

Upgraded to ver 1.2.6 beta today, will see if this is the fix we have been waiting for

I have three WYZE thermostats: two at my home and one at a remote cabin. The two at home work just fine. Remote one drops offline continuously. I took one of the ones from the house and swapped with the one at the cabin and the problem stayed at the cabin, so Wi-Fi there is some part of the problem.

I’ve poked around in the cabin router (a Calix 844G-1) off and on for months, looking for something that might interfere. Finally found a setting for WMM (Wi-Fi MultiMedia) that supposedly provides Quality of Service and traffic prioritization. Exactly the kind of thing that different router vendors might implement differently.

So, I turned that feature off five days ago and the thermostat hasn’t been offline since. I won’t claim this as a fix, only that this is the longest my thermostat has stayed online in a long while.

If this is the fix, I’ll be thrilled. If not, I’m ready with a Rube Goldberg fix that will allow me to reboot the thermostat remotely using a WYZE plug. Let me know if you would like the details on that.

If you can, the first thing you should do is upgrade your Router to a WiFi 6 level router.

Newer routers are equipped to handle all the chatter all these IoT (Internet of Things) devices produce. More RAM, more processors, able to handle more devices.

I just switched to the Wyze Pro Mesh WiFi and I love it. All the cameras open pretty quickly (7 of them). No timeouts.

It’s said often but most issues with Wyze can be solved by getting the proper network equipment.

Does your Wyse Pro Mesh WiFi device get insanely HOT!! I know they warn about this, however it is way too hot!!! This cannot be good for the electronics within, and all that heat is consuming energy to generate. I’m not happy with the unit overall, and the heat issue is too concerning for me.

Did NOT fix the issue. So disappointed in WYSE


I have been having the same issue with both of my thermostats in my home. That is in addition to nearly every other Wyze device. So it is not a Thermostat issue alone. To your point it does appear to be related at least in part to DHCP renewal. I lowered my DHCP lease times to 3 hour lease cycles and that made things much worse. Now all Wyze devices were offline when their lease expired.

I had the thought that the issue may may be due to how the Wyze devices are attempting to renew their leases and or the timing around that aspect. My router will attempt to assign the IP address to the current lease holder before putting the IP back in the pool. It was there where I found my issue, at least in part.

It appears that when the Wyze device sees its lease has expired it goes in to broadcast mode to retrieve a new lease. That is while my router it attempting to renew the existing lease. Between the two the Wyze device has an insanely low timeout which is lower than the routers renewal timeout.

The really odd thing is that the Wyze device goes in to a loop and keeps broadcasting for a new IP address it eventually gets one. So you have an assigned IP address, its even pingable, but the device shows as offline in the Wyze app. Seriously?

It seems like there is a loop somewhere in the Wyze software that once the initial DHCP lease request fails there has to be a timer “what I am assuming to be a AWS based device status microservice somewhere” which updates the Wyze app that the device is offline. As it should.

However, when a new IP address is obtained there does not appear to be a device process to tell the “status microservice” that the device has an IP address and is ready to communicate. Even though the device is on the network it remains offline. I am then assuming that this is the basis for stock answer to “just power cycle” the Wyze device. That the startup sequencing assumes a new IP address and as such properly registers with the “status microservice” and the device comes online,

If that is the case and Wyze does not want to fix the issue then they should reboot the device each time its DHCP license expires. It appears to fix the issue as the router sees a new device register with the routers access point, renews the lease and the device properly registers with the “AWS based Wyze status microservice” and then triggers the update on the remote app.

In my case at one point I had a house full of devices, all of which had assigned IP addresses, none of which were “online” as far as Wyze is concerned. The only way I have to resolve / workaround the dam issue is to reboot the router. The reboot clears all leases, and starts the lease process with a clear table, causes all of the Wyze devices, along with every other device in my house, to register with the router like a new device.

To workaround the issue I have my router scheduled to reboot once every 22 hours with Lease times set to 24 hours. That way the leases never expire before the router reboots and the DHCP tables are cleared once a day.


Have you tried a different router or thermostat?

To truely troubleshoot it, you would need a 2nd thermostat and a 2nd router.

Scenario 1 - Your Router / Your thermostat - Test. It’s broken (what you detailed).
Scenario 2 - Different Router / Your thermostat - Test ???
Scenario 3 - Your Router / Different Thermostat - Test ???

Honestly though, it sounds like your router is having issues. I’ve not seen that across my 25 Wyze devices (all types of them). I had a TP-Link 1800 and now the Wyze Pro Mesh.

No issues. A good router seems to solve all these weird issues with devices.

I concur with your analysis!!! Issue is DHCP related. Different between different Wyze products. I Implemented a relay (NC) connected to a WYZE outlet, to interrupt the red-common wire to force the Thermostat to reboot upon demand. Unfortunately, I must use this more that occasionally.

I concur with your analysis!!! Issue is DHCP related. Different between different Wyze products. I Implemented a relay (NC) connected to a WYZE outlet, to interrupt the red-common wire to force the Thermostat to reboot upon demand. Unfortunately, I must use this more that occasionally.

I have a friend that has 3 thermostats. All were losing connectivity. Issue is that the home is 600 miles away and is a AB&B rental. So this is a big issue when he cannot prepare the home for new guests and also put the home in energy savings when not rented.

After a LONG-protracted back-n-forth with Wyze, they finally sent him 3 new thermostats to try. I installed them for him. They are on version firmware version 1.1.8. They have been installed a little over a month, and have NOT LOST connectivity, NOT EVEN ONCE.


No, when I think about it I would have to ask “Why would I bother?”. Are you really advocating changing out a core component of my network to find a compatible router for a consumer level device like a Wyze Thermostat? Wyze in no way publishes a list of “approved devices” or why one device would work better than another. There are articles deeper in their support and blogging areas which provide some insights on very specific routers like ASUS and others with very specific features to enable/disable to fix apparently known issues with those specific routers.

However, you have to really search for those solutions. When you do find those solutions and look very carefully at them they are not really router specific they discuss what could be considered common protocol options. Options which should be included in core documentation.

I think those options are not included in the core documentation because it would be confusing and could potentially scare off the average consumer who would not know how to modify their router configuration.

In the end I have well over 100 different different devices( IoT, virtual machines, Laptops/PC’s, SAN storage, streaming devices [Chrome Cast, Roku, etc.], terminal appliances ) none of which have any issue with the way my network has been designed. I work professionally as a network / cloud architect and can tell you that I both personally and professional follow fairly standard networking practices/standards.

Is it really on my head to have to go out and “find” a router which somehow works with all of my Wyze devices? I could be at that a very long time if I go out and just guess and buy different routers hoping that some stock consumer router hopefully/magically fills the need. The other attack at this is to lower my security settings or place all of my Wyze devices in a VLAN which is outside the control on my NAT. However that would open those devices to every jackass who plays hacker on the internet. That’s all I need is to have my house go to 120 degrees in the middle of the night or for someone to spy on me using my own cameras.

No, I think Wyze has two paths here. The first is to use their newly released mesh router as the approved standard for all of their WIFI devices. I mean really work out the kinks on that device and make it the baseline for all of their devices. Then say if you want 100% no problem buy the Wyze router and use Wyze devices on the Wyze router. To date they have not even done that as there are all sorts of issues using their own devices on their mesh router (plus there are a lot of issue with the router itself at the moment).

I would happy add the Wyze mesh router to my network if Wyze would stand behind it as a totally compatible out of the box solution for all of their WIFI devices. If you were to ask my opinion, it is a bit of an embarrassment that it has not yet happened.

The other approach would be to again use the newly released Wyze mesh router as the baseline. Build a set of standards to compare the consumer level router vertical leaders stock configurations against. Mapping the Wyze router protocol features against the likes of Cisco, ASUS, Netgear, TPLink would at least give you a starting point to note what was different. If for no other reason than to know what is available and is working on the Wyze mesh router and what may be different on the device you are working with. At least that would give you the knowledge of where to possibly start and what may be causing an issue.

I suppose I envision the Wyze testing lab something using an old Linksys BEFW11S4 (circa 1999) using a 2.4 GHz wireless band with a 802.11B / WEP wireless standard (as many of Wyze’s devices still only work correctly against 2.4GHz spectrum). The router is probably on top of a microwave oven which is above a garage and is being tested with a guy with a plate in his skull. Every time someone nukes a bean burrito the WIFI signal is blown out, the guy wets his pants and the garage door opens.

In all seriousness I really do not think it is incumbent on the consumer to guess at what the right router to use with Wyze devices. Nor do I think it should require the purchase of a specific router. It is all networking after all and everything should be resolvable via configuration. To resolve these issues all that would required is decent documentation and a published standard for people to work against. That and perhaps Wyze making their QA/UAT process a little deeper than: "Does the Wyze device get an IP address when connected to a circa 1999 Linksys wireless router in a DMZ.

In the immortal words of Chris Carter (formerly of the Minnesota Vikings) “Come On Man!”

It’s not the router. It’s the thermostat’s firmware.

That is kind of my entire point. You know the old statement “If there are no Weirdos in a room then you are the Weirdo.” Well if everything else on the network appears to have no issues then it is the devices that is having the issue which is the problem.

Agreed and verified in several of my homes. And the problem DOES NOT exist with firmware 1.1.8 Wish Wyze would give us a method to re-install firmware 1.1.8. Please Wyze, please help!!!