Thermostat connection issue

Have had my thermostat loose connection a couple of times now. Don’t remember what was going on the first time, but this time it occurred after the new firmware update. The first time, the only way that I could get it to reconnect was to remove the thermostat from the Wyze app and re-add it. A pain in the ass! Last night that wasn’t even working. Just sat there and said pairing.

Okay, here is what finally worked for me and maybe try it before removing the thermostat. Go into settings, apps, go to the Wyze app and Force Stop it. I did it twice just to make sure it stopped. Reopened the Wyze app and it was working.

BTW, I am using an android phone and am on Spectrum with their Technicolor modem/wifi router.

Hope this works for everyone and maybe it will give the Wyze Support Crew an insight into the problem.

Let me know if this helps.

Is the thermostat showing no wifi on the display itself or just the cloud lost icon in the app?
If it’s the later, just restart your router and it should go away.

Actually it was showing both. The first thing I tried was resetting the router wirh no luck. I’m thinking the wyze app always running in the background might have something to do with it and hence the need to force stop the app and restart it. I also tried shutting wifi off and on with no luck.