Lost connection to Thermostat after update. Any Help?

Hi. I installed my new Wyze thermostat early January and everything worked perfectly. I had no problems and the setup was easy. Then towards the end of January, I noticed I could not connect to the wall unit from my phone. It said the device was not available and to check my network connectivity. Network appears to be fine as everything else is still connected including my other Wyze devices. I could still control it from the wall unit just fine, just could not from my phone.

Read some troubleshooting guides online and every one said to reboot the wall unit and reset to factory defaults. I did, but now it just sits there at the Wyze screen and my phone can not pair with it. I’ve tried rebooting several times and nothing. So basically it’s not working at all now with us now getting into single-digit temps. I removed it and placed a “dumb” thermostat in it’s place for the time being. It’s working fine.

I happened to check and saw that the app updated it’s software around the time I lost connectivity. I can’t confirm if that is it for sure since I didn’t notice it right away, but it was within the same week. Maybe related, I also updated my iOS to 14.4 which addressed some Bluetooth issues. Makes me wonder if updating to iOS 14.4 changed something with Bluetooth, and the Wyze update did not address it or compounded it. I don’t know. That’s my best guess.

I’ve tried requesting help from Wyze support but all I’ve received is a generic automated message suggesting I try everything I’ve already tried, or to send it back for a refund. This has now been over a week and a half since I submitted with no response. I really like the Wyze products, and want to get this to work, but if I can’t get this resolved, I guess I’ll have to return it.

Anyone have any ideas?


do you have another device to try completing setup?

Tried my wife’s phone but getting the same issue, and she updated same time as me if it’s the app update. I may have an older iPhone that might work but it will be installing the latest version which I think is the issue. But I’ll give that a try. Might have to wait until we are back above freezing here though. :slight_smile: