Thermostat bluetooth issue

I just installed the thermostat yesterday, I have it wired with C power. It powers up and displays the Wyze logo. Using the app I go through the setup to connect the thermostat and when it comes time to connect through bluetooth, it says that it can’t find any thermostats and to make sure my HVAC system is turned on (which it is). When I search through bluetooth devices in the area, it detects it as CO_EA1 but it won’t pair because it says the app is in control of that. The app is not connecting to the thermostat on my phone, or my wife’s phone. Our phones are up to date and out Wyze apps are up to date.

  • Thermostat is wired Rc, Y1, G1, W1, and C

have you tried a reset of the device. I believe when powered and stuck on WYZE logo, press and hold button.


I just tried a reset. Had no effect on operation, still can’t connect.

I am having the same issue

I am too. I have two separate furnaces. It was setting up my upstairs and not my downstairs, so my husband suggest I delete the updtairs and start again with the downstairs, and now neither one will pair.

I installed the thermostat and it is defective, as neither my phone nor my tablet see the device when searching via Bluetooth. The Wyze app does not find it. I have reset the thermostat. My phone and tablet find eachother, so it appears the Bluetooth radio in the thermostat is non-functional. Very disappointing. I am waiting on an initial response from Wyze Support.

My husband was worried about the house getting cold last night, so I pushed the button on one of the thermostats for much longer than I had anticipated, but it did come on eventually, and it worked. Then I did the same on the other thermostat. We woke up to a warm house. The trick, for me, was to just lay on that button until it did what I wanted.

I have an Android phone and it cannot find the thermostat, Tried the wife’s phone and it did not work, Tried the son-in-law’s and it connected. Differences his is an Samson, ours are Lg’s

@SabrinaC - so I tried the “lay on that button” trick and it worked.

I tried resetting it 3 times and unplug it & checked everything. With my phone that’s LG v40 & LG G7 didn’t work. As soon as I use Apple phone it worked…
Hopefully it will fix with future update…

UPDATE: I tried paring with my wife’s Samsung Galaxy S20 and it paired and seems to be working so far. After it completed initial setup it told me a firmware update was available, so I updated, but I thought it was odd that I needed an update only minutes after installing the app from the Google Play store.

I am having the same problem. I am wired the same way as the poster Sashi. I am using a Samsung Galaxy S10. I’ve tried pulling the thermostat off the wall and re-mounting it. I’ve tried holding down the dial button on the thermostat until it asks if I want to reset it. I still can’t get it to pair with my phone. I just got off the phone with support and the gentlemen, while very friendly, doesn’t appear to have ever used the thermostat and says this is the first time he’s had this call.

Yes, I am able to reset it via holding in the dial but that has not resolved the issue. I will try to connect via a different phone this evening. Thanks!

Glad it worked out for you. I will try a different phone tonight. Thanks!

I was having similar issue pairing bluetooth to my S9+. It finally connected with my Amazon fire tablet. Not sure this helps anyone

My wife and I both have S10e’s. I’ll try my fire tablet after I charge it. If it works, I’ll be in a state of both joy and disappointment. Hopefully their programming team is aware of this issue and are working on a solution.

Do you happen to have a Samsung Watch paired to the device you’re using to setup the thermostat? If so, try disconnecting it, then try connecting the thermostat.

I don’t have a smart watch of any kind. I tried my Kindle, no luck.

My wife unpaired all her bluetooth devices and tried, also no luck.

I just received my WYZE Thermostat and my wiring is straight forward (R,Y,W,C,G). After installation the WYZE logo appears on the thermostat but cannot connect to the BLUETOOTH. Since it was cold I had to uninstall Wyze thermostat and re-install my old thermostat and to turn the heat back on and the furnace is working fine. I haven’t checked the wiring at the furnace location yert. Will double check the wiring tomorrow at the furnace and will try connecting one more time before returning the units.

My wyze thermostat is the sane way. It will not connect to either phone nor tablet. Our phones are up to date on versions and bluetooth models. I believe the thermostat is a dud as it will not correctly put out a bluetooth signal. The latest response we received was blaming out phones, which we know is not the issue. All our wyze devices connect great including the wyze bands and headphone.

Mine is powering on but not finding it in order to pair.

Here are my wires on my current unit.