Wyze Scale S only display in Kg after update

Yeah, weird that we are using different model scales and experiencing the same bug. It must be something with the new app causing it or the server or something. IDK. Will you submit a log for your scale and post it here? I will see if I can send your log and my log to someone to look at.

Just to be clear, a log is not a support ticket, and nobody will be responding it directly. It will just be collecting information from our scales so a dev can look into it. We may not get a response back since it’s not a support ticket, but if you’d like to open a support ticket, you can contact support about it. If you do contact support, maybe submit the log for the scale first though so you can give it to them to pass on. If you do that, you are more likely to get a response back eventually. If you do, let me know. I plan to just ask an employee to pass the logs on to the devs and hope they figure out what is going on whether they respond to me or not. Support could possibly have more info though if other people have called in about this. It is too much of a coincidence for us to be the only 2 people having this start around the same time though. Very weird.


Let me figure out how to get a log first.
Then proceed after that.

Ok - logID 887746.
That’s the only thing I see but no details beyond that.

Thanks I’m passing this on to some people along with my log of 889650.

My scale now seems stuck on kg like yours. Before I could step on and off a few times and it would eventually show lbs instead, but now it has stopped doing that and seems totally stuck on kg. Like you, I can switch the settings back and forth and it will temporarily show lbs again, but it soon switches right back to being stuck on kg. Very weird!

If I hear anything back, I will let you know, but we may or may not hear a direct response, I can only tell you that I’m going to pass it on since I can verify this isn’t an isolated incident.

Just tested my scale S and it shows pounds on the screen

1 Like

Mine has been fixed and working in lbs consistently for at least a week and a half now. I think this might be fixed.

@username258 is yours working correctly now too?

I have reported this issue in this month’s Fix-it-Friday thread. If this issue is still affecting you, I would recommend voting for it so that Wyze can see it is not an isolated issue:


Yes thank you for following up. It reverted to lbs about 2 weeks after I asked here.

1 Like

Same problem

My scale has been showing KG for about a week. I see people saying that their scales have gone back LBS. How did they accomplish that?

We took the batteries out of the scale & the scale reverted back to lbs.

Same problem.

Update. Took the batteries out and it did go back to pounds. My wife used it OK. I then stepped on it and it was back to kg. I went into settings and cycled between the setting of lbs to kg and back to lbs and scale is now showing pounds. The scale has worked correctly for over a year until now.

1 Like

Wyze responded about this issue:

For anyone currently seeing KG, try that solution and if it doesn’t fix it, please let us know. Mine is currently working, but if/when it switches to KG again I will try this.


Worked once and then switched back to kg.

1 Like

Once I removed the batteries for about 10 seconds and then reload, I have not experienced any additional issues.

Mine still reverts back to kgs even after resetting cache and taking batteries out. It only switches back to kgs when I have the app connected. Without the app it stays on lbs.

1 Like

Tried all suggestions and it still reverts to kg. There is one anomaly though. My app has the switch in settings to select either lbs or kg. My wife’s, who also uses the scale, app doesn’t have that switch. I have to switch the scale to lbs for her to use it.


I removed the batteries from the scale for a minute and reinstalled them. This reboot seems to have solved the issue for me.

You didn’t mention using the button on the back of the scale labeled “UNIT/RESET”…Wyze said that was necessary to resolve the issue.

please check the button on the back labeled UNIT/RESET to make sure it’s on the correct setting. The app will then sync when connected

Try using that button and see if that helps, then report back again.

Mine also shows only kg and a weight of 0 regardless of what’s on it. It also doesn’t seem to be connected to my phone anymore. I removed the batteries many times for a hard reset but nothing changes. It’s about to go in the garbage. I love the Wyze cameras, but this scale and the watch seem to be a lesser quality.

Still not working correctly. Randomly switches to kg.

I guess Wyze isn’t interested.


1 Like