Wyze Scale only displays Kg and will not "sleep"

Continuing the discussion from Wyze Scale Just locks up:

I have the same problem with my Wyze Scale as the person that posted this on the Wyze Forum in December, 2020:

"… I found the unit dead two days ago, figured the batteries just didn’t last from the original. So put new batteries in and it boots and then goes to 0 Kgs (not lbs) and locks up. Won’t stop showing the 0 Kgs, as though someone was standing on the scale.
Only way to stop the unit from just running down the batteries at this point is to pull one and try again. Did this several times before giving up. Yes, tried standing on it to see if it would help but its locked up."

There was no reply to that original post, but before I delve into Customer Support I thought I’d try here for any possible solutions. Any suggestions?

Which scale model?

When I brought up the KG issue in Fix-it-Friday a while ago, this was their response:

@carverofchoice It’s the basic scale, no ‘s’ or ‘x’, so there isn’t a reset button. Purchased in November of 2022. The iOS app will connect to the scale, but it doesn’t sync any data. Have tried pulling the batteries for several days in an attempt to reset the scale with no luck. I wish there was a way to force a firmware refresh, but the app won’t allow it because the firmware is up to date.

I have that scale too. Sorry to hear you’re experiencing this. If you can get it to work right, it’s really a great scale. I’ve had mine since launch and use it daily.

I would try deleting it from my app and setting it up from scratch again. Then call support if it is still malfunctioning.

Up until this issue we’ve liked the scale and how data syncs with the iOS Health app. Maybe related, initially the battery life was quite good, but over the past few months it seemed like whenever I wanted to use it (once every few weeks) it would be dead. Install fresh batteries each time and all would be fine, until this last time when the scale locked up.
I’ll give your suggestion a try and see what happens. Thanks!

1 Like

Well, I tried deleting the scale from the app in order to add it via the setup process, but I cannot add the scale back into the app. ‘Chatted’ with customer service and ended up with a $10 Wyze gift card, which is what I originally paid for the scale on sale (plus shipping & tax). Not the resolution I was hoping for, but better than nothing.

1 Like

Dang. Sorry to hear it didn’t fix it. At least you basically got the scale for free though so there is no significant loss in that sense. Would’ve definitely just been preferable to have it functioning as wanted/desired though.

I’m sure I’ll buy another scale, but it’ll be one of the models that can be reset. Thanks for your suggestions in trying to find a solution!