Scale Won't Turn On

So about a week ago I went to use my scale and the display wouldn’t turn on at all so I replaced the batteries and fixed that issue. But now the scale’s display just shows all 8s and my phone isn’t seeing to register it. I tried a different set of batteries and syncing it to my phone and none of that fixed the issue. I’m hoping you guys can help me with that because I do not want to have to buy a new scale.

Welcome to the Forum, @danitwelve911! Have you tried a factory reset?

1 Like

Hello I have tried reseting the scale and while I was able to get rid of the 8888s. I am now running into an issue where when I try and sync it to my phone I get to a point where it asks me to step on the scale and most of the time it just gives me a weight of 0.0 and clearly is not registering my weight but sometimes it will also give me an error.

I’m glad you were able to get the scale reset. That sounds like progress. You didn’t say what error the Scale S is showing you, so this Support article might be relevant:

If that doesn’t help you resolve the issue, then I’d consider opening a ticket with Wyze Support unless someone else here in the Forum has other suggestions.