Scale S Firmware Will Not Update

I have a Scale S with the Firmware 1.0.105 and keep getting a message to update to version 1.0.107 but can’t seem to do it.

I’ve update my Wyze app to the latest availabe for iOS which is 2.42.1 I have an iPhone 13 Pro running the latest iOS 16.5. When I initiate the firmware update the Wyze app shows a screen with two gears rolling. Words on the screen say “Updating … Feel Free to Leave This Page. The Device Will Reboot When the Update Finishes” Below that is a status bar fully filled in (aqua color) and below that the words “Downloading”

I’ve tried on both 5.0 and 2.4 GHz Wifi (mainly 2.4). It’s running as I type this for the last 2.5 hours?

Note the iPhone System Bluetooth Settings indicate it’s connected to the scale, and scale is displaying the Bluetooth icon.

Prior to this latest attempt I did some troubleshooting including

  1. Removing the batteries from the scale and rebooting
    2)Deleting the scale from the Wyze app
    3)Deleting the Wyze app from the iPhone and reinstalling

After all this I reinstalled the Wyze app, paired it with rebooted Scale. The Scale works fine, taking all the measurements, reporting them to the iPhone but says it needs the firmware update which I can’t seem to do.

Any ideas appreciated


You did great troubleshooting. Basically everything I was thinking of suggesting besides a “Factory Reset.” Maybe try that and see if it helps reset it to better accept the update?

Other than that, maybe contact support and see if they have experience with others reporting the same thing.

Thanks for the reply

Actually I had already done the factory reset without knowing what it was — but I did see the CLr displayed. I did that right after removing and reinserting batteries.

I also had multiple emails with Wyze support this afternoon but they didn’t have an answer

Well, on the brightside, you might not actually need the 1.0.107 firmware…it seems like everything should still basically work well without it. It says these are the things they changed:

  • Changing the error code to CAL isn’t a functionality change, and doesn’t really matter anyway.
  • If you don’t have a Pixel 6/Pro, then the second thing won’t affect you either…or if you do have them but don’t have the watch/band, then it still doesn’t matter.
  • The third one might matter a little bit more, and while a battery issue can be annoying, at least it should still function well.

Obviously fixing it so the firmware will update would be ideal, I’m just saying that at least the scale should still work well anyway.

Have you by chance tried rebooting your phone? I have seen this make a difference with some firmware updates. Something weird like a memory leak issue causing a conflict in some cases. I have seen it make a difference. It could be worth a try. Also, after rebooting the phone, while it says feel free to leave this page, I would stay there for an extra long time just in case your phone tries to disconnect from the scale the moment you leave that page/app. That is quite possible.
Oh! try clearing the app cache first too. So I would try this:

  1. In the app go to the account tab - App Settings - Cache File Size = Click “Clear”
  2. Restart/Reboot the phone
  3. Initiate the firmware update, but stay nearby and stay on the updating page for a few minutes.
  4. After a while, verify by closing the app, open it back up and checking the firmware version number (this will force the app to show the updated info)

Thanks for all the brainstorming — I should have mentioned I tried rebooting the iPhone but clearing the cache didn’t occur to me so I followed your 4 steps at the end of the last email. Clear Cache, Reboot, Initiate the Update and Let it Run but only for 15 minutes. No errors during that time just continued to say “Downloading” like before.

Then I closed the Wyze app and reopened it and it still shows the Firmware update needed

This is a long shot but in the Wyze app if I click on Account — Firmware Update, the Bathroom Scale is listed with the old and new firmware version #s. But what is the purpose / meaning of the words “Individual upgrade only”. It sounds like some type of restriction?

Thanks for all your help.

1 Like

That means that it doesn’t allow doing the Firmware update from that page, what is referred to as the “Bulk update” method. On that page you can usually see all the devices that need an update, and tell the app to process ALL of them at the same time.

The reason the “Bulk Update” area doesn’t work for the Scales is that they require connecting to phone through Bluetooth first in order to get access to the internet, while lots of other devices have their own access and don’t need the phone’s help. So for the Scales you have to open the device individually and then while it is connected to phone, tell it to do the update and give it enough time to download through the update the phone, transfer it to the scale, then the scale can install it. This is why I said to try staying on that page for a while to make sure it had enough time to finish downloading the update through the Phone and transferring the file by Bluetooth.

Anyway, that’s what it means by individual upgrade only, it simply means that it can’t initiate the update from that location because it needs you to open the device directly through Home Page first to connect by Bluetooth, since that it how scales get internet access for the updates.

If your phone is on WiFi, maybe try to turn that off so it tries Data only? Maybe there is some kind of shield or firewall conflict for whatever IP address is used for the update. I doubt it will make a difference, but I have seen something weird like that before and it’s the only other thing that comes to mind offhand.

I think I am out of ideas. You did some good troubleshooting all on your own already. I don’t know why it isn’t working. How long have you had it?

Just wanted to report that I have the exact same issue as jdkress, and have tried the same steps to remediate. Mine is brand new, first day of using.

1 Like

Interesting. I appreciate the confirmation, it is helpful to know that it is not an isolated incident! I’ll set a reminder to report this during the fix-it-Friday event this week.

1 Like

@jdkress @lhsbh I did post about this issue in this month’s Fix-it-Friday event here:

I would recommend clicking on that link and liking that post to show that it applies to you and that you are actively experiencing this issue. I don’t know if it will get enough votes to qualify as the top priority concern this month since there are only 2 of you reporting it so far, but it will still get reviewed and get visibility and the teams will be made aware of what it going on, so it will be helpful regardless.

I just wanted to let you know that I remembered you were struggling with this and I added this in there on your behalf so it would get visibility with the employees. :+1:


I have the same issue. Brand new scale not updating.


it doesnt update for me either, even after factory reset. If I don’t see update soon, I’ll have to return the device

First, thanks to “Carver” for making Wyze aware of this since I surfaced it

Personally I’d discourage anyone from returning the product because of this. I’ve had mine since 12/2021 and it still works great

However, if Wyze doesn’t address it or at least chime in on this since multiple people are experiencing it I probably won’t won’t buy Wyze products anymore. Sad

1 Like

I have the exact same issue with my brand new Scale S. I contacted support and they have me run some troubleshooting to no avail. They sent new scale. It’s doing exact same thing. Ugh! Hope someone finds a solution

1 Like

Same issue here. Brand new purchased a couple of weeks ago

1 Like

same issue here. brand new scale s, came here to see if there was a fix

1 Like

Same scale will not update firmware

Don’t know if this will work for everyone but I got updated by using my Android phone vs my iPhone which I’d been attempting with for weeks.


1 Like

Oh! That is good to know! Thank you for sharing this. That should be something actionable that Wyze can check/verify and resolve with an app update.

For the rest of you who are having this problem, are you all using iOS?
@jdkress @lhsbh @utell @mitt-wyz @brockcafe @foolio @timbkirby Can you confirm if you are using iOS? Are any of you having this problem on Android?

yes ios

Yes ios 16.5.1