Wyze Scale Bug with Android and not iOS

I was testing something for @carverofchoice related to the scale. We both have Android and I also have an iOS device.

Here are my versions:
Android: 2.24.41
iOS: 2.24.41 (3)

Log Submitted: 297794

Using the Android Device, the scale no longer reads or conencts to the phone.
Using iOS, it connects and has all of my previous information. I think there is a bug in the Android App which makes the scale not able to connect.

Please note: I have the Headphones, Earbuds pro, and Watch 47 connected to the Android device. Not sure if one of these is interfering either. The last device I connected was the Ear Buds Pro.

Android Video of what happens

iOS Video showing it working


Can also validate. Data shows on iOS but not Android.
LogID 297787

1 Like

Well done. Thanks for checking your scales and running some great tests guys.

I was concerned when my scale didn’t work this morning…afternoon (it was my morning, since I was up until 7am working). I am very pleased to hear it seems to just be something temporary and that it is working fine on iOS (which indicates it can be fixed again for Android too). That is a relief. And I guess I should clarify that the scale was working unconnected to still tell me my weight, it just wasn’t connecting to the app or doing the other measurements I normally like it to do, so I wondered if you guys experienced this too. Thanks for verifying and reassuring me my scale should be just fine and it’s likely just a temp Android outage/bug.


I just got an updated Android App 2.24.51. The scale seems to be working from Android again. Will need to test more.

But I must say, we reported the issue and the fix is out. Amazing. :rofl:

1 Like

I think it’s coincidence.

When I woke up I had a notification from twitter or IG that Wyze said they released a new app version. Then I got out of bed and tried the scale and it wasn’t working. Then I asked you if yours was working, then you reported it, then the app update came through. I think it was submitted before we reported it and it’s all coincidence of a sort.

In fact, I think the pending app update is what caused the scale not to connect use in the first place. They might’ve changed something and told it to switch to the new protocol or flexible code (HTML or whatever the GUI refers to) immediately upon publishing the new pending update, but the old app couldn’t use the new protocol yet, and the old one was not capable to do so as soon as they published the new one.

I’m pretty sure it went down closer to that. Wyze obviously has some html or other coding inside the app that they can change on the fly without an app update (hence why your iOS settings were noticed to be changing on the fly the other day without an update as you two mentioned), and changing that flexible coding temp disabled the scale in the old app version before we’d installed the approved update.

That’s my theory. It would be cool if we had anything to do with the fix, but since they announced an update before we were even aware of the bug, I don’t think that it is the case.

For anyone having this scale connection issue, try to update your Android app to Version 2.24.51 and it should be fixed (It fixed mine).


My scale is having the same problems as of now. I tried deleting the scale and readding. Now I can’t add it either. I guess that’s no surprise after looking at the likely cause posted by carverofchoice. I’m pretty new to the beta program. The play store is still serving up v2.24.41 at least as far as I’m concerned, is there a way to force it to give me the new one, or do I need to just be patient?

1 Like

2.24.51 is the prod release now. You can uninstall the Beta Version, go to the App Store and see if it serves up the new version.

I have also found that, at times, you need to remove yourself from the beta, uninstall the app, then go to the Store and install the Prod Version. Then you can join the beta again.

But for now, uninstall the version on your phone and install from the App Store and see if you get it.

I’ve updated to the newest app. The scale is connecting but is only measuring weight and showing bmi. All of the other data points are gone.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.