Wyze Robot - Always in CLEANING

Patiently awaiting a firmware or app update,

I did run a cleaning by pushing the button. The vacuum covered all available areas, recorded its journey on the map and went home to recharge.

I think I can suffer in this mode :wink: until the engineers identify and correct the problem.

I have the exact same issue. My problem is that the vacuum was @ a low battery state when this occurred. My app is stuck showing a fully charged vacuum @ 14%, you can’t launch the vacuum from the app without a minimum 15% charge. So my vacuum is a paper weight unless I manually launch it, or wait on the programmed schedules I have set. “Charging 14%” is my vacuum’s state @ the moment.

Also, the charging dock contacts are way too thin, on a decent pile carpet the vacuum pushes it’s contacts underneath the base contacts - I’ve had to remedy this by sticking a book of post-it-notes carefully behind the charging base. Did anyone test this product before release?

Folks - No one has actually mentioned contacting support so I have done so and referenced them back to the content of this thread. Ticket number is 996433.

1 Like

Was there any temp workaround?

Actually, several of us have mentioned just that and I even sent them a log from the app.

Same issue, tried resetting the wifi, Off and on, factory reset, all that jazz. Contacted support, haven’t heard anything.

I’ve called in also and submitted logs with description, they seem to be aware of this but was offered no workaround at this time. It’s understandable, version 1 lifecycle. :wink:

I just got notified of a beta firmware update. Hoping it would fix this problem, I updated. The update went smoothly, but after the update the app still acts like the vacuum is cleaning.

Oh well.

Ah! Mine just became unstuck during a cleaning cycle! Battery seems to be updating now too. :partying_face:

Mine is working again. I ran a full clean cycle manually by pressing the power button. Once it finished cleaning and returned to the dock the app updated after a little while.

Ok, here is how I got my vacuum and app to re-sync up the correct data. I pressed both buttons on the vacuum down for about 3 or more seconds. Also, there is a micro usb port on the bottom of the vacuum that seems to assist with manual charging. * Prior to doing this step, my firmware update would repeatedly fail. *

I also signed up for the beta firmware program for the vacuum to 1.6.95. My map, the virtual walls, true charge status and everything seems to work now. Now if we can get the ability to edit the Room borders and rotate virtual walls for angled portions of floor designs, it would be nice.

Did you try clearing your app cache and holding down both buttons on the vacuum to see if a status change triggers?

Ok, thanks for the tip. I seem to have gotten mine working (I already had the new beta firmware and app installed).

I took the vacuum off the charger, pressed and held both buttons on the vacuum for 3 seconds until the unit said it was in pairing mode.

At this point if I went into the vacuum in the app I was told the vacuum wasn’t connected to the internet.

I had to hit + on the Wyze app main screen to add a new device. I started the process to add a vacuum, entered my WiFi details, connected to the vacuum’s WiFi, finished setup, giving the vacuum the same name as it had previously.

I expected to see 2 vacuums listed in the app now, but there was only the one entry.

The maps are intact as are the cleaning records (I wasn’t sharing the vacuum, so I can’t speak to that status). I can now command the vacuum via the app and it correctly shows vacuum status and battery levels.

Please note: because I had already upgraded to the beta app and firmware, I do not know if they are required to fix this problem.

Perhaps someone without the beta can try the WiFi reset steps only and see if that works by itself.


Wyze made some type of fix in their cloud, Mine (like many others) started working over the last hour. I didn’t change anything and there were no firmware or app updates. Wyze fixed something in the cloud.

1 Like

My app is now displaying info normally, I have not updated firmware. Something on their cloud must have contributed to the issue.

My app was working yesterday and earlier today, but now is back to being stuck on cleaning with frozen counters.

I’m having the same trouble. It finished cleaning and went back to charger but still say cleaning with the spinning fan.

Also having the same issue. Reset the map, deleted the device, but when I re-add it still shows the same.

Yup. Stuck on cleaning. Mine failed between the 3rd and 4th cleaning cycles about 2 hours ago (post time 2021/01/16 19:10 CST) after a cleaning cycle I stopped early. I had previously done that too with no issues.

You might want to try what I did here:

I’d try that without the beta updates and see if it works. If it doesn’t, you might want to try joining the beta, downloading the new app and firmware and trying those steps again.

I’m not going to call this fixed yet, but I’ve done two full cleaning and one partial cleaning without the issue returning.