Wyze Lamp Socket not recognized

Accessory Lamp Socket when picked says “Please update your camera firmware to the latest version”
Camera is V3 with the latest version.
Yes I’m using the included very short USB cable. :frowning:

App is v2.26.22 Android
App is v2.26.21 iOS

1 Like

Sorry for the trouble. Could you please submit a log from your V3? Thank you very much.

Current V3 firmware is

Looks like you do need to update camera firmware

Had to remove Beta apps on iOS and Android and go with standard release.
Once I did that all the beta devices had firmware updates including this camera.
After the update, it then found the Lamp Socket accessory.

Nope - Lost the accessory again after flashing RTSP firmware

Same problem my v3 version wyze lamp socket not recognized…

1 Like

Same problem after trying with two different v3 cams (version and three Lamp Sockets. Such a bummer too.

Yea, set up for me has not worked either. I’ve tried multiple ways of setting this up & the socket will not work. I’ve found no information regarding the socket & V3 cams that have the RTSP firmware. The socket gets power, powers the V3 camera & the light will work (power on (unscrewing/screwing in the lightbulb)),

However, within the Wyze app there is no option for controlling/configuring the socket itself. Only the camera is able to be controlled/settings modified.

There is no lightbulb indicator next to the IR settings on the apps UI. Tapping the accessories setting for the camera results in an “Uh oh, check wifi” message even though in the setup process it says I have a great connection (mere feet from the router).

2 separate sockets & v3 cams have the same results. v3 cams have the latest:
RTSP firmware
Plugin version
Wyze App Ver. 2.26.22. Not enrolled or using the Beta program (app).

1 Like

That’s probably too old to support the socket, unless you know something I haven’t seen.

similar problem. after downloading new camera version today the lamp sockets began to be recognized. did this yesterday several times to no success. not sure why it worked today.

Update: Two of my three sockets worked after I swapped out my v3 camera cables with each other (no clue why but here we are).

I can’t get my third socket to pair, but maybe I’m not quick enough on the 30-second discover mode, which I now see listed in the FAQ. I will explore this more and try swapping out the camera again if that’s the issue.

The only thing that’s not working for me is motion detection from the cameras, but I suspect maybe that’s rule-related since I have my lights set to turn on from dusk to 11 pm then off afterward. I have them set with my Christmas lights (controlled via outdoor wyze power plugs) and they are on the same rules settings, so it’s possible a workaround for turning off my lights might be overkill for the sockets if they are in the same group/rules.

I am having the same issue with the motion detection. I have my socket set to turn on at 4:30pm and turn off at 8:30pm. My hopes was that motion detection would work after that. It sometimes works, but it only seems to work if I open the app after the 8:30pm shutoff time.

Additionally, I can’t get my lamp socket to update (stuck at version and every time I try to update to the current version ( it fails. I’m wondering if the new version fixes the motion detection setting, but that remains to be unseen. I’ve tried updating 20-30 times now (no exaggeration) with zero luck. Upon each failure to install, I have to hard reset (cut power) to the socket to get it to function properly.

Hello. I was wondering if anyone was having the same issue with their lamp socket I am. I screwed it into my front door outside light and follow the steps but the lightbulb would not turn on and it doesn’t seem like it is getting any power, Yes the power is on and yes the lightbulb works without the lamp socket, or it is actually making full contact. I tried the lamp socket in another light socket and it worked just fine. What happens when the Wyze lamp socket does not fully seat into the socket?

1 Like

I am having the same problem. Camera works fine in lamp socket inside. When hooked up to my outside socket the lamp doesn’t come on and the camera has no power. Have you found a solution for your problem?

You you have your outside socket turned on?

Yes, bulb by itself comes on with the switch. When attached to the lamp socket nothing comes on with the switch.

I’ve read other accounts of this occurring. For whatever reason, the end of the Wyze lamp socket isn’t fully seating into the socket of the housing you are using. I’ve read on a different blog threads about someone using spacers to bridge the gap and make the end fully seat, but I would be hesitant on doing this purely due to fire hazards (I don’t know of a marketed product solution for this). I’d suggest checking to see if you can make a slight modification to the housing to get the socket to screw in all the way.

Best of luck!

Did anyone get a resolution to the lamp socket not being accessible on wyze app even thought V3 camera and light bulb have power and work?

I was able to fix the issue by shutting off the switch to the lamp and using a pair of needle-nose pliers to pry up the socket tab which was almost completely flattened. Once I had raised the tab, and screwed everything back together, I turned on the switch and everything came on properly.

@jitterd24 there are a few reasons I’ve been able to track regarding this issue.

  1. the Wyze lamp socket, for whatever reason, is not making contact at the base of the socket and therefore it is not receiving power. This seems to be an issue with the lack of standardization of the lighting manufactures sockets. If you are getting power to your light and camera, this likely isn’t the issue you are experiencing.

  2. An after-market USB cable isn’t fitting into the socket. I had this issue and was able to shave the sides of the USB cable slightly using a razor so it would properly seat into the USB receiving end.

  3. The super short cable that came with the Wyze lamp socket has additional wires in it for data sharing that the longer cord you received when you originally bought the V3 camera does not have. If you are using an after-market cable or the longer cable that was included in your V3 camera, try switching them out for the shorter cable that came with the lamp socket and see if that fixes things. If so, I have found an after-market cable that is 25’ long and works almost perfectly with the camera. Only issue I’ve had on the long cable is it’s missing something that allows me to update the socket. Not too big an issue since when an update is available I just take the socket inside and hook it up to one of my indoor cameras with the short cable, update it, and put it back outside. Luckily updates don’t occur daily!

Hopefully one of these help.

1 Like