Wyze Lamp Socket not recognized

Thank you Brendan. I think the cable is going be the issue. I was unaware that it used the wire as communication from the camera. 25’ cable will be too long, if you have some info on the cable that would be cool so I can research a shorter cable similar to the 6 foot one that came with the camera.

WYZE team;
Do you have any info on a cable that is longer and will allow communications between the lamp socket and V3 camera? The 6foot one that comes with the camera does not allow communications between the camera and the lamp socket.

@jitterd24 this is the wire I use:

You might be able to look at the seller and see if there are shorter versions. Like I mentioned in my previous post, I seem to get full functionality with that cable, minus being able to update the socket. I just remove the socket and update it using the original short cable and a standalone spare camera I have (only had to update it once in 4 months).

Was anyone able to get the wyze cam v3 to work with the lamp socket after installing the RTSP firmware?

My camera works fine and detects all three lamp sockets but after I install the rtsp firmware it just won’t detect lamp socket.

It won’t work…RTSP is an older firmware with no concept of the socket.

1 Like

I thought the rstp firmware was just an add-on.
My two wyze cam V2 still get their update even after I installed the rstp firmware
This is sad if they make us choose between having lamb sockets or local recording
I’m going to open up a ticket and see if I get an answer

RTSP is a completely separate firmware, the lamp sockets will not work with RTSP

Edit: Fixed a very misleading typo

1 Like

When did that change? Is there an update to the RTSP firmware?

That was a typo will edit


1 Like

That’s wired if RSTP is completely separate firmware and the other feature on wyze cam are undated separately then I don’t under why it don’t work??
This is sad news.

Wyze has stated repeatedly that there may be new features and products introduced that will not be compatible with the RTSP firmware. It is a “branch” from the production firmware and was based on an earlier version and isn’t being updated regularly for new features.

1 Like

Thank you for the help. Purchased another usb cable from another vendor and it works just as advertised.

You mean you have the wyze lamp socket working with wyze cam v3 RTSP firmware installed?

@jitterd24 asked about a longer cable, not RTSP firmware.

1 Like

I had a similar problem, the socket was not recognized on the app. The light and camera worked but I kept getting an error when trying to add the lamp socket as an accessory.

I was using the USB cable that came with the camera which didn’t work. I found out I needed to use the USB that came with the socket instead of the camera. After swapping those out, it worked and I was immediately prompted to set-up the socket.


Is there any real resolution to this issue? I have installed the light socket (3 in fact) and one camera using the usb cable that came with the socket (not the cam). It does not detect the light socket. I even installed one of the cables that came with socket #2 and it still does not detect. I appreciate any help as I don’t want the lights on all night and day.

For me, the issue was that the pin on the inside of the light socket was too flat to reach the Wyze lamp socket adapter. So, I shut off the breaker for that socket, reached in with a pair of needle-nose pliers, and pulled the pin up a bit. I restored power to the socket and tried again. On this attempt, the camera came on immediately. Hopefully this solves your problem.

The cable that comes with wyze equipment is made with only two wires comnected to terminals for power only. Therefore no data transfer and the resolution is to purchase a cable from amazon. Majority do allowing data transfer.

1 Like

Oh for the Sake of Pete… THIS! I couldn’t figure out why the heck I couldn’t get the camera to see the light socket - I needed a longer cable than the stupid short cable that comes with the socket so I was using a USB extender with the cable that came with the camera…

Soon as I swapped the cable that came with the camera with a ‘NORMAL’ cable it popped right up in the app.

WYZE — PLEASE update your documentation and installation steps to tell people NOT to use the cable that comes with the v3 cameras!.. Or better yet - put a proper cable in there.

1 Like