V3 camera Lamp sockets unable to control through app after install

I have had v3’s installed with extension cords for the past month. I purchased lamp sockets thinking that I would clean up the cords and minimize the clutter. Cameras are running RTSP (I am not sure if this could be a contributing factor or not to this issue). I have followed the installation instructions that come with the sockets 4 times and have been unable to get the v3 to list the socket as an accessory in the settings. Upon install, the light turns on, everything installs with the QR code and the install states that the socket has been installed and can now be controlled using the camera. When I go into the settings and click lamp socket, I get the “Uh Oh” message. The cameras all show up in the app, but no way to control the lamps. I have deleted all the cameras and performed fresh installs and still no luck. I have written support and hope that maybe the community might have experience with this or a troubleshooting resolution.


I don’t run RTSP, but I think that firmware is based on an old baseline firmware that did not know about the Sockets. So I wouldn’t expect it to work. Have you tried manually installing current firmware as a test?

1 Like

I thought that might be a problem as well. Factory reset the camera and tried the install again without any luck. Not sure what is going on with these sockets but this can’t be normal given the simplicity of everything else I have had with Wyze.

As @Newshound asked, did you flash to the current firmware for the camera? Factory reset doesn’t do it.

1 Like

That was it! Thanks for the help all @WildBill and @Newshound

1 Like

I have the same problem with my lamp socket.
What is RTSP?
And what does “flash to the current firmware” mean?
My camera updated itself as soon as I installed it and works well but the lamp socket is not visible in its accessories section.

RTSP is the software you load through the microSD card for server surveilance software to connect to the Wyze. If you haven’t loaded the software or loaded an SD card, I don’t think you are at risk. Flashing the current software involves going to the Wyze site and downloading the current firmware for your camera, loading it onto an SD card, loading that into the camera and performing a reset.

I have not put an SD card in the camera yet.
The firmware version it downloaded over wifi on installation is the same version that is available to be flashed. So would factory resetting and flashing the firmware do anything different than what the camera did over wifi?

I don’t believe so. The lamp socket and camera connected after I flashed the firmware back to the most up to date version. I did previously have the cameras installed and then had to delete them and reconnect all of them with the lamp socket installation.