Wyze Floodlight / Camera V3 Problems

I have had the Wyze floodlight/cam v3 installed for maybe 8 months or whenever it was first offered at Home Depot, I have had no problems until recently. The Camera works perfectly fine while plugged into the back of the infared sensor but the floodlight seems to have a mind of its own, when you press the light icon it shows illuminated but the light isnt on, i get message of unplug your camera and reconnect when i try to go into the floodlight settings, and if i do by chance get into the settings any change i make does not work. Ive attempted to turn power on and off and i have tried delering the camera and going through the setup multiple times.

Sounds like you’ve done some good standard troubleshooting that I would’ve recommended trying. At this point I would recommend contacting Support. They might have you retry some of the things you’ve already done, but they need to make sure they’ve tried everything before checking on warranty options, etc. Hopefully they can will be aware of what might be going on with that. Mine is not having that issue, so I would have them look into it.


(206) 339-9646, or you can chat with an agent or create a ticket on the support site.
4 am - 6 pm PT Monday through Friday, and 8 am - 4 pm PT Saturday.