Wyze cam Floodlight

So I installed a floodlight no issues in my backyard area! Has worked great for weeks. I installed another in the front area by garage replacing an existing light. Setup was a breeze, everything was fine until the next morning and the light/camera was offline. I noticed the V3 came had a solid red light. I power cycled to no avail, disconnected and reconnected physically. I tried to flash firmware but camera would not reset and remained on red light of death. I unscrewed the V3 cam, and put another V3 came I had in my house, and it’s working this far.

Any ideas? Also if this works, doesn’t Wyze owe me a new v 3 camera?

I have about 4 V3 cameras, never had this issues. The floodlight and camera did a firmware update right after first power up, but it worked fine. About 12 hours later the issues popped up.

Support may run you thru some verification troubleshooting, but the camera is warrantied for a year. Unfortunately, Support will be closed until Jan 3rd at least. But try them then:

There are many ways to contact Wyze. Their phone number is (206) 339-9646, or you can chat with an agent or create a ticket on the support site.

They’re open for support between 4 am-8 pm PT Monday through Friday, and 8 am-4 pm PT Saturday.
[note due to typhoon Rai recovery, hours will be 6 AM - 6 PM PT for the next 5 days at least]

I had support basically say “we are closing your ticket with no resolution.” when I had problems with my floodlight V3. I have a second V3 right next to it (plugged in to it) and actually had originally planned on the cam being hard wired but this camera never keeps its connection so kept the light switch so I could more easily power cycle the device.

They said “your AP is too far away” so I located a hardwired AP to right above the camera, they said “you have too many devices on the network” well that’s a problem because the 28 devices on this discrete network are all wyze devices… They said it was my setup, so many excuses.

I’m like look, I don’t know what to tell you, the camera right next to the flood light, plugged into the floodlight, has never had a problem, ever, this one can’t maintain a connection to save it’s life. Gives me a bad taste about their more recent customer support honestly, and major concerns with these devices that are more hard wired into the house.


Since I swapped a V3 from inside with the one that was originally in the flood light, it’s been fine. I think the original V3 that came with the unit got the red light o death…I just need Wyze to replace my V3 camera. As for the other USB port on the floodlight, I have not used it on either of my floodlights

This has been one of my concerns with the Wyze model all along…WIFI. I’ve got too many Wyze devices and others that use wifi which is one reason I’ve setup a separate IoT network AP. It’s only for my Wyze and Kasa smart devices and has a dedicated router running as an AP. I’ve been planning to add another AP but haven’t done so yet. I’m also switching to non-wifi devices such as z-wave and LoRA to help limit the count of wifi devices on my network.

1 Like