Brand new floodlight v3 - can't get it past solid red light

I’m new to Wyze and I just got a new floodlight v3 cam direct from Wyze, Physical install went fine, the floodlights come on but I’m trying to setup the camera and pressing the setup button does not give me any “ready to connect” prompt. It’s just stuck on solid red. I’ve tried turning it off/on (which means flipping the breaker), holding the setup button for 10s+ and neither of those things work. No card is in the slot. Not really the best impression of Wyze so far and I’ve got more cameras coming, so hopefully there is something I’m missing?

Sounds like the camera may need to be replaced.

1 Like

Okay thanks, I’m working with support now.

Just as a followup - Wyze sent me a replacement and it worked with no issues. :slight_smile:

1 Like

I am having this exact same problem. I am coordinating with Wyze Support to send me a replacement unit. I can only flip the breaker to have the lights stay on for a few second – so power is good – then the camera will only have a red led blink with no prompt for setup. Hopefully a replacement unit is the answer.

Welcome to the forums!

Looks like we are right on track according to the floodlight installer within the app… See below:

Next step:

You need to press the setup button underneith the camera for the prompt to be said. Have you not pressed the button? The flashing led is the sign that it’s ready for setup to proceed.


Well, I totally missed that. I hit the button as you described and everything worked like it is supposed to. I guess I was too rigid with the instructions and I never bothered to inspect the camera.

Everything works great! Thank you so much for posting a response to my issue.


I would update Support that you don’t need a replacement then. Glad its working!

1 Like

Yes, I requested for them to close the ticket. Glad to see great support on some good products