Wyze Drops "Works with Google" from app... Google still tells me "This isn't an issue with google services"

Ok, so a little background. I bought my original 2 Wyze Cams for many reasons, but here are the important ones. Good image quality, ability to record to SD for recall later, cheap, and google integration with our 3 “hubs”. Fast forward a year, and we now have 5 Wyze cams in our home, (including and Outdoor Cam) and I’m starting to get pretty peeved. We’ve just had a child in early july, and thats when I noticed the “Displaying Smart Home Camera” Black screen being a consistent issue. Being able to view our sons crib and our main living areas from upstairs are VERY important to us. It was great to be in bed and say, “Hey Google, show me max’s room” If we heard him getting restless. I’ve read a few responses from people saying "google said they recognize there is an issue, but they don’t have a timeline. Well I call nonsense… I’ve called google 3 times, and all three times they’ve said, it’s "more than likely an API issue with wyze services/firmware. I don’t want this to turn negative, but I have family/friends with cameras by Arlo, Yi, Eufy, swann, etc. ALL WORK WITH GOOGLE FINE!!!. I have a old Yi home cam that i use for my 3d printer, and that WORKS FINE!!!. Now, i go into the wyze app, and “Works with Google” is removed. It’s also strangely absent from the new Outdoor Cam packaging. This NEEDS TO GET FIGURED OUT!!! WYZE, just be transparent with this! Thoughts?


You’re right! It’s a Wyze issue, not a google issue. They’ve known about this and they are working on it. @Frederik should be able to give more information.


There were 2 issues one was WYZE and one was Google. I do believe the Google side has been resolved because as of about 3 days ago I can again stream to my Google Home display. The problem is it takes 30-45 seconds prior to streaming and it has tremendous lag. That is what I had before it had stopped working completely for awhile. On the WYZE end I have seen them talking on the forums about implementing WebRTC to deal with those issues and that is definitely where WYZEFrederik will be able to have more answers.

1 Like

I’ve tried everything DAILIY. Including deleting ALL my Wyze devices, and setting them all up from scratch. Unlinking/relinking my Wyze account with google home, Creating a new Wyze account with gmail email (suggested by someone) and setting up new devices there, and more… Including every combination of BS I could think of. We have a first gen google home hub, the nest hub, and the nest hub Max. I can’t get ANY CAMS TO PLAY ON ANYTHING. I’ve left the black screen on for 15 minutes (usually times out after 5-10 though). Same issue with friends and coworkers. It sucks cause I RECOMMENDED WYZE to them.


I fail to see how webRTC is a “fix” for this. Maybe I’m mistaken, but isn’t webRTC a browser solution? Google’s Developer platform is locked up tight since “works with nest” API was dropped last year. Many nest devicesdon’t openly share backend data with 3rd parties. For instance, we were going to buy flair smart vents, but the nest thermostat (google) won’t share simple temperature and humidity data with the vents and controller. Google is worried about privacy and security, and you gotta play by their rules. Simply put, Wyze failed to do this. I work for a tech company that had google integration in the past. We couldn’t do ANYTHING after the change, so we abandon that aspect of our company.

I agree whole heartedly, really getting old this 'have it one day, gone the next, rewind repeat.


I honestly have no idea what it is, I have just seen it mentioned a few times by employees. As far as making it work someone had said they relinked their devices to Google and it worked, so I relinked mine and asked it to show one of the cams that was on the up to date FW and after about 45 seconds it did play. It lagged horribly and cut out once or twice, but at least this time I had a picture.


I’ve re-linked a dozen times… Including again last night… I’ve managed router settings… I’ve deleted and re-setup cameras (all of them)… Nothing works. Best i got since months ago, was about 25 seconds of my outdoor cam to play on my google nest hub (original)… It was about 12 seconds delayed… once it quit, couldn’t get it back. It’s hilariously terrible, and unacceptable for a company that claims “google Home/Assistant integration”.

1 Like

Let me try to explain what we are seeing on our end.

The Google Home integration is working for the most part. Meaning that we are seeing a large number of success connection and streaming.

BUT… we have seen a series of issues related to oAuth. oAuth is the mechanism that allows us to establish a trust between the user, Google and Wyze that the user is who is says he is and allowing to google to connect to the camera that belongs to the user. Because oAuth relies on tokens with expiration, a lot of the failure where because the tokens were expiring without the users being informed. There is an automatic renewal mechanism that was not working properly. That’s why a lot of the recommendations, and success, was to reconnect the account so those tokens can be valid again.

Now for people, that are still experiencing the problem of connecting, I’m not sure what the problem can be. I know that we have an open issue with Google where, inside the Nest Hub, there is an error being produced. It’s been several weeks that Google has been investigating and they still not have been able to tell me what the problem is and how we (Google and/or Wyze) can fix it. I’m pinging them every week to make sure that it is not ignored.
We are not changing the implementation that much so this is a service that should be stable. The report I’m seeing are saying that this is varying quite a lot. That’s not good and we need to figure out. Believe it or not but it is as frustrating for us than it is for you when you cannot use a feature we spent months developing and heavily tested.

Now, I would like to recommend the following. It won’t fix the issue but it will raise awareness on our side of problems. If you are still facing an issue trying to connect, please go in the mobile app and send feedback (log). The log from the mobile will not help BUT it will give us some information like identifiers. also put some information about the time you tried to connect and the camera you tried to connect to. This would give us enough data to start looking into a potential problem and if the problem is on our side or the google side.

For WebRTC, yes. This is something that I’m betting a lot on. Several reasons:

  1. Yes it’s a standard used in browser but it is a basic technology, it’s not limited to web browsers and could be used in pretty much anything.
  2. For the moment, we are using an RTMP stream to a server in the cloud and then transcoding using the Dash protocol and sending the newly formatted stream to the hub.
  3. RTMP and Dash are file based so we have to create a file with about 4 seconds of video and then create another one and so on. The files are sent as soon as they are complete.
  4. Google Nest Hub (but almost all the players are doing the same) requires at least 2 files in their device before starting to play the first one. So it’s only when the 3rd file is starting to be uploaded to the device that it would start playing.
  5. Depending on the resolution, the amount of movement in the frame, the bandwidth of the connection at the time of the upload, it can take a little bit of time (ie. a few seconds) to upload the files to the servers.
  6. the players when playing the files do not skip frames. Think about it like watching a movie. If the connection is too slow, should they skip part of the movie and try to stay on time or pause the movie until they have all the frames to continue so the viewer is not missing anything? Well, Dash, HLS and a few other protocols want to make sure you see everything.
  7. WebRTC happened to have also a data channel where we can pass information directly from one device to the other. This could open up a few cool feature.

Soo all those things considered, you can see that you have at least 2 * 4s delays to create the initial file, about 1 seconds of transcoding, about 2 to 5s of moving the files around, about 1 second to do all the security verification and you are at 15 to 20s of delay before the first frame could be shown.

WebRTC is different. It does not care to show all the frames. It cares to show you the latest frame even if it means skipping one or two in the process. WebRTC is frequently used for two way communications (think something like Zoom). There is no transcoding required because what comes out of the camera is what is expected on the other side. The results is a significant improvement in the experience where we can expect latency no greater than 2s and most likely less. Connection time is also a little easier because there is no files to carry around. We have to establish credentials, create a networking path back to the devices and connect them together. So again we are most likely in the 5s to max 8s range also maybe better.


Thank you, your post is so clear and definitive and well written… Best communication from Wyze ever received.


Thanks @Frederik! My Google Nest Hub is working now, streaming all my WCOs or V2 cameras! There is a 15 second to 40 second delay. WCOs seem to load faster than V2s … particularly my older V2s. Not sure that’s scientific findings on my part. Just a feeling. I’m primarily interested in viewing the WCOs which to me are the most important to monitor.

Glad you and Google are continuing to work on it. FYI, my Nest Hello Doorbell streams to the Google Hub almost instantly. But then again, Google could be favoring display of its own cameras.


Thank you for your explanation! Hope you can solve this issue (as well as others related to Google Home integration), you are an exceptional team! :mechanical_arm:

1 Like

Thank you for your thoughtful response. I have been wondering myself what the technical complications were to the current implementation with Google. Keep up the good work!


This still does not work for me. The response I get from my hub is " sorry, I don’t know where to play the video, please tell me the exact name of the screen."
Any suggestions?

1 Like

This sounds like an unrelated issue to me… but what do I know. If you go in your Google Home app, what is the device named (that you are streaming to). Hopefully this is an obvious one, but that’s what you have to say. Like One of mine is called living room hub. So I would say, “hey google, stream living room camera on living room hub”. Another issue that could be going on is you have set within Google Home one device to always be the default player of audio or streams, so naturally that device is trying to play whatever you were trying to look at, but it may not be a device with a screen. If there are any misspellings I apologize, sending this through my iPhone via dictation

My hub is called “bedroom display”. If I say “hey google, play stranger things on netflix on the bedroom display” it plays just fine.
If I say “Hey google, stream front door camera on the bedroom display” I get that message about not knowing where to play the video.

1 Like

For fun try, “show me the front door camera on bedroom display”. Some people reported having issues when saying “stream”.

1 Like

Well thanks for that, it worked! Took about 90 secs to actually load but at least it worked. I wondered if I could also stream it to my TV via the Nvidia Shield but alas that failed with the previous message being given. Oh well, one out of two ain’t bad :smiley:

1 Like

That was my next question… How long did it take/how laggy was it. I love google home products, and feel they are “better”, in most ways to Amazon/Alexa devices, but I bought a echo 3 dot and echo show 5 for “science”. Speakers are better than my nest devices, and ALL cameras showed up within 10 seconds of being asked, and were maybe 4-5 seconds of lag. I can deal with that. So my choice is, dump Wyze or dump google. As of now, it’s wayyy more costly to replace 8 (6 more now) nest devices, than 5 Wyze cams.

Sorry im not trying to be obstinate or argumentative… That said… If youre having so many problems with Wyze Cams showing up and working with Google then why dont you just use them the easiest and most reliably? Through your smartphone? I havent had 1 problem bringing up live view or perusing playback when using my phone. You talk about wanting immediate piece of mind by being able to see your child in their room in real time if you notice they are fussing by earshot. I get the whole - It says it works with X and by all thats holy and not it better work with X - sentiment but if I were you and it was causing that level of anger, internal turmoil and mental anxiety that its seeming to find an easier solution… Instead of beating your head against the wall trying a solution you know doesnt work easily for now. Find an easier solution in the meantime