Viewing through google home

Woke up yesterday and i can no longer ask google to view my cameras . It says no connection

Which Wyze app version are you running? Beta 3.0?

1 Like

I just tested on my Samsung Phone as well as my Google Nest Device. both of which do not seem to be streaming at this time.

@Seapup , as you know I am using Wyze Beta 3 on my phone, but the Nest is native.

I will try a few things to see if I can get it to work.

@kcknchkn , what have you tried so far?


I did notice a couple of days ago that I wasn’t seeing any live streams of my cameras in the Google Home app (Android), but that’s not unusual as that seems to be hit or miss. I won’t know until I’m home later whether or not I can still ask Google Assistant to stream to any Google-enabled devices and get the expected video.

:pencil2: Edit: Now that I’m able to talk to Assistant, when I request a camera, Google Assistant gives the appropriate voice response (e.g., “Sure, streaming the [requested camera] on [Home Hub device].”) but doesn’t actually show any video stream. I’ve tried so far on a Chromecast and a Home Hub and have requested streams from a Cam v4, a Cam OG, and a Video Doorbell v2, all with the same (non-playing) result. It seems pretty apparent at this point that something is likely hosed on Google’s end (no surprise), because Assistant clearly recognizes the cameras I’m asking for and responds with the appropriate name, so my interpretation is that the Wyze/Google integration is somewhat intact (i.e., Google Home still recognizes my devices, so I don’t need to delete/add/resync the Wyze account).

I still don’t think this is a Beta issue. I’m using production versions of both the Google Home and Wyze apps on Android. I think this topic belongs in the Services & Integrations category, and if I had to guess, I’m gonna go with this being a temporary (though indefinite) outage caused by something Google did. :man_shrugging:

Oh, hey! Welcome to the Forum, @kcknchkn! :wave:

:pencil2: Edit @2024-07-06T01:55:31Z: I was just able to get a Cam OG to stream by asking Google Assistant on both a Chromecast HD and a Google Home Hub. I can also view a live stream of that camera in the Google Home app (Android). No other cameras I’ve tried (Cam v4, Cam Pan v3, Video Doorbell v2) are playing through Google Home (i.e., my experience is the same as I described earlier). I have not tried reconnecting my Wyze account to Google Home, nor have I changed any other settings.

I continue to suspect that this is an evolving issue on Google’s end, though it’s also possible that Wyze is fiddling with something on their servers. :man_shrugging:


Same here. Cam OG only one working out of about 10 different cameras ( various different versions ). I have tried unlinking and re-linking but it did not help.

This is still my current experience, as well. The Cam OG is the only one of my Wyze cameras that I successfully call up to live stream on my Home Hub, and I’m still able to view live streams of two different kinds of non-Wyze cameras on the same device.

I recall reading elsewhere on the Forum that Cam OG uses a different kind of technology or streaming protocol (I’m fuzzy on the details and haven’t dug deep into the issue) than other Wyze cameras and that perhaps that’s related to the cost-cutting measures that were employed in order to meet the target price for that model, so now I’m wondering if Wyze did something on their end (again, like the apparent server fiddling that resulted in the recent connectivity outage for original Plugs) that has broken the connection.

I should also note that all of my Wyze cameras show up as available/online in the Google Home app. That is, when I go to the Devices tab in the app, all of the camera tiles are highlighted the same (including the Cam OG), and tapping any non-OG camera gives a screen that indicates the app is “Connecting”, so the cameras are there and the integration isn’t completely broken, even though I haven’t tried un/re-linking, which I wouldn’t expect to resolve the issue.

My working hypothesis is still that it’s a Wyze and/or Google server situation, but that’s just guessing. :man_shrugging:

Also of note is the firmware numbering on the OG is very different to that of the other camera versions.

1 Like

Just checked my Google home and found my v2 and v3 cams are offline. I don’t use Google home and rely on the app. I am on the latest non-beta software.

It’s no big deal for me. Just decided to check.

1 Like

Just checked, and confirm that my Google Hub won’t stream any of my cameras that use TUTK all of a sudden. I did get a non-TUTK camera to stream.


My cameras are online in the sense that Google Home can “see” them and recognize that they’re available, it’s just that the Cam OG is the only one I’m able to stream through any Google Home app or device at the moment.

1 Like

Mine say they’re online until I try to stream them through the hub menu. Then they will say “connecting” for a while and eventually some will say they are offline when they fail, then go back to showing as if they’re online.

What’s weird to me is that Wyze is supposed to connect to Google and Alexa through WebRTC, but since only the TUTK cameras are failing to stream, it makes me think that’s not [exclusively] the case after all.

1 Like

My Wyze Doorbell Pro streams without issues. My V4, V3, V3Pro, and the Floodlight Pro will not connect for some reason.


I just tried that, and I see what you mean. Before, I was just using voice commands to Google Assistant on the Home Hub, and the only camera that gave any pre-stream indication that it was actually “Connecting” was the Cam OG. With the others, Google Assistant responds (audio) that it’s streaming the appropriate camera, but there’s no visual indication that it’s even connecting.

That’s interesting that @spamoni’s Video Doorbell Pro also works. I don’t know enough about the innards and backend technology to have a good concept of why some camera models are different and why most seem to be failing the Google Home connection at this point, but hopefully someone at Wyze can check into this.

Hopefully @kcknchkn will respond with an update at some point, too, because I still think that this topic is miscategorized and might get more appropriate visibility if it was tagged differently. I also think another new topic is essentially describing the same issue, so perhaps they should be merged.

1 Like

I’m no expert, but I know that the OG and VDBPro use a different SDK than most of the other cameras which use “TUTK” to connect. So it is strange that people have reported the OG and VDBPro working, but so far, none of the TUTK cameras.

I agree that this issue is mislabeled. I don’t think it has anything at all to do with the App or Beta.


Bummer. I thought you might have fixed it when I woke up today. :smirk:

Definitely not just a beta issue.


There is no broadcast on Google Home Hub Max. The Wyze cameras are displayed in the Google app, which means there is a problem with the Wyze cameras. Is it really time to extend all five Wyze cameras?
This means that it’s not Cam Pan, not V2, but I have 5 of them and not one of them broadcasts. The cameras were purchased specifically for remote broadcasting of elderly people and it’s already the fourth day where I’m paying for the Internet at the dacha, but I can’t see what’s going on there remotely I can! Developers please take action!

Adding a “me too” since updating to the latest beta a couple of days ago. Weirdly going back to the production version and the same problem persists.

The Nest hub says all 3 cameras are online, but when asked to display on the hub, it acknowledges the command but nothing appears. When asked to display on the phone the app says it can’t connect to any of the 3. The Nest battery doorbell shows fine on both hub and phone.

Really hoping for a fix (soonish) :slight_smile:

Still broke as of this afternoon on the non-beta firmware. Luckily the app still works.

I still suspect this is probably a server issue (Google’s and/or Wyze’s), but I think being more precise might contribute to the usefulness of the discussion.

Given these comments, I’m unsure about what’s being discussed: Google Home app beta (Public Preview)? Wyze app beta? Firmware production or beta versions for…which device(s)? :man_shrugging:

Just my 2¢.

1 Like

FYI widget shortcuts are no longer working on iPhone