Wyze Doorbell Cam v2 disconnects and stops working after a few days without a factory reset

My new wyze doorbell cam v2 worked out of the box but only for about 2 days, and then I could no longer connect to it (flashing orange light). Attempting delete and re connect it would not work either (could not connect to the internet).

Performing an factory reset by holding the setup button for 10 seconds worked again for another 2 days, but then its back to the orange light and being unable to connect to the internet again.

Hardwired, Latest firmware updated etc. 2.4ghz internet band. previously had a v1 doorbell cam in the same location that worked perfectly.

1 Like

I was having similar issue. Doorbell v2 would work for a few days then the Flashing Orange Ring of Death (FORD) would start. I had to do the long reset and then once again add the new doorbell. I eventually found that my router had a scheduled reboot every few days. It would reboot at 3am. Don’t know if it came that way or if I set it up years ago. All my other devices can recover from the reboot but the doorbell v2 could not. I turned the scheduled router reboots off and the doorbell has stayed connected. Maybe this is your problem too.

Couldnt find any such settings in my xfinity router, but im going to try and experiment tonight. I think it might be related to conneting its press to alexa notifications.

I am having the same problem. My Netgear router does not have the ability to automatically reboot, so that is not the problem. The camera stops working at various times, sometimes during the day and sometimes during the night. My doorbell transformer is an old 10V 5VA model, which I suspect might be causing our problems.

Yes, this problem was caused by my old underpowered tranformer. After replacing it with a new 16V 30VA transformer, the camera has been stable and my existing mechanical chime now works.

Hello. I too am getting the orange blinking. Restarting the camera seems to kick start it again but it’ll only be for a few minutes before it does the orange blinking light again.

It’s so annoying as I am not able to see live view. Notifications seems to still happen and get recorded. Doorbell chime works as well. It’s when I log into the app and I view live, it displays the last image it saw before it went offline.

I have an extender right next to my front door. I also have a v3 pro camera which is even further than my doorbell v2 cam and that has no issues. So I know it’s not the network.

Just to add. The issues seems to only be not being able to view live. Restarting the camera fixes it for a few and it’ll get stuck again and I won’t be able to view live.

I wanted to report back. I fixed my issue. It seems my Google mesh router had wpa3 enabled. By disabling it I am now able to vie my live feed. No longer am I seeing the orange circle of death.

1 Like

So it appears my solution didn’t work. I’m not able to view live view. And I get the orange circle of death. Only solution to fix it temporarily is hitting the restart to restart the camera under the settings.

I’ve also come to find out it’s not just my doorbell camera. All of my other wyze cameras are doing the same.

I wanted to circle back here again. My issue of the orange light and the constant camera disconnecting and not being able to view live view was a result of a recent (I think) update to my Google (1st generation) mesh router.

They removed the ability for the cameras to connect to 2.4ghz. Basically it’s what the mesh will set whether you like it or not.

My fix was I got rid of the Google mesh routers and picked up the TP-Link Deco M5 routers and my cameras are operational again. I’ve set the M5 to only broadcast 2.4.

Here is what I purchased.

https://www.amazon.com/dp/B06WVCB862/

[Mod Edit]: Removed your Amazon affiliate referral tags from your referenced product link.

I’m having the same problem with a doorbell loosing connection and eventually shutting down. I bought 2 of the v2 doorbells 2 months ago, one for me and one for my daughter’s house. Mine is working fine, hers keeps disconnecting. We both have 16v 10va transformers. She had a wyze cam within 2 feet of the doorbell before, so I’m not suspecting a signal issue. Mine chimes my existing mechanical doorbell just fine, hers just buzzes intermittently, so I disconnected the mechanical doorbell and used her Alexa devices as the chime. Every time I do a reset of the doorbell it works for a couple days then dies. Any idea?

Well I think I’m done. I purchased the Wyze
Doorbell Cam V2 shortly after it was released. Ever since I’ve continually experienced the orange ring of death. Despite following all tips and tricks found on the forum, at most, I probably got 7 uninterrupted days of service; most times 2-3 days if I’m lucky. The firmware has been checked, the router is within 15 feet, the transformer has been replaced, band has been verified on 2.4, and the camera has been reset multiple times. Power down reset seems to work the best for me to restore operation but I’ve learned to expect it will only work for a short time before i need to repeat. I have other Wyze products on the network including two other cameras, power plugs, and bulbs which all work fine. I think it’s time to move on.

I get the orange ring, but my doorbell v2 is still connected, rings/notifies when the button is pressed and is recording fine. No idea why the orange light is on…

Worked fine for a good year, Now constant disconnects, and have to factory reset, pulling it off the wall.

Same problem for me. No reason why this should not work, but it just doesn’t. I have a dozen other things connected to the network that all work fine, but not this. I don’t have time to produce test this for wyze. Its going back and I will buy something that actually works.

Ughh this issue has been happening to me often lately. My other wyze cams work except the doorbell which blinks orange randomly. Could this be a recent firmware update? It’s been fine since launch til now. This is completely unacceptable of a company to expect customers to just factory reset every day…