Wyze Cam v3 Firmware Released - 12/28/20

Hi, everyone!

We hope that folks that were celebrating last week had a wonderful holiday. :slight_smile:

We just released Wyze Cam v3 firmware version! This update improves local storage stability, fixes a connectivity bug that caused streams to get stuck at step 3/3, and fixes a bug that caused a yellow spot in the video.

Read our Release Notes:


This firmware was on the V3 that I got on Thursday. So that may be why I never had the issues this supposedly fixed but there is a problem with the sound in the events tab

1 Like

This firmware fixes the 3 / 3 freezing issue, but now my portrait view of my group is broken. If I turn it to landscape it works fine. If I throw a v2 cam in the group it works in both but the v3’s show black.

I have tried deleting the group and rebuilding. I have also tried adding them to others.


Hey, it recognizes my SD card now, good job😀

I discovered an issue in this release involving the detection zone. If I resize the zone, the app freezes if it is short. Ie, vertical size is small.
If I make it bigger it works, but aligns itself to the bottom when I reopen it.
ticket number 84111

1 Like

Chao is aware of my sound issue so he’s looking into it.

After upgrading yesterday to this version, one of my v3 cams has a reddish tinge to the image during the daytime with night vision off. The other v3 was upgraded at the same time and is fine. I’ve tried rebooting a couple times and switching the night vision to on and off and auto.

I turned the camera off for 5 minutes and powered it back on using the app to power off/on. When it came back on, the image flickered between a normal color image in daytime to the reddish tinged image. Rebooted again and no change.

I have the same black screen preview in the groups after the v3 firmware upgrade. Drilling down into the camera works, but backing out to the group view displays the black preview again. It worked fine before the firmware update. Thanks in advance for squashing this bug.


Same problem with the black screen when viewed in groups. Was working good before


Same issue on Android 9

This is a display refresh issue. You can either select that camera and return, or if you can, scroll it out of view then back. Either way, the app is forced to refresh.

What it means, is trouble. Because Wyze neglected to test this rudimentary function. What other pieces of the code are untested?

What’s worse is that it only happens for V3 devices. It means there are several places in their base code that do exactly the same function. Where is code reuse and DRY (Don’t repeat yourself)?


Where is the physical download link on your website? My V3 cam will not update from the app and I need the actual firmware to be loaded onto the micro SD to update manually. It freezes everytime I go to update from the app.

Here is a link to the website with the available firmware downloads


Thanks Jason, but the latest firmware doesn’t even have a physical link

You are correct the latest one does not yet, but as soon as they do post it that is where it can be found.


I got the firmware upgrade on my v3. Been 2.5 days, so far so good. No hanging on the step 3/3. I also think the startup process to live stream is a bit faster too.

1 Like

Thank you

Thank you for getting this firmware out. The 3/3 issue was incredibly frustrating and this has fixed my problems.


LOL. Didn’t fix the issue with recognizing my SD card. Both v3 cameras have issues recognizing it. I have to restart them 3 times and then it will work. It is really sad. I had the same issue with v2 models previously. Such a royal pain. You’d think it would be pretty straight forward to see a memory card.