Wyze Cam v3 Connection Issues

Is anybody else having issues over the last few months with viewing their cameras off their home WIFI? My issue is that most of the time when I’m off my WIFI and I try and access either recordings or live video, connecting camera by secure channel never gets past (1/3). This happens sometimes when I’m on my home WIFI, but it seems to be all most all the time I’m off my home WIFI.

It seems I can fix this by selecting the camera to view, then selecting the settings, then selecting Restart. After doing this the camera comes back online for a little while. But, why should I have to do this anytime I want to view the camera or playback?

I have 2 of these cameras v3, both are running firmware version my app is listed as Wyze - Make Your Home Smarter (Beta) in the Play Store. Both cameras have Samsung Pro Endurance MicroSDXC Memory cards 128GB. 1 was replaced about a month ago, a little after these issues started, but hasn’t seemed to make a difference.

Has anybody experienced anything similar or is there anything I can try?


I personally have not experienced it. However, I have heard that individuals who are experience some weird connection issues, they simply log out of the app, power cycled the camera and then Logged back into the app.

This establishes a new connection and seems to correct some of the issues being experienced.

I’ll have to give that a try when i get home. I assume power cycling is unplugging the camera?

You are correct. Interrupting the power flow to the cam for at least 15 seconds, preferably 30 or more is power cycling.
A handy thing to do is accomplish this by plugging your cam into a smart plug so you can remotely or automatically do this when needed. All of my cams are set up this way and automatically power cycle twice a day and are easily done again when needed.

Only issues I have are the live view staying connected. It has no pattern of when it disconnects and there is a 25 second delay from when a incident occurs to when I see it on my “live feed”. I could be dead by then if someone broke in. This started with the 16th firmware update.

Thanks for the confirmation. I’ve done the smart plug for another item that had issues. But I replaced the item with one that worked right. If the power cycle works, I may just add the smart plugs to assist if i need to do it in the future.

1 Like

I have nine V3 cameras installed and they are flaky and unreliable on top of the dreadful quality audio. Just this evening they again began going offline and even after resets and app logouts, there is no reconnecting them. I think it’s likely a Wyze or AWS service issue again. Wyze never owns up to the issues and never compensates its client’s for any down time. I’ve written about three different issues to Wyze support (including a pre-sales fiasco), and the Wyze support never escalates (or at least no response ever comes back from the supposed escalation) and support overall is all but impotent beyond their few, scripted steps. The product is just unreliable as a security measure. It’s at best a toy. And the company is a customer’s top-five nightmare.

1 Like

I’ve had great luck with them up until a few months ago. Maybe you’re onto something. Maybe they switched something up with their servers and it’s causing issues with the v3 cameras.

I did the power cycle on both cameras & logged out of the app, then logged back in. It’ll be a couple days until I’m off my WIFi again, so i won’t know if it’s any better for a few days.

Some much for power cycling & signing out of the app. Today I tried twice since leaving my home WIFI & the 1st try both cameras worked, but on the 2nd try only 1 worked.

I had to do the restart in the app to get the 2nd camera working. It worked every time since the power cycle on my home WIFI. I’m guessing it’s their app.

Just checked back again, and both cameras won’t get past (1/3) in the loading process without resetting them through the app, then waiting a minute. So, basically logging out and power cycling didn’t do anything. I’m not sure what they’ve done on their end, but their app is making the cameras really unreliable.

I have a 3rd camera sitting in the box still (I bought it when I thought the camera might be the issue). But after this, why would I install it only to deal with these issues.

I’m guessing I have to wait to see if they put out an update and it fixes this issue. Does anybody know if there’s another app that works with these cameras?

1 Like

I am experiencing the same issue running same firmware. Sometimes need to completely power down and reboot to regain abiliry to view cam feeds, but i still receive events and notifications. Pretty frustrating

What i usually get is secure connection not available, trying to activate these cameras while away from home is a hit miss. I think before i go on our next vacation i will scrap my 7 Wyze cameras, dont need to be 2 thousand miles from home and find out nothing is working. Shame, have had wyze since their start and i just dont feel confidence anymore


I’ve had this issue now for months exactly as described by the OP. Can’t get past loading step 1 of 3 for most cameras and resetting usually works but at that point, it’s a huge hassle because the reset fixes the problem for only a few minutes before the issue arises again. I noticed the problem was introduced with the last firmware update. I regretted updating them all. I wish they’d revert.

The same here, constant loading then a connection problem issue, then you come back 15 minutes later and no issue. Leaves me doubting whether i want to rely on these to inform me of a break in while on vacation

1 Like

Ok, it’s not just me. I added my 3rd v3 that i had still in the box & it’s the same with all three.

So, their firmware seems to have made these cameras very unreliable when away from home.

Hopefully they’re aware, since that’s pretty important for a security camera to work when you’re away.

It may not be the firmware. Just found out my 3rd camera has older firmware & still had to be reset all day of i wanted to see anything.

It prompted me to update firmware when i got home and checked the video. I forgot to check the version, but it updated to I noticed it still has another update available After checking, my other cameras are on firmware So, appears to be a couple more.

From this I’m guessing it’s the app that they messed up. Just hoping they fix it soon because this is ridiculous.

It is not the firmware (or at least the many, many firmware updates that have been done to these cameras have had no impact on this noise issue).
It’s just incredulous that the company has no idea what’s going on with this issue (known about since at least 2020) and refuses to dedicate itself to resolving the issue with the urgency with which we the clients are asking.
I’ve already narrowed my selection of a replacement IP-based NVR and turret cameras with which I will be replacing all my Wyze V3 cams. If I don’t just sell them, I will relegate them to monitoring chipmunk and mouse activity on my property. They can’t be relied on for security or health and safety monitoring.

Yes, I too have consistent issues with connections and it is not my Wi-Fi as I have other devices rather away that maintain connections. Every one says power cycle. Well if not home, which is when I want the security camera on, I can’t power cycle! Oh, use a smart plug… Wyze smart plugs list connection too… Also not reliable. I am not going to run old dial type timers to power cycle my cameras every night. This is a ridiculous problem that should be fixed.

1 Like

Power cycle hahahahaha! That is the standard go to. Exactly how many times do you have to power cycle? It doesn’t work, so its time to find the real problem. I have had another wyze camera since 2020 and never had any issues with it. Then 3 months ago, I buy one for outside and then it’s working great, then the disaster on the 16th! Why aren’t your “programmers” looking at the update on the 16 vs. the previous one to see where they screwed up. Sounds really simple to me, and also, hire programmers that are experienced.


I’m having the same problems, I’m now changing all of my cameras to TP link Tapo