Repeated "Connection Failed" on Cam V2 running firmware

After upgrading firmware on my V2, I’m now constantly getting disconnected from it in the Wyzecam App. I’ve tried clearing cache, uninstalled and reinstalled the App, and power cycled the cam. Seeing regular disconnections from the camera every few minutes. Seems to be a lot less stable after the firmware updates. Anyone else seeing this behavior? Wyzecam App is running on a Samsung Galaxy S5 running Android v6.01.

I had a similar issue with v3 after the update. I tried restarting the device and my router several times but that didn’t work. I checked my SD card, which was nearly full, so I powered down the camera, pulled the sd card from the device, copied the files to my desktop, reinserted the SD card, reformatted it, hit sync and all is working as I desire. I hope this helps and that your issue is simple to solve. Good luck!

1 Like

Thanks Khrissy, I’ll try reformatting the card to see if that helps.

Yup, I’m seeing the same thing. My app said there was a new firmware upgrade, and like a dummy, I went ahead and started the upgrade with 1 camera only to experience what you said. Then the app says, there is a known problem with a recent upgrade. The workaround they provided of course didn’t do anything. I don’t understand why Wyze keeps pushing these updates knowing they don’t work. What I’m learning from this is if there’s a firmware upgrade, don’t do it. I’m stuck now with a non-functioning camera.
Advice to Wyze:

  1. Test the firmware first before deploying it. This is basic.
  2. Stop pushing the firmware updates as soon as you know it has a problem.
  3. Provide a mechanism for restoring a previous firmware version.

Wyze decided Android 7 is minimum.

FYI. Reformatting my microSD card and rebooting the camera seems to have solved the issue. I am rarely seeing the issue now (no more than I was seeing it before the upgrade.)

Thanks for the info. I’ve tried turning the camera off, back on; restarting the camera; unplugging the power cord and plugging it back in. Camera operation is ok except for the playback lol, so the firmware can no longer talk to the SD, it’s not backward compatible. Not very good engineering standards. Issue for me is that I don’t want to erase my SD; there’s stuff on there that I may need and want to keep for a while, and it’s a hassle for me to take the SD out because of the camera location.

** Update ** Talked to support, Updating the app solved the problem. Didn’t need to reformat the uSD or do anything else.